aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-06-23 20:46:21 +0800
committerdhn <dhn@FreeBSD.org>2011-06-23 20:46:21 +0800
commit12577e9091c667e242a5c414030f4535f23f44e1 (patch)
treeb2bee0ac639b0af12f1c3a95b1cc52e851b229d7 /net
parent83ff965870b9b3245c1b177f7dbf582e2f057157 (diff)
downloadfreebsd-ports-gnome-12577e9091c667e242a5c414030f4535f23f44e1.tar.gz
freebsd-ports-gnome-12577e9091c667e242a5c414030f4535f23f44e1.tar.zst
freebsd-ports-gnome-12577e9091c667e242a5c414030f4535f23f44e1.zip
SSSPL - Simple Socks Server for Perl
SSS is a simple socks server written in perl that implements the SOCKS v5 protocol. WWW: http://sourceforge.net/projects/ssspl/ PR: ports/156398 Submitted by: Hung-Yi Chen <gaod@hychen.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ssspl/Makefile34
-rw-r--r--net/ssspl/distinfo2
-rw-r--r--net/ssspl/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index abebf52cfc14..318fa779718f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1043,6 +1043,7 @@
SUBDIR += ssltunnel-client
SUBDIR += ssltunnel-server
SUBDIR += ssmping
+ SUBDIR += ssspl
SUBDIR += ssvnc
SUBDIR += stone
SUBDIR += stund
diff --git a/net/ssspl/Makefile b/net/ssspl/Makefile
new file mode 100644
index 000000000000..8f74255b6ea2
--- /dev/null
+++ b/net/ssspl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ssspl
+# Date created: 2011-04-02
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssspl
+PORTVERSION= 0.1
+CATEGORIES= net perl5
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/sss.pl%20v${PORTVERSION}/
+DISTNAME= sss
+EXTRACT_SUFX= .pl
+
+MAINTAINER= gaod@hychen.org
+COMMENT= A Simple Socks Server for Perl
+
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/sss.pl
+STRIP=
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ ${CHMOD} +x ${WRKSRC}/${DISTFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTFILES} ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/net/ssspl/distinfo b/net/ssspl/distinfo
new file mode 100644
index 000000000000..cdd5734a7af3
--- /dev/null
+++ b/net/ssspl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sss.pl) = 71c844853aaaa81709a597cb5f4562ed5e4368737ea4f2f7077a31e71a7798e5
+SIZE (sss.pl) = 13293
diff --git a/net/ssspl/pkg-descr b/net/ssspl/pkg-descr
new file mode 100644
index 000000000000..534c74064734
--- /dev/null
+++ b/net/ssspl/pkg-descr
@@ -0,0 +1,6 @@
+SSSPL - Simple Socks Server for Perl
+
+SSS is a simple socks server written in perl that
+implements the SOCKS v5 protocol.
+
+WWW: http://sourceforge.net/projects/ssspl/