aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-28 05:47:35 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-28 05:47:35 +0800
commit14065fd88181ed3a9d86cfc1fce2299d174899b7 (patch)
tree2a15b58178b89fa846f36702cfd75cf1a38d7191 /net
parent94cadad06c5fa6e5b92e262ec6ddd52efb4b1e29 (diff)
downloadfreebsd-ports-gnome-14065fd88181ed3a9d86cfc1fce2299d174899b7.tar.gz
freebsd-ports-gnome-14065fd88181ed3a9d86cfc1fce2299d174899b7.tar.zst
freebsd-ports-gnome-14065fd88181ed3a9d86cfc1fce2299d174899b7.zip
Add the KDE metaports
* add multimedia/dragon (was missing) * add the meta ports for the categories * add x11/kde5 [yeah, we know, there technically is no "KDE 5"]
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/kdenetwork/Makefile32
-rw-r--r--net/kdenetwork/pkg-descr1
3 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 803a9a71578f..06378a4e1654 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -319,6 +319,7 @@
SUBDIR += kcalutils
SUBDIR += kcontacts
SUBDIR += kdav
+ SUBDIR += kdenetwork
SUBDIR += kdenetwork-filesharing
SUBDIR += kdenetwork-kde4
SUBDIR += kdenetwork-filesharing-kde4
diff --git a/net/kdenetwork/Makefile b/net/kdenetwork/Makefile
new file mode 100644
index 000000000000..1497bcd83ddb
--- /dev/null
+++ b/net/kdenetwork/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= kdenetwork
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE Network applications (meta port)
+
+USES= kde:5 metaport
+USE_QT5= #
+
+OPTIONS_DEFINE= FILESHARING KGET KRDC KRFB
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NKOPETE}
+
+FILESHARING_DESC= Network file sharing via Samba
+FILESHARING_RUN_DEPENDS= kdenetwork-filesharing>=${KDE_APPLICATIONS_VERSION}:net/kdenetwork-filesharing
+
+KGET_DESC= Download manager
+KGET_RUN_DEPENDS= kget>=${KDE_APPLICATIONS_VERSION}:net/kget
+
+# Kopete will be added with the 18.04 update
+# KOPETE_DESC= Multi-protocol instant messenger
+# KOPETE_RUN_DEPENDS= kopete>=${KDE_APPLICATIONS_VERSION}:net-im/kopete
+
+KRDC_DESC= RDP and VNC client
+KRDC_RUN_DEPENDS= krdc>=${KDE_APPLICATIONS_VERSION}:net/krdc
+
+KRFB_DESC= Desktop Sharing (VNC server)
+KRFB_RUN_DEPENDS= krfb>=${KDE_APPLICATIONS_VERSION}:net/krfb
+
+.include <bsd.port.mk>
diff --git a/net/kdenetwork/pkg-descr b/net/kdenetwork/pkg-descr
new file mode 100644
index 000000000000..a74871663977
--- /dev/null
+++ b/net/kdenetwork/pkg-descr
@@ -0,0 +1 @@
+KDE Network Metapackage.