aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-09-27 20:50:34 +0800
committerroam <roam@FreeBSD.org>2006-09-27 20:50:34 +0800
commit14ad4515694955ed2730a2f0d54c46152503e5cc (patch)
treed000e84140c559b0adadefa1198ddb1ffad00f5f /net
parent6d4b421f93dae9518da91b56607868a61cbceb2e (diff)
downloadfreebsd-ports-gnome-14ad4515694955ed2730a2f0d54c46152503e5cc.tar.gz
freebsd-ports-gnome-14ad4515694955ed2730a2f0d54c46152503e5cc.tar.zst
freebsd-ports-gnome-14ad4515694955ed2730a2f0d54c46152503e5cc.zip
Remove the mistaken run-dependency on libnet, since it causes conflicts
in dependent ports. Also, reinstitute the choice between libnet-1.0 and 1.1, since the dependent ports seem to actually like libnet-1.0 better. PR: 103554 Submitted by: arved
Diffstat (limited to 'net')
-rw-r--r--net/libnids/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 8a64167ed394..76103a1eb6e7 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libnids
PORTVERSION= 1.21
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +16,7 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Network monitoring library with TCP/IP reassembly
OPTIONS= LIBNET "Include code requiring libnet" ON \
+ LIBNET10 "Use the old libnet-1.0.x version" ON \
GLIB2 "Use GLIB2 for multiprocessing support" ON
GNU_CONFIGURE= yes
@@ -27,8 +29,11 @@ MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_LIBNET)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
-RUN_DEPENDS+= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+.if !defined(WITHOUT_LIBNET10)
+BUILD_DEPENDS+= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+.else
+BUILD_DEPENDS+= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+.endif
.else
CONFIGURE_ARGS+= --disable-libnet
.endif