aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-02 15:14:17 +0800
committerkrion <krion@FreeBSD.org>2003-10-02 15:14:17 +0800
commit17736b9a98cf777d3e9f868b04f719ae0c4d8d5e (patch)
tree1024f9c155862b88369553dfaec5868f64b21cf5 /net
parent8df3ddca9ce58f43c3c7d13226696e864f1979bc (diff)
downloadfreebsd-ports-gnome-17736b9a98cf777d3e9f868b04f719ae0c4d8d5e.tar.gz
freebsd-ports-gnome-17736b9a98cf777d3e9f868b04f719ae0c4d8d5e.tar.zst
freebsd-ports-gnome-17736b9a98cf777d3e9f868b04f719ae0c4d8d5e.zip
Add p5-Jabber-Connection 0.04, jabber Perl library for
client/component connectivity. PR: 57478 Submitted by: Lars Eggert
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Jabber-Connection/Makefile27
-rw-r--r--net/p5-Jabber-Connection/distinfo1
-rw-r--r--net/p5-Jabber-Connection/pkg-descr7
-rw-r--r--net/p5-Jabber-Connection/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5c2a0a329b45..f54a5b9b2a52 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -412,6 +412,7 @@
SUBDIR += p5-IO-Interface
SUBDIR += p5-IO-Socket-Multicast
SUBDIR += p5-JUNOScript
+ SUBDIR += p5-Jabber-Connection
SUBDIR += p5-Mon
SUBDIR += p5-Net
SUBDIR += p5-Net-AIM
diff --git a/net/p5-Jabber-Connection/Makefile b/net/p5-Jabber-Connection/Makefile
new file mode 100644
index 000000000000..46bbb62aee01
--- /dev/null
+++ b/net/p5-Jabber-Connection/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Jabber-Connection
+# Date created: 01 October 2003
+# Whom: Lars Eggert
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jabber-Connection
+PORTVERSION= 0.04
+CATEGORIES= net perl5
+#MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= Jabber
+MASTER_SITES= http://www.pipetree.com/jabber/jabberconnection/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= larse@isi.edu
+COMMENT= Jabber Perl library for client/component connectivity
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Jabber::Connection.3 Jabber::NS.3 Jabber::NodeFactory.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Jabber-Connection/distinfo b/net/p5-Jabber-Connection/distinfo
new file mode 100644
index 000000000000..d8d011f167cf
--- /dev/null
+++ b/net/p5-Jabber-Connection/distinfo
@@ -0,0 +1 @@
+MD5 (Jabber-Connection-0.04.tar.gz) = ab9a85df88637f6bc542a38ac0501d8e
diff --git a/net/p5-Jabber-Connection/pkg-descr b/net/p5-Jabber-Connection/pkg-descr
new file mode 100644
index 000000000000..ded4fcdf7811
--- /dev/null
+++ b/net/p5-Jabber-Connection/pkg-descr
@@ -0,0 +1,7 @@
+Jabber::Connection
+
+Jabber::Connection is a new Perl library for Jabber that provides
+the basic features for client and component connectivity, plus an
+xmlnode-like library for flexibly manipulating Jabber elements.
+
+WWW: http://www.pipetree.com/jabber/jabberconnection/
diff --git a/net/p5-Jabber-Connection/pkg-plist b/net/p5-Jabber-Connection/pkg-plist
new file mode 100644
index 000000000000..cfb62bb10f1e
--- /dev/null
+++ b/net/p5-Jabber-Connection/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Jabber/Connection.pm
+%%SITE_PERL%%/Jabber/NS.pm
+%%SITE_PERL%%/Jabber/NodeFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Connection/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Connection
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber
+@dirrm %%SITE_PERL%%/Jabber