aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
committerMartin Matuska <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /net
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadfreebsd-ports-gnome-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
freebsd-ports-gnome-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.zst
freebsd-ports-gnome-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Diffstat (limited to 'net')
-rw-r--r--net/p5-AnyEvent-Twitter/Makefile14
-rw-r--r--net/p5-Net-Amazon/Makefile11
-rw-r--r--net/p5-Net-GrowlClient/Makefile12
-rw-r--r--net/p5-Net-Twitter/Makefile14
-rw-r--r--net/p5-OAuth-Lite/Makefile10
-rw-r--r--net/radiator/Makefile10
-rw-r--r--net/v6eval/Makefile9
7 files changed, 56 insertions, 24 deletions
diff --git a/net/p5-AnyEvent-Twitter/Makefile b/net/p5-AnyEvent-Twitter/Makefile
index 92aee770011b..ca0f2bfa64fb 100644
--- a/net/p5-AnyEvent-Twitter/Makefile
+++ b/net/p5-AnyEvent-Twitter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= AnyEvent-Twitter
PORTVERSION= 0.51
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,16 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sahil@FreeBSD.org
COMMENT= Implementation of the Twitter API for AnyEvent
-BUILD_DEPENDS= p5-AnyEvent>=3.5:${PORTSDIR}/devel/p5-AnyEvent \
+RUN_DEPENDS= p5-AnyEvent>=3.5:${PORTSDIR}/devel/p5-AnyEvent \
p5-AnyEvent-HTTP>=0:${PORTSDIR}/www/p5-AnyEvent-HTTP \
- p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
p5-Net-OAuth>=0:${PORTSDIR}/net/p5-Net-OAuth \
p5-Net-Twitter-Lite>=0:${PORTSDIR}/net/p5-Net-Twitter-Lite
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= AnyEvent::Twitter.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Amazon/Makefile b/net/p5-Net-Amazon/Makefile
index e3c5b6d14db5..382fcce1c74f 100644
--- a/net/p5-Net-Amazon/Makefile
+++ b/net/p5-Net-Amazon/Makefile
@@ -14,12 +14,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Framework for accessing amazon.com via SOAP and XML/HTTP
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,7 +27,11 @@ PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500805
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
.endif
.include <bsd.port.post.mk>
diff --git a/net/p5-Net-GrowlClient/Makefile b/net/p5-Net-GrowlClient/Makefile
index 1b85a762a39b..5a6acb014bc1 100644
--- a/net/p5-Net-GrowlClient/Makefile
+++ b/net/p5-Net-GrowlClient/Makefile
@@ -16,11 +16,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= markun@onohara.to
COMMENT= Perl implementation of Growl Network Notification Protocol
-BUILD_DEPENDS= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-RUN_DEPENDS= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-
PERL_CONFIGURE= yes
MAN3= Net::GrowlClient.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Twitter/Makefile b/net/p5-Net-Twitter/Makefile
index 7d9e29f56f67..24abdcf96780 100644
--- a/net/p5-Net-Twitter/Makefile
+++ b/net/p5-Net-Twitter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Twitter
PORTVERSION= 3.13007
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Perl interface to twitter.com
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Data/Visitor/Callback.pm:${PORTSDIR}/devel/p5-Data-Visitor \
${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
${SITE_PERL}/MooseX/AttributeHelpers.pm:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
@@ -24,7 +24,7 @@ BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/namespace/autoclean.pm:${PORTSDIR}/devel/p5-namespace-autoclean \
${SITE_PERL}/Net/OAuth/Simple.pm:${PORTSDIR}/net/p5-Net-OAuth-Simple \
${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -43,4 +43,10 @@ MAN3= Net::Twitter.3 Net::Twitter::Search.3 Net::Identica.3 \
Net::Twitter::Role::SimulateCursors.3 \
Net::Twitter::Role::WrapError.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-OAuth-Lite/Makefile b/net/p5-OAuth-Lite/Makefile
index 5fcd1416e7cb..ee483f44f060 100644
--- a/net/p5-OAuth-Lite/Makefile
+++ b/net/p5-OAuth-Lite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= OAuth-Lite
PORTVERSION= 1.27
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/L/LY/LYOKATO
@@ -21,7 +22,6 @@ RUN_DEPENDS= \
p5-Class-ErrorHandler>=0.01:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-Crypt-OpenSSL-RSA>=0.25:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
p5-Crypt-OpenSSL-Random>=0.04:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random \
- p5-Digest-SHA>=5.45:${PORTSDIR}/security/p5-Digest-SHA \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
p5-List-MoreUtils>=0.21:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-UNIVERSAL-require>=0.11:${PORTSDIR}/devel/p5-UNIVERSAL-require \
@@ -46,4 +46,10 @@ MAN3= OAuth::Lite.3 \
OAuth::Lite::Token.3 \
OAuth::Lite::Util.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/radiator/Makefile b/net/radiator/Makefile
index 37951894127e..7ee0c058bbae 100644
--- a/net/radiator/Makefile
+++ b/net/radiator/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Radiator
PORTVERSION= 4.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= # fetch manually
EXTRACT_SUFX= .tgz
@@ -17,14 +18,17 @@ COMMENT= Radiator Radius Server by Open System Consultants
OPTIONS= MYSQL "MySQL Support" off
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
RESTRICTED= "Commercial software"
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTFILES})
IGNORE= will not be automatically fetched due to licensing\
restrictions. You MUST manually fetch the UNIX version after\
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 4dbb1f72c5b3..721807745a4c 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -7,7 +7,7 @@
PORTNAME= v6eval
PORTVERSION= 3.0.1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tahi.org/release/v6eval/
@@ -15,8 +15,7 @@ MASTER_SITES= http://www.tahi.org/release/v6eval/
MAINTAINER= Yukiyo.Akisada@jp.yokogawa.com
COMMENT= IPv6 Conformance Test Platform
-RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
USE_PERL5= yes
USE_OPENSSL= yes
@@ -30,6 +29,10 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
.if ${OSVERSION} > 900007
BROKEN= fails to build with new utmpx
.endif