aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-04-16 12:16:49 +0800
committerwill <will@FreeBSD.org>2000-04-16 12:16:49 +0800
commit18311ed48477507832b24eb91d77f146652cd78e (patch)
tree7c3045bb8bc9985b43d4cf338745e0f7655a7761 /net
parent110300f9341809ff92eb65095a09e5c7a649f28e (diff)
downloadfreebsd-ports-gnome-18311ed48477507832b24eb91d77f146652cd78e.tar.gz
freebsd-ports-gnome-18311ed48477507832b24eb91d77f146652cd78e.tar.zst
freebsd-ports-gnome-18311ed48477507832b24eb91d77f146652cd78e.zip
Add AMCL, which is a GTK-based MUD client.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/amcl/Makefile28
-rw-r--r--net/amcl/distinfo1
-rw-r--r--net/amcl/pkg-comment1
-rw-r--r--net/amcl/pkg-descr9
-rw-r--r--net/amcl/pkg-plist1
-rw-r--r--net/gnome-mud/Makefile28
-rw-r--r--net/gnome-mud/distinfo1
-rw-r--r--net/gnome-mud/pkg-comment1
-rw-r--r--net/gnome-mud/pkg-descr9
-rw-r--r--net/gnome-mud/pkg-plist1
11 files changed, 81 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index cc31c1c78d00..ed1827b6c60d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -3,6 +3,7 @@
SUBDIR += SSLtelnet
SUBDIR += adns
+ SUBDIR += amcl
SUBDIR += archie
SUBDIR += archie.el
SUBDIR += argus
diff --git a/net/amcl/Makefile b/net/amcl/Makefile
new file mode 100644
index 000000000000..fcabb71289d0
--- /dev/null
+++ b/net/amcl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: amcl
+# Date created: 15 Apr 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= amcl
+PORTVERSION= 0.7.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/amcl/ \
+ http://www.localhost.nu/apps/amcl/tars/ \
+ http://amcl.alliances.org/tars/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/muds
+DISTNAME= ${PORTNAME}-${PORTVERSION}pl1
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= GTK_CONFIG="${GTK_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/net/amcl/distinfo b/net/amcl/distinfo
new file mode 100644
index 000000000000..0bd27be3f46d
--- /dev/null
+++ b/net/amcl/distinfo
@@ -0,0 +1 @@
+MD5 (amcl-0.7.0pl1.tar.gz) = 6e88daf39a3d2fbe4fa61f375df51031
diff --git a/net/amcl/pkg-comment b/net/amcl/pkg-comment
new file mode 100644
index 000000000000..81f8a2589abb
--- /dev/null
+++ b/net/amcl/pkg-comment
@@ -0,0 +1 @@
+GTK-based MUD client with triggers, aliases, colors, etc.
diff --git a/net/amcl/pkg-descr b/net/amcl/pkg-descr
new file mode 100644
index 000000000000..6852b4dc4b26
--- /dev/null
+++ b/net/amcl/pkg-descr
@@ -0,0 +1,9 @@
+AMCL is short for Another MUD CLient. It is based
+on GTK, and offers many features, such as full support
+for ANSI colors, aliases, command history, triggers,
+automapping, multiple connections, and so forth.
+
+WWW: http://www.localhost.nu/apps/amcl/
+Author: Robin Ericsson <lobbin@localhost.nu>
+
+- Will <andrews@technologist.com>
diff --git a/net/amcl/pkg-plist b/net/amcl/pkg-plist
new file mode 100644
index 000000000000..ccbc437e24d8
--- /dev/null
+++ b/net/amcl/pkg-plist
@@ -0,0 +1 @@
+bin/amcl
diff --git a/net/gnome-mud/Makefile b/net/gnome-mud/Makefile
new file mode 100644
index 000000000000..fcabb71289d0
--- /dev/null
+++ b/net/gnome-mud/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: amcl
+# Date created: 15 Apr 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= amcl
+PORTVERSION= 0.7.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/amcl/ \
+ http://www.localhost.nu/apps/amcl/tars/ \
+ http://amcl.alliances.org/tars/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/muds
+DISTNAME= ${PORTNAME}-${PORTVERSION}pl1
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= GTK_CONFIG="${GTK_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/net/gnome-mud/distinfo b/net/gnome-mud/distinfo
new file mode 100644
index 000000000000..0bd27be3f46d
--- /dev/null
+++ b/net/gnome-mud/distinfo
@@ -0,0 +1 @@
+MD5 (amcl-0.7.0pl1.tar.gz) = 6e88daf39a3d2fbe4fa61f375df51031
diff --git a/net/gnome-mud/pkg-comment b/net/gnome-mud/pkg-comment
new file mode 100644
index 000000000000..81f8a2589abb
--- /dev/null
+++ b/net/gnome-mud/pkg-comment
@@ -0,0 +1 @@
+GTK-based MUD client with triggers, aliases, colors, etc.
diff --git a/net/gnome-mud/pkg-descr b/net/gnome-mud/pkg-descr
new file mode 100644
index 000000000000..6852b4dc4b26
--- /dev/null
+++ b/net/gnome-mud/pkg-descr
@@ -0,0 +1,9 @@
+AMCL is short for Another MUD CLient. It is based
+on GTK, and offers many features, such as full support
+for ANSI colors, aliases, command history, triggers,
+automapping, multiple connections, and so forth.
+
+WWW: http://www.localhost.nu/apps/amcl/
+Author: Robin Ericsson <lobbin@localhost.nu>
+
+- Will <andrews@technologist.com>
diff --git a/net/gnome-mud/pkg-plist b/net/gnome-mud/pkg-plist
new file mode 100644
index 000000000000..ccbc437e24d8
--- /dev/null
+++ b/net/gnome-mud/pkg-plist
@@ -0,0 +1 @@
+bin/amcl