aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-05-12 21:37:17 +0800
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-05-12 21:37:17 +0800
commit1935804eecc0b8a6e91ce1e45a3d6a6d079b3db1 (patch)
treef88220a6d88a57eed5e024f9220f88dd88c673f0 /net
parente955b725a06224ebf75e752fe40e1f4c468826bc (diff)
downloadfreebsd-ports-gnome-1935804eecc0b8a6e91ce1e45a3d6a6d079b3db1.tar.gz
freebsd-ports-gnome-1935804eecc0b8a6e91ce1e45a3d6a6d079b3db1.tar.zst
freebsd-ports-gnome-1935804eecc0b8a6e91ce1e45a3d6a6d079b3db1.zip
Add libosip2 port version 4.0.0, that is API incompatible with version
in net/libosip. This patch was submitted as an update against net/libosip but it was decided to add it as a separate port. oSIP is an implementation of SIP. SIP stands for the Session Initiation Protocol and is described by the rfc2543 (soon to be deprecated by latest revisions). This library aims to provide multimedia and telecom software developers an easy and powerful interface to initiate and control SIP based sessions in their applications. SIP is a open standard replacement from IETF for H323. WWW: http://www.gnu.org/software/osip/ PR: 175104 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libosip2/Makefile22
-rw-r--r--net/libosip2/distinfo2
-rw-r--r--net/libosip2/pkg-descr9
-rw-r--r--net/libosip2/pkg-plist55
5 files changed, 89 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f8fb23192ad8..91429f6c9f95 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -335,6 +335,7 @@
SUBDIR += libopennet
SUBDIR += liboping
SUBDIR += libosip
+ SUBDIR += libosip2
SUBDIR += libpcap
SUBDIR += libpcapnav
SUBDIR += libproxy
diff --git a/net/libosip2/Makefile b/net/libosip2/Makefile
new file mode 100644
index 000000000000..c25a57b162f6
--- /dev/null
+++ b/net/libosip2/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= libosip2
+PORTVERSION= 4.0.0
+CATEGORIES= net
+MASTER_SITES= GNU/osip
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Low layer of SIP implementation
+
+LICENSE= LGPL21
+
+CONFIGURE_ARGS= --disable-debug --disable-trace
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+USES= pathfix pkgconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "/^SUBDIRS/s| help | |g" ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net/libosip2/distinfo b/net/libosip2/distinfo
new file mode 100644
index 000000000000..f48bb34a33a5
--- /dev/null
+++ b/net/libosip2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libosip2-4.0.0.tar.gz) = bb2d228a41750fab397480002b0865f305f83a3840b1aa84851593593491b015
+SIZE (libosip2-4.0.0.tar.gz) = 644958
diff --git a/net/libosip2/pkg-descr b/net/libosip2/pkg-descr
new file mode 100644
index 000000000000..240d294f3ae5
--- /dev/null
+++ b/net/libosip2/pkg-descr
@@ -0,0 +1,9 @@
+oSIP is an implementation of SIP.
+
+SIP stands for the Session Initiation Protocol and is described by the
+rfc2543 (soon to be deprecated by latest revisions). This library aims
+to provide multimedia and telecom software developers an easy and powerful
+interface to initiate and control SIP based sessions in their applications.
+SIP is a open standard replacement from IETF for H323.
+
+WWW: http://www.gnu.org/software/osip/
diff --git a/net/libosip2/pkg-plist b/net/libosip2/pkg-plist
new file mode 100644
index 000000000000..c8d8112ccd18
--- /dev/null
+++ b/net/libosip2/pkg-plist
@@ -0,0 +1,55 @@
+include/osip2/osip.h
+include/osip2/osip_condv.h
+include/osip2/osip_dialog.h
+include/osip2/osip_fifo.h
+include/osip2/osip_mt.h
+include/osip2/osip_time.h
+include/osipparser2/headers/osip_accept.h
+include/osipparser2/headers/osip_accept_encoding.h
+include/osipparser2/headers/osip_accept_language.h
+include/osipparser2/headers/osip_alert_info.h
+include/osipparser2/headers/osip_allow.h
+include/osipparser2/headers/osip_authentication_info.h
+include/osipparser2/headers/osip_authorization.h
+include/osipparser2/headers/osip_call_id.h
+include/osipparser2/headers/osip_call_info.h
+include/osipparser2/headers/osip_contact.h
+include/osipparser2/headers/osip_content_disposition.h
+include/osipparser2/headers/osip_content_encoding.h
+include/osipparser2/headers/osip_content_length.h
+include/osipparser2/headers/osip_content_type.h
+include/osipparser2/headers/osip_cseq.h
+include/osipparser2/headers/osip_error_info.h
+include/osipparser2/headers/osip_from.h
+include/osipparser2/headers/osip_header.h
+include/osipparser2/headers/osip_mime_version.h
+include/osipparser2/headers/osip_proxy_authenticate.h
+include/osipparser2/headers/osip_proxy_authentication_info.h
+include/osipparser2/headers/osip_proxy_authorization.h
+include/osipparser2/headers/osip_record_route.h
+include/osipparser2/headers/osip_route.h
+include/osipparser2/headers/osip_to.h
+include/osipparser2/headers/osip_via.h
+include/osipparser2/headers/osip_www_authenticate.h
+include/osipparser2/osip_body.h
+include/osipparser2/osip_const.h
+include/osipparser2/osip_headers.h
+include/osipparser2/osip_list.h
+include/osipparser2/osip_md5.h
+include/osipparser2/osip_message.h
+include/osipparser2/osip_parser.h
+include/osipparser2/osip_port.h
+include/osipparser2/osip_uri.h
+include/osipparser2/sdp_message.h
+lib/libosip2.a
+lib/libosip2.la
+lib/libosip2.so
+lib/libosip2.so.10
+lib/libosipparser2.a
+lib/libosipparser2.la
+lib/libosipparser2.so
+lib/libosipparser2.so.10
+libdata/pkgconfig/libosip2.pc
+@dirrm include/osipparser2/headers
+@dirrm include/osipparser2
+@dirrm include/osip2