aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-07 16:50:24 +0800
committerAndrej Zverev <az@FreeBSD.org>2012-06-07 16:50:24 +0800
commit1c72794ad2f4bbc49e32a86fe0029a3fda97362f (patch)
treeaec54ceade509a68632cc7c44555bb3e3c8c4b0a /net
parent8ee731ffd46a98d8a56bcebc809ddacec633480a (diff)
downloadfreebsd-ports-gnome-1c72794ad2f4bbc49e32a86fe0029a3fda97362f.tar.gz
freebsd-ports-gnome-1c72794ad2f4bbc49e32a86fe0029a3fda97362f.tar.zst
freebsd-ports-gnome-1c72794ad2f4bbc49e32a86fe0029a3fda97362f.zip
- Remove SITE_PERL from *_DEPENDS
Diffstat (limited to 'net')
-rw-r--r--net/p5-Event-tcp/Makefile4
-rw-r--r--net/p5-Net-Address-IPv4-Local/Makefile2
-rw-r--r--net/p5-Net-SFTP/Makefile2
-rw-r--r--net/p5-Net-Traceroute-PurePerl/Makefile2
-rw-r--r--net/p5-SOAP/Makefile4
-rw-r--r--net/p5-URI-OpenURL/Makefile2
6 files changed, 8 insertions, 8 deletions
diff --git a/net/p5-Event-tcp/Makefile b/net/p5-Event-tcp/Makefile
index a97936ad87de..9054cb91fe22 100644
--- a/net/p5-Event-tcp/Makefile
+++ b/net/p5-Event-tcp/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Glue code to build client-server style TCP-based services
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
- ${SITE_PERL}/${PERL_ARCH}/Ioctl.pm:${PORTSDIR}/devel/p5-Ioctl
+BUILD_DEPENDS= p5-Event>=0:${PORTSDIR}/devel/p5-Event \
+ p5-Ioctl>=0:${PORTSDIR}/devel/p5-Ioctl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Address-IPv4-Local/Makefile b/net/p5-Net-Address-IPv4-Local/Makefile
index 856ca4a2f3ee..bad47fac9a2d 100644
--- a/net/p5-Net-Address-IPv4-Local/Makefile
+++ b/net/p5-Net-Address-IPv4-Local/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A class for discovering the local system's IP address
-BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error
+BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Net::Address::IPv4::Local.3
diff --git a/net/p5-Net-SFTP/Makefile b/net/p5-Net-SFTP/Makefile
index 54e202ac76f4..b86ca556fe3c 100644
--- a/net/p5-Net-SFTP/Makefile
+++ b/net/p5-Net-SFTP/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module implementing Secure File Transfer Protocol client
-BUILD_DEPENDS= ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+BUILD_DEPENDS= p5-Net-SSH-Perl>=0:${PORTSDIR}/net/p5-Net-SSH-Perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Traceroute-PurePerl/Makefile b/net/p5-Net-Traceroute-PurePerl/Makefile
index 144bdd72f359..c920aac61106 100644
--- a/net/p5-Net-Traceroute-PurePerl/Makefile
+++ b/net/p5-Net-Traceroute-PurePerl/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Traceroute(1) functionality in perl via raw sockets
-BUILD_DEPENDS= ${SITE_PERL}/Net/Traceroute.pm:${PORTSDIR}/net/p5-Net-Traceroute
+BUILD_DEPENDS= p5-Net-Traceroute>=0:${PORTSDIR}/net/p5-Net-Traceroute
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/net/p5-SOAP/Makefile b/net/p5-SOAP/Makefile
index 2aca2177236f..83856ac52882 100644
--- a/net/p5-SOAP/Makefile
+++ b/net/p5-SOAP/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules providing an API to the Simple Object Access Protocol
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= p5-SOAP-Lite-[0-9]*
diff --git a/net/p5-URI-OpenURL/Makefile b/net/p5-URI-OpenURL/Makefile
index deb0151878b8..7bd4e62610fc 100644
--- a/net/p5-URI-OpenURL/Makefile
+++ b/net/p5-URI-OpenURL/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Parse and construct OpenURL's (NISO Z39.88-2004)
-BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= URI::OpenURL.3