aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-04-19 01:39:09 +0800
committerdelphij <delphij@FreeBSD.org>2012-04-19 01:39:09 +0800
commit1cf840cbd490f1baf63150c3f497192bcb5604e5 (patch)
treef0262ccef5a289f8886e6b7e51a085e3a20e86a5 /net
parentf5d861e3dea3c8e97d39d03ab93ffea097cf6591 (diff)
downloadfreebsd-ports-gnome-1cf840cbd490f1baf63150c3f497192bcb5604e5.tar.gz
freebsd-ports-gnome-1cf840cbd490f1baf63150c3f497192bcb5604e5.tar.zst
freebsd-ports-gnome-1cf840cbd490f1baf63150c3f497192bcb5604e5.zip
Update to 2.4.30.
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile10
-rw-r--r--net/openldap24-server/distinfo4
-rw-r--r--net/openldap24-server/files/manpages4
-rw-r--r--net/openldap24-server/files/patch-servers__slapd__inet_ntoa.diff70
-rw-r--r--net/openldap24-server/files/patch-shlib-version18
-rw-r--r--net/openldap24-server/pkg-plist27
6 files changed, 38 insertions, 95 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 61ba53ee80bf..76fb128f8b87 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-DISTVERSION= 2.4.26
+DISTVERSION= 2.4.30
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -38,6 +38,7 @@ UNIQUENAME?= ${PKGNAMEPREFIX}openldap24
LATEST_LINK?= ${UNIQUENAME}${PKGNAMESUFFIX}
USE_OPENSSL= yes
MAKE_JOBS_SAFE= yes
+USE_AUTOTOOLS= libtool
WANT_OPENLDAP_VER?= 24
.if ${WANT_OPENLDAP_VER} != 24
@@ -45,7 +46,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 2
+PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 8
OPTIONS= SASL "With (Cyrus) SASL2 support" off \
@@ -134,8 +135,6 @@ CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif
-USE_AUTOTOOLS= libtool
-
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -156,6 +155,9 @@ CONFIGURE_ARGS= --with-threads=posix \
--disable-dependency-tracking \
--enable-dynamic
+# XXX FreeBSD does not implement O_DSYNC and fdatasync at this time.
+CFLAGS+= -DMDB_DSYNC=O_SYNC -Dfdatasync=fsync
+
.if defined(WITHOUT_FETCH)
CONFIGURE_ARGS+= --without-fetch
.endif
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index f7090d4815e9..1c6b2d053b38 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openldap-2.4.26.tgz) = 1f42048cebbcd8647c9c566f8f070946103a15717345915ecd5fccfbe19a7c3d
-SIZE (openldap-2.4.26.tgz) = 5250064
+SHA256 (openldap-2.4.30.tgz) = fc013e528616f8578d9f221409c48af9b8937a62005e0bec88f6f1c4c8ff3d81
+SIZE (openldap-2.4.30.tgz) = 5440261
diff --git a/net/openldap24-server/files/manpages b/net/openldap24-server/files/manpages
index 4381caaf9d99..b6010b1dcef7 100644
--- a/net/openldap24-server/files/manpages
+++ b/net/openldap24-server/files/manpages
@@ -206,6 +206,7 @@ MAN5+= ldap.conf.5 \
slapd-ldap.5 \
slapd-ldbm.5 \
slapd-ldif.5 \
+ slapd-mdb.5 \
slapd-meta.5 \
slapd-monitor.5 \
slapd-ndb.5 \
@@ -242,7 +243,8 @@ MAN5+= ldap.conf.5 \
slapo-unique.5 \
slapo-valsort.5
MLINKS+= \
- slapd-bdb.5 slapd-hdb.5
+ slapd-bdb.5 slapd-hdb.5 \
+ slapd-sock.5 slapo-sock.5
MAN8+= slapacl.8 \
slapadd.8 \
diff --git a/net/openldap24-server/files/patch-servers__slapd__inet_ntoa.diff b/net/openldap24-server/files/patch-servers__slapd__inet_ntoa.diff
deleted file mode 100644
index 3d64dcade8f0..000000000000
--- a/net/openldap24-server/files/patch-servers__slapd__inet_ntoa.diff
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git servers/slapd/connection.c servers/slapd/connection.c
-index aea3b39..65ce576 100644
---- servers/slapd/connection.c
-+++ servers/slapd/connection.c
-@@ -1500,12 +1500,21 @@ connection_input( Connection *conn , conn_readinfo *cri )
- #ifdef LDAP_CONNECTIONLESS
- if ( conn->c_is_udp ) {
- char peername[sizeof("IP=255.255.255.255:65336")];
-+ const char *peeraddr = NULL;
-
- len = ber_int_sb_read(conn->c_sb, &peeraddr, sizeof(struct sockaddr));
- if (len != sizeof(struct sockaddr)) return 1;
-
-+#if defined( HAVE_GETADDRINFO ) && defined( HAVE_INET_NTOP )
-+ char addr[INET_ADDRSTRLEN];
-+ inet_ntop( AF_INET, &peeraddr.sa_in_addr.sin_addr,
-+ addr, sizeof(addr) );
-+ peeraddr = addr;
-+#else /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
-+ peeraddr = inet_ntoa( peeraddr.sa_in_addr.sin_addr );
-+#endif /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
- sprintf( peername, "IP=%s:%d",
-- inet_ntoa( peeraddr.sa_in_addr.sin_addr ),
-+ peeraddr,
- (unsigned) ntohs( peeraddr.sa_in_addr.sin_port ) );
- Statslog( LDAP_DEBUG_STATS,
- "conn=%lu UDP request from %s (%s) accepted.\n",
-diff --git servers/slapd/daemon.c servers/slapd/daemon.c
-index 8e8a69d..ccfa2ee 100644
---- servers/slapd/daemon.c
-+++ servers/slapd/daemon.c
-@@ -1971,8 +1971,16 @@ slap_listener(
- # ifdef LDAP_PF_INET6
- case AF_INET6:
- if ( IN6_IS_ADDR_V4MAPPED(&from.sa_in6_addr.sin6_addr) ) {
-+#if defined( HAVE_GETADDRINFO ) && defined( HAVE_INET_NTOP )
-+ char addr[INET_ADDRSTRLEN];
-+ inet_ntop( AF_INET,
-+ ((struct in_addr *)&from.sa_in6_addr.sin6_addr.s6_addr[12]),
-+ addr, sizeof(addr) );
-+ peeraddr = addr;
-+#else /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
- peeraddr = inet_ntoa( *((struct in_addr *)
- &from.sa_in6_addr.sin6_addr.s6_addr[12]) );
-+#endif /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
- sprintf( peername, "IP=%s:%d",
- peeraddr != NULL ? peeraddr : SLAP_STRING_UNKNOWN,
- (unsigned) ntohs( from.sa_in6_addr.sin6_port ) );
-@@ -1989,12 +1997,19 @@ slap_listener(
- break;
- # endif /* LDAP_PF_INET6 */
-
-- case AF_INET:
-+ case AF_INET: {
-+#if defined( HAVE_GETADDRINFO ) && defined( HAVE_INET_NTOP )
-+ char addr[INET_ADDRSTRLEN];
-+ inet_ntop( AF_INET, &from.sa_in_addr.sin_addr,
-+ addr, sizeof(addr) );
-+ peeraddr = addr;
-+#else /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
- peeraddr = inet_ntoa( from.sa_in_addr.sin_addr );
-+#endif /* ! HAVE_GETADDRINFO || ! HAVE_INET_NTOP */
- sprintf( peername, "IP=%s:%d",
- peeraddr != NULL ? peeraddr : SLAP_STRING_UNKNOWN,
- (unsigned) ntohs( from.sa_in_addr.sin_port ) );
-- break;
-+ } break;
-
- default:
- slapd_close(sfd);
diff --git a/net/openldap24-server/files/patch-shlib-version b/net/openldap24-server/files/patch-shlib-version
index 6218e0132783..30007848c658 100644
--- a/net/openldap24-server/files/patch-shlib-version
+++ b/net/openldap24-server/files/patch-shlib-version
@@ -1,14 +1,14 @@
# I have checked all headers and don't think the shared library
# bump is a needed one. We patch it back to prevent large
# rebuild need.
---- build/version.var.orig 2011-06-30 08:13:36.000000000 -0700
-+++ build/version.var 2011-07-05 00:27:39.172875169 -0700
-@@ -17,7 +17,7 @@ ol_major=2
+--- build/version.var.orig 2012-02-29 09:37:09.000000000 -0800
++++ build/version.var 2012-03-07 13:40:22.456547776 -0800
+@@ -17,7 +17,7 @@
ol_minor=4
- ol_patch=26
- ol_api_inc=20426
--ol_api_current=9
+ ol_patch=30
+ ol_api_inc=20430
+-ol_api_current=10
+ol_api_current=8
- ol_api_revision=1
- ol_api_age=7
- ol_release_date="2011/06/30"
+ ol_api_revision=3
+ ol_api_age=8
+ ol_release_date="2012/02/29"
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 34bcce3b0659..442bf6015075 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -1,17 +1,26 @@
@comment $FreeBSD$
@unexec %%RC_DIR%%/etc/rc.d/slapd stop 2>&1 >/dev/null || true
-etc/openldap/schema/README
-etc/openldap/schema/core.ldif
-etc/openldap/schema/cosine.ldif
-etc/openldap/schema/dyngroup.ldif
-etc/openldap/schema/inetorgperson.ldif
-etc/openldap/schema/nis.ldif
-etc/openldap/schema/openldap.ldif
-etc/openldap/schema/pmi.schema
-etc/openldap/schema/pmi.schema.default
+etc/openldap/slapd.ldif.default
+etc/openldap/slapd.ldif
@unexec if cmp -s %D/etc/openldap/slapd.conf %D/etc/openldap/slapd.conf.default; then rm -f %D/etc/openldap/slapd.conf; fi
etc/openldap/slapd.conf.default
@exec [ -f %B/slapd.conf ] || cp %B/%f %B/slapd.conf
+etc/openldap/schema/ppolicy.ldif
+etc/openldap/schema/pmi.schema.default
+etc/openldap/schema/pmi.schema
+etc/openldap/schema/pmi.ldif
+etc/openldap/schema/openldap.ldif
+etc/openldap/schema/nis.ldif
+etc/openldap/schema/misc.ldif
+etc/openldap/schema/java.ldif
+etc/openldap/schema/inetorgperson.ldif
+etc/openldap/schema/dyngroup.ldif
+etc/openldap/schema/duaconf.ldif
+etc/openldap/schema/cosine.ldif
+etc/openldap/schema/core.ldif
+etc/openldap/schema/corba.ldif
+etc/openldap/schema/collective.ldif
+etc/openldap/schema/README
etc/openldap/DB_CONFIG.example
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.la