aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-08-13 18:15:27 +0800
committerdinoex <dinoex@FreeBSD.org>2010-08-13 18:15:27 +0800
commit1dafc433615f1f5cedd04037463a6819a71d1814 (patch)
treec7902d62f2eab3b0bad744ff7671583c7a52fad9 /net
parentcd78cbfd829b558e4485ea86a934cb105d68df47 (diff)
downloadfreebsd-ports-gnome-1dafc433615f1f5cedd04037463a6819a71d1814.tar.gz
freebsd-ports-gnome-1dafc433615f1f5cedd04037463a6819a71d1814.tar.zst
freebsd-ports-gnome-1dafc433615f1f5cedd04037463a6819a71d1814.zip
- add secondary mirror
- update RC script PR: 148769 Sumitted By: Sevan Janiyan
Diffstat (limited to 'net')
-rw-r--r--net/sixxs-aiccu/Makefile3
-rw-r--r--net/sixxs-aiccu/files/sixxs-aiccu.in24
2 files changed, 19 insertions, 8 deletions
diff --git a/net/sixxs-aiccu/Makefile b/net/sixxs-aiccu/Makefile
index eba7593368a6..c917d2fc070b 100644
--- a/net/sixxs-aiccu/Makefile
+++ b/net/sixxs-aiccu/Makefile
@@ -9,7 +9,8 @@ PORTNAME= aiccu
PORTVERSION= 20070115
PORTREVISION= 1
CATEGORIES= net ipv6
-MASTER_SITES= http://noc.sixxs.net/archive/sixxs/aiccu/unix/
+MASTER_SITES= http://noc.sixxs.net/archive/sixxs/aiccu/unix/ \
+ http://www.sixxs.net/archive/sixxs/aiccu/unix/
PKGNAMEPREFIX= sixxs-
DISTNAME= aiccu_20070115
diff --git a/net/sixxs-aiccu/files/sixxs-aiccu.in b/net/sixxs-aiccu/files/sixxs-aiccu.in
index 40b0fbe72e45..95e9ef809d8f 100644
--- a/net/sixxs-aiccu/files/sixxs-aiccu.in
+++ b/net/sixxs-aiccu/files/sixxs-aiccu.in
@@ -14,17 +14,27 @@
. /etc/rc.subr
-name=sixxs_aiccu
+name="sixxs_aiccu"
rcvar=`set_rcvar`
command="%%PREFIX%%/sbin/sixxs-aiccu"
-command_args=%%PREFIX%%/etc/aiccu.conf
-start_cmd="%%PREFIX%%/sbin/sixxs-aiccu start $command_args"
-stop_cmd="%%PREFIX%%/sbin/sixxs-aiccu stop $command_args"
-required_files=%%PREFIX%%/etc/aiccu.conf
+
+load_rc_config ${name}
# set default
-sixxs_aiccu_enable=${sixxs_aiccu_enable:-"NO"}
+: ${sixxs_aiccu_enable="NO"}
+: ${sixxs_aiccu_config="%%PREFIX%%/etc/aiccu.conf"}
+
+command_args="${sixxs_aiccu_config}"
+required_files="${sixxs_aiccu_config}"
+start_cmd="${command} start $command_args"
+stop_cmd="${command} stop $command_args"
+brokers_cmd="${command} brokers"
+tunnels_cmd="${command} tunnels $command_args"
+test_cmd="${command} test $command_args"
+autotest_cmd="${command} autotest $command_args"
+license_cmd="${command} license"
+version_cmd="${command} version"
+extra_commands="brokers tunnels test autotest license version"
-load_rc_config ${name}
run_rc_command "$1"