aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2014-05-30 02:52:12 +0800
committerXin LI <delphij@FreeBSD.org>2014-05-30 02:52:12 +0800
commit21a3e98189f82fbefa1ee85c69f143e25b87c4d5 (patch)
tree98938c6d2a06c4a1aee145a3d00eae55b63cb1bc /net
parent86c5fb317049e5bd7284839d3a33b861e1f07493 (diff)
downloadfreebsd-ports-gnome-21a3e98189f82fbefa1ee85c69f143e25b87c4d5.tar.gz
freebsd-ports-gnome-21a3e98189f82fbefa1ee85c69f143e25b87c4d5.tar.zst
freebsd-ports-gnome-21a3e98189f82fbefa1ee85c69f143e25b87c4d5.zip
- Add support to GSSAPI (implies SASL).
PR: ports/189470 Submitted by: zi
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 77eaf33779c4..779246a10809 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -64,9 +64,10 @@ PORTREVISION_SERVER= 1
OPENLDAP_SHLIB_MAJOR= 8
OPENLDAP_MAJOR= ${DISTVERSION:R}
-OPTIONS_DEFINE= FETCH
+OPTIONS_DEFINE= FETCH GSSAPI
-FETCH_DESC= Enable fetch(3) support
+FETCH_DESC= Enable fetch(3) support
+GSSAPI_DESC= With GSSAPI support (implies SASL support)
.if !defined(CLIENT_ONLY)
OPTIONS_DEFINE+= DYNACL ACI BDB MDB DNSSRV PASSWD PERL RELAY SHELL
@@ -144,10 +145,17 @@ BROKEN= You have 'USE_OPENLDAP' variable defined either in environment or in m
USE_OPENLDAP= yes
WANT_OPENLDAP_VER= 24
+.if ${PORT_OPTIONS:MGSSAPI} && empty(PORT_OPTIONS:MSASL)
+PORT_OPTIONS+= SASL
+.endif
+
.if ${PORT_OPTIONS:MSASL}
WANT_OPENLDAP_SASL= yes
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.*
PKGNAMESUFFIX= -sasl-server
+.if ${PORT_OPTIONS:MGSSAPI}
+RUN_DEPENDS+= cyrus-sasl-gssapi>0:${PORTSDIR}/security/cyrus-sasl2-gssapi
+.endif
.else
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif