aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-11-14 02:49:23 +0800
committerarved <arved@FreeBSD.org>2003-11-14 02:49:23 +0800
commit22b1a77738f9251fd7cd2588f74e6e6b34c151be (patch)
treec0b53b765884e761d3ac86cada14f39907b45ea6 /net
parentaf4a54d1493731a6a03ff1a4e2aa2c9a7d6077a3 (diff)
downloadfreebsd-ports-gnome-22b1a77738f9251fd7cd2588f74e6e6b34c151be.tar.gz
freebsd-ports-gnome-22b1a77738f9251fd7cd2588f74e6e6b34c151be.tar.zst
freebsd-ports-gnome-22b1a77738f9251fd7cd2588f74e6e6b34c151be.zip
add gift-fasttrack plugin that enables giFT users to participate
in the FastTrack network. PR: 58362 Submitted by: Stefan Ehmann <shoesoft@gmx.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/gift-fasttrack/Makefile36
-rw-r--r--net/gift-fasttrack/distinfo1
-rw-r--r--net/gift-fasttrack/pkg-descr5
-rw-r--r--net/gift-fasttrack/pkg-plist14
5 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 658fc617e1af..5af5c08168e4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -158,6 +158,7 @@
SUBDIR += geta
SUBDIR += ggsd
SUBDIR += gicq
+ SUBDIR += gift-fasttrack
SUBDIR += gift-gnutella
SUBDIR += gift-openft
SUBDIR += giftcurs
diff --git a/net/gift-fasttrack/Makefile b/net/gift-fasttrack/Makefile
new file mode 100644
index 000000000000..bec42d362334
--- /dev/null
+++ b/net/gift-fasttrack/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: giFT-FastTrack
+# Date created: 2003-09-04
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFT-FastTrack
+PORTVERSION= 0.8.3
+CATEGORIES= net
+MASTER_SITES= http://download.berlios.de/gift-fasttrack/
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= A FastTrack plugin for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+DOC_FILES= AUTHORS COPYING ChangeLog \
+ INSTALL NEWS README TODO
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/gift-fasttrack/distinfo b/net/gift-fasttrack/distinfo
new file mode 100644
index 000000000000..09401bf627ea
--- /dev/null
+++ b/net/gift-fasttrack/distinfo
@@ -0,0 +1 @@
+MD5 (giFT-FastTrack-0.8.3.tar.gz) = 2f355e357e8ef777acf7ff37be117fd4
diff --git a/net/gift-fasttrack/pkg-descr b/net/gift-fasttrack/pkg-descr
new file mode 100644
index 000000000000..999617485d66
--- /dev/null
+++ b/net/gift-fasttrack/pkg-descr
@@ -0,0 +1,5 @@
+giFT-FastTrack is a plugin for giFT which enables users of giFT to participate
+in the FastTrack network. The required cryptographic algorithms have been
+successfully reverse engineered and searching/downloading already work.
+
+WWW: http://developer.berlios.de/projects/gift-fasttrack/
diff --git a/net/gift-fasttrack/pkg-plist b/net/gift-fasttrack/pkg-plist
new file mode 100644
index 000000000000..4659b4b5e580
--- /dev/null
+++ b/net/gift-fasttrack/pkg-plist
@@ -0,0 +1,14 @@
+lib/giFT/libFastTrack.la
+lib/giFT/libFastTrack.so
+share/giFT/FastTrack/FastTrack.conf
+share/giFT/FastTrack/nodes
+%%PORTDOCS%%share/doc/giFT-FastTrack/AUTHORS
+%%PORTDOCS%%share/doc/giFT-FastTrack/COPYING
+%%PORTDOCS%%share/doc/giFT-FastTrack/ChangeLog
+%%PORTDOCS%%share/doc/giFT-FastTrack/INSTALL
+%%PORTDOCS%%share/doc/giFT-FastTrack/NEWS
+%%PORTDOCS%%share/doc/giFT-FastTrack/README
+%%PORTDOCS%%share/doc/giFT-FastTrack/TODO
+@dirrm lib/giFT
+@dirrm share/giFT/FastTrack
+@dirrm %%PORTDOCS%%share/doc/giFT-FastTrack