aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 18:15:24 +0800
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 18:15:24 +0800
commit23e6a2b3da60fd03fb9e392af59450056c09f9a5 (patch)
tree3b7e9ffbd68b82f181ccb4b1d327b834b4994adf /net
parent9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (diff)
downloadfreebsd-ports-gnome-23e6a2b3da60fd03fb9e392af59450056c09f9a5.tar.gz
freebsd-ports-gnome-23e6a2b3da60fd03fb9e392af59450056c09f9a5.tar.zst
freebsd-ports-gnome-23e6a2b3da60fd03fb9e392af59450056c09f9a5.zip
BROKEN on 5.1: bad C++
Diffstat (limited to 'net')
-rw-r--r--net/cflowd/Makefile8
-rw-r--r--net/irrtoolset/Makefile8
-rw-r--r--net/papaya/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/net/cflowd/Makefile b/net/cflowd/Makefile
index 2c92cef1c2c0..58698a767341 100644
--- a/net/cflowd/Makefile
+++ b/net/cflowd/Makefile
@@ -22,6 +22,12 @@ COMMENT= Flow analysis tool used for analyzing Cisco's NetFlow switching
BUILD_DEPENDS= ${LOCALBASE}/lib/libArts.a:${PORTSDIR}/net/arts++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -41,4 +47,4 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/cflowd.sh \
${PREFIX}/etc/rc.d/cflowd-base.sh.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/irrtoolset/Makefile b/net/irrtoolset/Makefile
index 53bced116452..7cfd192945d8 100644
--- a/net/irrtoolset/Makefile
+++ b/net/irrtoolset/Makefile
@@ -16,6 +16,12 @@ COMMENT= A suite of routing policy tools to interact with the IRR
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_BISON= yes
USE_GMAKE= yes
USE_GCC= 2.95
@@ -36,4 +42,4 @@ post-patch:
aLL_TARGET= depend all
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/papaya/Makefile b/net/papaya/Makefile
index 883ba9b5cd0f..1b0b25a12534 100644
--- a/net/papaya/Makefile
+++ b/net/papaya/Makefile
@@ -21,6 +21,10 @@ WANT_GNOME= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.if ${HAVE_GNOME:Mgnomelibs}!=""
USE_GNOME+= gnomeprefix gnomehack gnomelibs
.else