aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-28 16:32:07 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-28 16:32:07 +0800
commit2430e68212ca6e8ab3e5526a7713318c3c52d52f (patch)
tree7dfb67622d2b4fce3df6631a52b105d695c9c1b8 /net
parent853c3cb087315466fe683d7f6060f52088e02f5d (diff)
downloadfreebsd-ports-gnome-2430e68212ca6e8ab3e5526a7713318c3c52d52f.tar.gz
freebsd-ports-gnome-2430e68212ca6e8ab3e5526a7713318c3c52d52f.tar.zst
freebsd-ports-gnome-2430e68212ca6e8ab3e5526a7713318c3c52d52f.zip
- Support staging
- Define DOCS option
Diffstat (limited to 'net')
-rw-r--r--net/beanstalkd/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net/beanstalkd/Makefile b/net/beanstalkd/Makefile
index 87cf7d2ea90e..4ef7198bcc1c 100644
--- a/net/beanstalkd/Makefile
+++ b/net/beanstalkd/Makefile
@@ -10,28 +10,26 @@ COMMENT= Fast, distributed, in-memory workqueue service
LICENSE= MIT
+USES= gmake
USE_RC_SUBR= beanstalkd
-USE_GMAKE= yes
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
-PLIST_FILES= bin/beanstalkd
+PLIST_FILES= bin/beanstalkd man/man1/beanstalkd.1.gz
SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
PORTDOCS= protocol.txt
-MAN1= beanstalkd.1
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
test: configure
@cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} check