aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 18:06:40 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 18:06:40 +0800
commit243e441442c8fbeef8cd2586bc9df2f5c8906ea6 (patch)
treed7c90dcdf5a4d019682fdae97e53b8c7801b313e /net
parentef980029f0f4ba154a1036f15ffd57f471623209 (diff)
downloadfreebsd-ports-gnome-243e441442c8fbeef8cd2586bc9df2f5c8906ea6.tar.gz
freebsd-ports-gnome-243e441442c8fbeef8cd2586bc9df2f5c8906ea6.tar.zst
freebsd-ports-gnome-243e441442c8fbeef8cd2586bc9df2f5c8906ea6.zip
Support stage
Enforce usage of gcc as this is bad c++ code that only g++ accept when it should not see http://clang.debian.net/status.php?version=3.0&key=USE_OF_UNDECLARED_IDENTIFIER for details MFH: 2014Q2
Diffstat (limited to 'net')
-rw-r--r--net/libtnl/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/libtnl/Makefile b/net/libtnl/Makefile
index 46aed25c9755..11a1f49a1bf0 100644
--- a/net/libtnl/Makefile
+++ b/net/libtnl/Makefile
@@ -8,13 +8,13 @@ MASTER_SITES= SF/opentnl/TNL%20Source/${PORTVERSION}
DISTNAME= tnl-${PORTVERSION}-source
MAINTAINER= ports@FreeBSD.org
-COMMENT= A robust, secure, easy to use cross-platform C++ networking API
+COMMENT= Robust, secure, easy to use cross-platform C++ networking API
+USES= uidfix
+USE_GCC= any
WRKSRC= ${WRKDIR}/tnl/tnl
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAKE_ARGS= -j`${SYSCTL} -n hw.ncpu`
-NO_STAGE= yes
# Other arches can be added easily, provided there is hardware to test:
ONLY_FOR_ARCHS= i386 amd64
.if defined(NO_PROFILE) || defined(NOPROFILE)
@@ -29,7 +29,7 @@ PLIST_SUB+= PROFILE=''
#
#EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude tnl/libtomcrypt
-pre-su-install:
- ${MKDIR} ${PREFIX}/include/tnl
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/tnl
.include <bsd.port.mk>