aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-05-03 03:23:55 +0800
committerjbeich <jbeich@FreeBSD.org>2015-05-03 03:23:55 +0800
commit253bf496d19841b38823f07007e00e1d9a307a89 (patch)
tree9d79fbf168ce284220c6ec0128669b11a3dd7b89 /net
parent4cb9163ebe3504c8f8dbb29ae8963fc603fbc304 (diff)
downloadfreebsd-ports-gnome-253bf496d19841b38823f07007e00e1d9a307a89.tar.gz
freebsd-ports-gnome-253bf496d19841b38823f07007e00e1d9a307a89.tar.zst
freebsd-ports-gnome-253bf496d19841b38823f07007e00e1d9a307a89.zip
net/miruo: add new port
Network monitor/analyzer which prints packets on terminal in neat style. Packet data can also be read from a file saved by tcpdump(1). WWW: https://github.com/KLab/miruo PR: 199723 Submitted by: Koichiro IWAO <meta+ports@vmeta.jp>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hanstunnel/Makefile42
-rw-r--r--net/hanstunnel/distinfo4
-rw-r--r--net/hanstunnel/files/patch-Makefile73
-rw-r--r--net/hanstunnel/files/patch-client.cpp11
-rw-r--r--net/hanstunnel/files/patch-main.cpp10
-rw-r--r--net/hanstunnel/files/patch-src_echo.cpp (renamed from net/hanstunnel/files/patch-echo.cpp)9
-rw-r--r--net/hanstunnel/files/patch-src_tun.cpp11
-rw-r--r--net/hanstunnel/files/patch-src_tun__dev__freebsd.c14
-rw-r--r--net/hanstunnel/files/patch-tun.cpp45
-rw-r--r--net/hanstunnel/files/patch-utility.cpp10
-rw-r--r--net/hanstunnel/pkg-descr3
-rw-r--r--net/hanstunnel/pkg-message (renamed from net/hanstunnel/files/pkg-message.in)0
-rw-r--r--net/miruo/Makefile19
-rw-r--r--net/miruo/distinfo2
-rw-r--r--net/miruo/pkg-descr4
16 files changed, 76 insertions, 182 deletions
diff --git a/net/Makefile b/net/Makefile
index 856b990d7601..2300c7c92de3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -376,6 +376,7 @@
SUBDIR += miniupnpc
SUBDIR += miniupnpd
SUBDIR += miredo
+ SUBDIR += miruo
SUBDIR += mono-zeroconf
SUBDIR += mopd
SUBDIR += morebalance
diff --git a/net/hanstunnel/Makefile b/net/hanstunnel/Makefile
index 1b97527b550d..e6db93c5b306 100644
--- a/net/hanstunnel/Makefile
+++ b/net/hanstunnel/Makefile
@@ -2,42 +2,30 @@
# $FreeBSD$
PORTNAME= hans
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= net security
MASTER_SITES= SF/hanstunnel/source
MAINTAINER= vsityz@gmail.com
COMMENT= Hans makes it possible to tunnel IPv4 through ICMP
-LICENSE= GPLv3
-
-OPTIONS_DEFINE= CLANG
-
-CLANG_DESC= Build with Clang instead of GCC
-
-OPTIONS_DEFAULT= CLANG
-
+LICENSE= FPL GPLv3 # or any later version
+LICENSE_COMB= multi
+LICENSE_NAME_FPL=Freeware Public License
+LICENSE_FILE_FPL=${WRKSRC}/src/sha1_license.txt
+LICENSE_PERMS_FPL=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= dos2unix
+DOS2UNIX_FILES= ${LICENSE_FILE_FPL}
+MAKE_ARGS= GCC="${CC}" GPP="${CXX}" \
+ CFLAGS="${CFLAGS} -c" LDFLAGS="${LDFLAGS}" \
+ TUN_DEV_FILE="src/tun_dev_freebsd.c"
PLIST_FILES= bin/hans
-SUB_FILES= pkg-message
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCLANG}
-.if ${OSVERSION} >= 900033 && exists(/usr/bin/clang)
-CC= clang
-CXX= clang++
-.else
-BUILD_DEPENDS+= clang33:${PORTSDIR}/lang/clang33
-CC= clang33
-CXX= clang++33
-.endif
-.else
-USE_GCC= any
-.endif
+# Remove CRs before ask-license to fix formatting in dialog(1)
+post-extract: dos2unix
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hans ${STAGEDIR}${LOCALBASE}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hans ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net/hanstunnel/distinfo b/net/hanstunnel/distinfo
index 639a5ccbbbd4..32c7a8a7103a 100644
--- a/net/hanstunnel/distinfo
+++ b/net/hanstunnel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hans-0.4.1.tar.gz) = 8e4df005bcf6a877ffd0810cc9b31aa3ae04f23d798bea6cc2893a3f26cac29c
-SIZE (hans-0.4.1.tar.gz) = 32860
+SHA256 (hans-0.4.4.tar.gz) = 81378258b8c9510ac01ad4d69f191e2927b9304daae033ee097f6ba4d39f6bb3
+SIZE (hans-0.4.4.tar.gz) = 33992
diff --git a/net/hanstunnel/files/patch-Makefile b/net/hanstunnel/files/patch-Makefile
deleted file mode 100644
index 747d9e5d4b7f..000000000000
--- a/net/hanstunnel/files/patch-Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
---- Makefile.orig 2010-02-17 17:30:21.000000000 +0200
-+++ Makefile 2013-04-04 15:18:50.818219413 +0300
-@@ -1,53 +1,51 @@
--LDFLAGS = `sh osflags ld $(MODE)`
--CFLAGS = -c -g `sh osflags c $(MODE)`
--TUN_DEV_FILE = `sh osflags dev $(MODE)`
--GCC = gcc
--GPP = g++
-+TUN_DEV_FILE = tun_dev_freebsd.c
-+GCC = ${CC}
-+GPP = ${CXX}
-
- all: hans
-
- hans: tun.o sha1.o main.o client.o server.o auth.o worker.o time.o tun_dev.o echo.o exception.o utility.o
-- $(GPP) -o hans tun.o sha1.o main.o client.o server.o auth.o worker.o time.o tun_dev.o echo.o exception.o utility.o $(LDFLAGS)
-+ ${GPP} -o hans tun.o sha1.o main.o client.o server.o auth.o worker.o time.o tun_dev.o echo.o exception.o utility.o ${LDFLAGS}
-
- utility.o: utility.cpp utility.h
-- $(GPP) -c utility.cpp $(CFLAGS)
-+ ${GPP} -c utility.cpp ${CFLAGS}
-
- exception.o: exception.cpp exception.h
-- $(GPP) -c exception.cpp $(CFLAGS)
-+ ${GPP} -c exception.cpp ${CFLAGS}
-
- echo.o: echo.cpp echo.h exception.h
-- $(GPP) -c echo.cpp $(CFLAGS)
-+ ${GPP} -c echo.cpp ${CFLAGS}
-
- tun.o: tun.cpp tun.h exception.h utility.h tun_dev.h
-- $(GPP) -c tun.cpp $(CFLAGS)
-+ ${GPP} -c tun.cpp ${CFLAGS}
-
- tun_dev.o:
-- $(GCC) -c $(TUN_DEV_FILE) -o tun_dev.o $(CFLAGS)
-+ ${GCC} -c ${TUN_DEV_FILE} -o tun_dev.o ${CFLAGS}
-
- sha1.o: sha1.cpp sha1.h
-- $(GPP) -c sha1.cpp $(CFLAGS)
-+ ${GPP} -c sha1.cpp ${CFLAGS}
-
- main.o: main.cpp client.h server.h exception.h worker.h auth.h time.h echo.h tun.h tun_dev.h
-- $(GPP) -c main.cpp $(CFLAGS)
-+ ${GPP} -c main.cpp ${CFLAGS}
-
- client.o: client.cpp client.h server.h exception.h config.h worker.h auth.h time.h echo.h tun.h tun_dev.h
-- $(GPP) -c client.cpp $(CFLAGS)
-+ ${GPP} -c client.cpp ${CFLAGS}
-
- server.o: server.cpp server.h client.h utility.h config.h worker.h auth.h time.h echo.h tun.h tun_dev.h
-- $(GPP) -c server.cpp $(CFLAGS)
-+ ${GPP} -c server.cpp ${CFLAGS}
-
- auth.o: auth.cpp auth.h sha1.h utility.h
-- $(GPP) -c auth.cpp $(CFLAGS)
-+ ${GPP} -c auth.cpp ${CFLAGS}
-
- worker.o: worker.cpp worker.h tun.h exception.h time.h echo.h tun_dev.h config.h
-- $(GPP) -c worker.cpp $(CFLAGS)
-+ ${GPP} -c worker.cpp ${CFLAGS}
-
- time.o: time.cpp time.h
-- $(GPP) -c time.cpp $(CFLAGS)
-+ ${GPP} -c time.cpp ${CFLAGS}
-
- clean:
- rm -f tun.o sha1.o main.o client.o server.o auth.o worker.o time.o tun_dev.o echo.o exception.o utility.o tunemu.o hans
-
-
- tunemu.o: tunemu.h tunemu.c
-- $(GCC) -c tunemu.c -o tunemu.o
-+ ${GCC} -c tunemu.c -o tunemu.o
diff --git a/net/hanstunnel/files/patch-client.cpp b/net/hanstunnel/files/patch-client.cpp
deleted file mode 100644
index 16a57a6261ae..000000000000
--- a/net/hanstunnel/files/patch-client.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- client.cpp.orig 2010-02-17 17:30:21.000000000 +0200
-+++ client.cpp 2013-04-03 16:05:10.000000000 +0300
-@@ -27,6 +27,8 @@
- #include <arpa/inet.h>
- #include <syslog.h>
-
-+#include <netinet/in.h>
-+
- using namespace std;
-
- const Worker::TunnelHeader::Magic Client::magic("hanc");
diff --git a/net/hanstunnel/files/patch-main.cpp b/net/hanstunnel/files/patch-main.cpp
deleted file mode 100644
index fe816c05b86e..000000000000
--- a/net/hanstunnel/files/patch-main.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- main.cpp.orig 2014-08-06 10:11:00.000000000 -0400
-+++ main.cpp 2014-08-06 10:11:12.000000000 -0400
-@@ -30,6 +30,7 @@
- #include <stdlib.h>
- #include <errno.h>
- #include <syslog.h>
-+#include <unistd.h>
-
- void usage()
- {
diff --git a/net/hanstunnel/files/patch-echo.cpp b/net/hanstunnel/files/patch-src_echo.cpp
index 302833f9ea88..0d4be34e7844 100644
--- a/net/hanstunnel/files/patch-echo.cpp
+++ b/net/hanstunnel/files/patch-src_echo.cpp
@@ -1,9 +1,10 @@
---- echo.cpp.orig 2014-08-06 10:11:40.000000000 -0400
-+++ echo.cpp 2014-08-06 10:11:56.000000000 -0400
-@@ -20,6 +20,7 @@
+--- src/echo.cpp.orig 2014-02-07 03:36:31 UTC
++++ src/echo.cpp
+@@ -19,7 +19,7 @@
+
#include "echo.h"
#include "exception.h"
-
+-
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in_systm.h>
diff --git a/net/hanstunnel/files/patch-src_tun.cpp b/net/hanstunnel/files/patch-src_tun.cpp
new file mode 100644
index 000000000000..60ff6d58d6a9
--- /dev/null
+++ b/net/hanstunnel/files/patch-src_tun.cpp
@@ -0,0 +1,11 @@
+--- src/tun.cpp.orig 2014-02-07 03:36:31 UTC
++++ src/tun.cpp
+@@ -20,7 +20,7 @@
+ #include "tun.h"
+ #include "exception.h"
+ #include "utility.h"
+-
++#include <sys/types.h>
+ #include <arpa/inet.h>
+ #include <netinet/in_systm.h>
+ #include <netinet/in.h>
diff --git a/net/hanstunnel/files/patch-src_tun__dev__freebsd.c b/net/hanstunnel/files/patch-src_tun__dev__freebsd.c
new file mode 100644
index 000000000000..5f223b322b47
--- /dev/null
+++ b/net/hanstunnel/files/patch-src_tun__dev__freebsd.c
@@ -0,0 +1,14 @@
+--- src/tun_dev_freebsd.c.orig 2014-02-07 03:36:31 UTC
++++ src/tun_dev_freebsd.c
+@@ -31,7 +31,11 @@
+ #include <errno.h>
+
+ #include <sys/ioctl.h>
++#ifdef __DragonFly__
++#include <net/tun/if_tun.h>
++#else
+ #include <net/if_tun.h>
++#endif
+
+ /* #include "vtun.h"
+ #include "lib.h" */
diff --git a/net/hanstunnel/files/patch-tun.cpp b/net/hanstunnel/files/patch-tun.cpp
deleted file mode 100644
index d60be6846d90..000000000000
--- a/net/hanstunnel/files/patch-tun.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
---- tun.cpp.orig 2010-02-17 10:30:21.000000000 -0500
-+++ tun.cpp 2014-08-06 10:10:51.000000000 -0400
-@@ -21,6 +21,7 @@
- #include "exception.h"
- #include "utility.h"
-
-+#include <sys/types.h>
- #include <arpa/inet.h>
- #include <netinet/in_systm.h>
- #include <netinet/in.h>
-@@ -41,8 +42,7 @@
-
- if (device != NULL)
- {
-- strncpy(this->device, device, VTUN_DEV_LEN);
-- this->device[VTUN_DEV_LEN] = 0;
-+ strlcpy(this->device, device, VTUN_DEV_LEN);
- }
- else
- this->device[0] = 0;
-@@ -68,23 +68,17 @@
- string ips = Utility::formatIp(ip);
- string destIps = Utility::formatIp(destIp);
-
--#ifdef LINUX
-- snprintf(cmdline, sizeof(cmdline), "/sbin/ifconfig %s %s netmask 255.255.255.0", device, ips.c_str());
--#else
-- snprintf(cmdline, sizeof(cmdline), "/sbin/ifconfig %s %s %s netmask 255.255.255.255", device, ips.c_str(), destIps.c_str());
--#endif
-+ snprintf(cmdline, sizeof(cmdline), "/sbin/ifconfig %s %s %s netmask 255.255.255.0", device, ips.c_str(), destIps.c_str());
-
- if (system(cmdline) != 0)
- syslog(LOG_ERR, "could not set tun device ip address");
-
--#ifndef LINUX
- if (includeSubnet)
- {
- snprintf(cmdline, sizeof(cmdline), "/sbin/route add %s/24 %s", destIps.c_str(), destIps.c_str());
- if (system(cmdline) != 0)
- syslog(LOG_ERR, "could not add route");
- }
--#endif
- }
-
- void Tun::write(const char *buffer, int length)
diff --git a/net/hanstunnel/files/patch-utility.cpp b/net/hanstunnel/files/patch-utility.cpp
deleted file mode 100644
index 40b65b5d5457..000000000000
--- a/net/hanstunnel/files/patch-utility.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- utility.cpp.orig 2014-08-06 10:12:15.000000000 -0400
-+++ utility.cpp 2014-08-06 10:12:30.000000000 -0400
-@@ -21,6 +21,7 @@
-
- #include <stdlib.h>
- #include <stdio.h>
-+#include <time.h>
-
- using namespace std;
-
diff --git a/net/hanstunnel/pkg-descr b/net/hanstunnel/pkg-descr
index 74316b5f115f..a3e2014699c5 100644
--- a/net/hanstunnel/pkg-descr
+++ b/net/hanstunnel/pkg-descr
@@ -3,4 +3,7 @@ could call it a ping tunnel. This can be useful when you find yourself
in the situation that your Internet access is firewalled, but pings are
allowed.
+Hans runs on Linux as a client and a server. It runs on Mac OS X,
+iPhone/iPod touch, FreeBSD and OpenBSD as a client only.
+
WWW: http://code.gerade.org/hans/
diff --git a/net/hanstunnel/files/pkg-message.in b/net/hanstunnel/pkg-message
index 023661b7b432..023661b7b432 100644
--- a/net/hanstunnel/files/pkg-message.in
+++ b/net/hanstunnel/pkg-message
diff --git a/net/miruo/Makefile b/net/miruo/Makefile
new file mode 100644
index 000000000000..74bbef6cb024
--- /dev/null
+++ b/net/miruo/Makefile
@@ -0,0 +1,19 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= miruo
+PORTVERSION= 0.9.5
+CATEGORIES= net
+
+MAINTAINER= meta+ports@vmeta.jp
+COMMENT= Pretty-print TCP session monitor/analyzer
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= KLab
+
+GNU_CONFIGURE= yes
+PLIST_FILES= sbin/miruo
+
+.include <bsd.port.mk>
diff --git a/net/miruo/distinfo b/net/miruo/distinfo
new file mode 100644
index 000000000000..d3f2db20577f
--- /dev/null
+++ b/net/miruo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KLab-miruo-0.9.5_GH0.tar.gz) = adb57d766dd91c1509c8239fc0c92c570fcb5e5900c2513807817424fc7eeffd
+SIZE (KLab-miruo-0.9.5_GH0.tar.gz) = 116387
diff --git a/net/miruo/pkg-descr b/net/miruo/pkg-descr
new file mode 100644
index 000000000000..a9404e44495c
--- /dev/null
+++ b/net/miruo/pkg-descr
@@ -0,0 +1,4 @@
+Network monitor/analyzer which prints packets on terminal in neat style.
+Packet data can also be read from a file saved by tcpdump(1).
+
+WWW: https://github.com/KLab/miruo