aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-07 01:36:08 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-07 01:36:08 +0800
commit25425dd86b2d1a2f1ae7be238114602e856271f0 (patch)
treeba74f1d331438ad12d7bd8d6461d952362e2d3c9 /net
parent3622c21bbfeb591eff18ea7487ed36a57356674a (diff)
downloadfreebsd-ports-gnome-25425dd86b2d1a2f1ae7be238114602e856271f0.tar.gz
freebsd-ports-gnome-25425dd86b2d1a2f1ae7be238114602e856271f0.tar.zst
freebsd-ports-gnome-25425dd86b2d1a2f1ae7be238114602e856271f0.zip
add p5-Net-XWhois
Whois Client Interface for Perl5 PR: 28090 Submitted by: Danny Howard <dannyman@tellme.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-XWhois/Makefile22
-rw-r--r--net/p5-Net-XWhois/distinfo1
-rw-r--r--net/p5-Net-XWhois/pkg-comment1
-rw-r--r--net/p5-Net-XWhois/pkg-descr8
-rw-r--r--net/p5-Net-XWhois/pkg-plist3
6 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e6d635606a43..0f22f6b35ad9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -257,6 +257,7 @@
SUBDIR += p5-Net-Traceroute
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
+ SUBDIR += p5-Net-XWhois
SUBDIR += p5-Net-ext
SUBDIR += p5-NetAddr-IP
SUBDIR += p5-NetAddr-IP-Count
diff --git a/net/p5-Net-XWhois/Makefile b/net/p5-Net-XWhois/Makefile
new file mode 100644
index 000000000000..c2237d00d86f
--- /dev/null
+++ b/net/p5-Net-XWhois/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-XWhois
+# Date created: 11 June 2001
+# Whom: Danny Howard <dannyman@tellme.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-XWhois
+PORTVERSION= 0.72
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dannyman@tellme.com
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::XWhois.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-XWhois/distinfo b/net/p5-Net-XWhois/distinfo
new file mode 100644
index 000000000000..6b501f71946d
--- /dev/null
+++ b/net/p5-Net-XWhois/distinfo
@@ -0,0 +1 @@
+MD5 (Net-XWhois-0.72.tar.gz) = fb761820691bfbfe5518cde9b0583997
diff --git a/net/p5-Net-XWhois/pkg-comment b/net/p5-Net-XWhois/pkg-comment
new file mode 100644
index 000000000000..414230d8b6da
--- /dev/null
+++ b/net/p5-Net-XWhois/pkg-comment
@@ -0,0 +1 @@
+Whois Client Interface for Perl5
diff --git a/net/p5-Net-XWhois/pkg-descr b/net/p5-Net-XWhois/pkg-descr
new file mode 100644
index 000000000000..31066af42796
--- /dev/null
+++ b/net/p5-Net-XWhois/pkg-descr
@@ -0,0 +1,8 @@
+The Net::XWhois class provides a generic client framework for doing Whois
+queries and parsing server response.
+
+One of the more important features of this module is to enable the design of
+consistent and predictable interfaces to incompatible whois response formats.
+The Whois RFC (954) does not define a template for presenting server data;
+consequently there is a large variation in layout styles as well as content
+served across servers.
diff --git a/net/p5-Net-XWhois/pkg-plist b/net/p5-Net-XWhois/pkg-plist
new file mode 100644
index 000000000000..556f3d5073f4
--- /dev/null
+++ b/net/p5-Net-XWhois/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/XWhois.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/XWhois/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/XWhois 2>/dev/null || true