aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorleres <leres@FreeBSD.org>2018-02-20 06:38:04 +0800
committerleres <leres@FreeBSD.org>2018-02-20 06:38:04 +0800
commit275aa98ee005c7f63704fd9d9709558ae81813e1 (patch)
treedeb99395c76bf9577a7b21e02fcee1f4840db360 /net
parentd07011ab40e0161f29b08561349cbd6536c507d4 (diff)
downloadfreebsd-ports-gnome-275aa98ee005c7f63704fd9d9709558ae81813e1.tar.gz
freebsd-ports-gnome-275aa98ee005c7f63704fd9d9709558ae81813e1.tar.zst
freebsd-ports-gnome-275aa98ee005c7f63704fd9d9709558ae81813e1.zip
Patch socat/Makefile to reference all of dependencies when
linking filan so that parallel make is reliable again. PR: 226012 Reviewed by: ler (mentor) Approved by: ler (mentor) Differential Revision: https://reviews.freebsd.org/D14445
Diffstat (limited to 'net')
-rw-r--r--net/socat/files/patch-Makefile.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/net/socat/files/patch-Makefile.in b/net/socat/files/patch-Makefile.in
new file mode 100644
index 000000000000..1c8df27086fb
--- /dev/null
+++ b/net/socat/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2017-01-06 20:58:40 UTC
++++ Makefile.in
+@@ -118,8 +118,9 @@ PROCAN_OBJS=procan_main.o procan.o proca
+ procan: $(PROCAN_OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(PROCAN_OBJS) $(CLIBS)
+
+-filan: filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o $(CLIBS)
++FILAN_OBJS=filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o
++filan: $(FILAN_OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(FILAN_OBJS) $(CLIBS)
+
+ libxio.a: $(XIOOBJS) $(UTLOBJS)
+ $(AR) r $@ $(XIOOBJS) $(UTLOBJS)