aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-03 20:08:14 +0800
committerkrion <krion@FreeBSD.org>2003-11-03 20:08:14 +0800
commit285780180da0fde7bb4b6a9e247a910730c24251 (patch)
tree2038ea617160698959c80e30ae490a2f2e42d92c /net
parente068f5287b61aa6e464e4cd388cd980252a322e6 (diff)
downloadfreebsd-ports-gnome-285780180da0fde7bb4b6a9e247a910730c24251.tar.gz
freebsd-ports-gnome-285780180da0fde7bb4b6a9e247a910730c24251.tar.zst
freebsd-ports-gnome-285780180da0fde7bb4b6a9e247a910730c24251.zip
hidentd is a simple and secure GPLed ident (RFC1413) server. It
requires either inetd, xinetd or ucspi-tcp to run. Basic features: * small and simple - around 300 lines of code * secure - runs without root priviledges * easy - no complicated configuration file syntax to learn. * hidentd is entirely controlled with command line options. * can be configured to provide fake usernames, protecting your * privacy * limited masqueraded/NAT connections support.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hidentd/Makefile29
-rw-r--r--net/hidentd/distinfo1
-rw-r--r--net/hidentd/pkg-descr12
-rw-r--r--net/hidentd/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b9da390bc762..5025a83a9460 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -199,6 +199,7 @@
SUBDIR += haproxy
SUBDIR += hawk
SUBDIR += hf6to4
+ SUBDIR += hidentd
SUBDIR += hinfo
SUBDIR += hlmaster
SUBDIR += honeyd
diff --git a/net/hidentd/Makefile b/net/hidentd/Makefile
new file mode 100644
index 000000000000..e96018894b6b
--- /dev/null
+++ b/net/hidentd/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hidentd
+# Date created: 02.11.2003
+# Whom: Kirill Ponomarew <krion@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hidentd
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://core.segfault.pl/~hobbit/hidentd/dist/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Simple and secure ident (RFC1413) server
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN8= hidentd.8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/hidentd/distinfo b/net/hidentd/distinfo
new file mode 100644
index 000000000000..dd23378a7ec1
--- /dev/null
+++ b/net/hidentd/distinfo
@@ -0,0 +1 @@
+MD5 (hidentd-0.2.tar.gz) = 28ef96009533e7f88dbe498b664ba4c7
diff --git a/net/hidentd/pkg-descr b/net/hidentd/pkg-descr
new file mode 100644
index 000000000000..aef19dba72e4
--- /dev/null
+++ b/net/hidentd/pkg-descr
@@ -0,0 +1,12 @@
+hidentd is a simple and secure GPLed ident (RFC1413) server. It
+requires either inetd, xinetd or ucspi-tcp to run. Basic
+features:
+
+* small and simple - around 300 lines of code
+* secure - runs without root priviledges
+* easy - no complicated configuration file syntax to learn.
+* hidentd is entirely controlled with command line options.
+* can be configured to provide fake usernames, protecting your privacy
+* limited masqueraded/NAT connections support.
+
+WWW: http://core.segfault.pl/~hobbit/hidentd/
diff --git a/net/hidentd/pkg-plist b/net/hidentd/pkg-plist
new file mode 100644
index 000000000000..083cec84ae1a
--- /dev/null
+++ b/net/hidentd/pkg-plist
@@ -0,0 +1,3 @@
+sbin/hidentd
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%