aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1999-10-25 12:03:28 +0800
committerobrien <obrien@FreeBSD.org>1999-10-25 12:03:28 +0800
commit285d8f1454e16cedccc7937e4387469594a83f84 (patch)
tree60c01be42669b0b747e15af7c8fac27ddd63fa05 /net
parent62a45a618d659edd4b44a719874b5d314795e8be (diff)
downloadfreebsd-ports-gnome-285d8f1454e16cedccc7937e4387469594a83f84.tar.gz
freebsd-ports-gnome-285d8f1454e16cedccc7937e4387469594a83f84.tar.zst
freebsd-ports-gnome-285d8f1454e16cedccc7937e4387469594a83f84.zip
Use our real binary's name in the syslog messages.
On hosts that support it, use LOG_SECURITY rather than LOG_PRIVAUTH. (why this type of thing needs to be private, I don't understand)
Diffstat (limited to 'net')
-rw-r--r--net/tdetect/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/tdetect/Makefile b/net/tdetect/Makefile
index 75f2d135eae4..55bacf9e3d45 100644
--- a/net/tdetect/Makefile
+++ b/net/tdetect/Makefile
@@ -16,6 +16,14 @@ MASTER_SITES= http://sb.123.org/ \
MAINTAINER= shipley@dis.org
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${PERL} -pi.dist -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
+.if ${OSVERSION} > 330002
+ ${PERL} -pi.orig -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tdetect ${PREFIX}/sbin/tdetect
@@ -33,4 +41,4 @@ post-install:
${ECHO} ''; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>