aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-12-09 16:26:43 +0800
committernovel <novel@FreeBSD.org>2011-12-09 16:26:43 +0800
commit28b774c462bb94acacbead41eeb4fd57ade1b65f (patch)
treefb289ec2e753db4054e52c020002116aefd0bdb6 /net
parent76403e8b80c3d13a2ce468776ba3fbb5ad850cfa (diff)
downloadfreebsd-ports-gnome-28b774c462bb94acacbead41eeb4fd57ade1b65f.tar.gz
freebsd-ports-gnome-28b774c462bb94acacbead41eeb4fd57ade1b65f.tar.zst
freebsd-ports-gnome-28b774c462bb94acacbead41eeb4fd57ade1b65f.zip
This is a client for the OpenStack Nova API. There's a Python
API (the novaclient module), and a command-line script (nova). Each implements 100% of the OpenStack Nova API. WWW: http://pypi.python.org/pypi/python-novaclient Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-novaclient/Makefile33
-rw-r--r--net/py-novaclient/distinfo2
-rw-r--r--net/py-novaclient/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 748af171a62d..5054b2aa34ac 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -869,6 +869,7 @@
SUBDIR += py-netaddr
SUBDIR += py-netifaces
SUBDIR += py-netstring
+ SUBDIR += py-novaclient
SUBDIR += py-oauth
SUBDIR += py-oauth2
SUBDIR += py-pcap
diff --git a/net/py-novaclient/Makefile b/net/py-novaclient/Makefile
new file mode 100644
index 000000000000..f1b32a4c479a
--- /dev/null
+++ b/net/py-novaclient/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-novaclient
+# Date created: 2011-12-08
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= novaclient
+PORTVERSION= 2.6.8
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Client for the OpenStack Nova API
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>=0:${PORTSDIR}/devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:${PORTSDIR}/devel/py-prettytable \
+ ${PYTHON_SITELIBDIR}/httplib2/__init__.py:${PORTSDIR}/www/py-httplib2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_NOEGGINFO= yes
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
+
+PLIST_FILES= bin/nova \
+ ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/${PYEASYINSTALL_EGG}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/net/py-novaclient/distinfo b/net/py-novaclient/distinfo
new file mode 100644
index 000000000000..b14eab4b0713
--- /dev/null
+++ b/net/py-novaclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-novaclient-2.6.8.tar.gz) = 2aa6edb819d4d61c25cf94f9c404decd8e1e1192e071184ee91129faa9c06805
+SIZE (python-novaclient-2.6.8.tar.gz) = 112291
diff --git a/net/py-novaclient/pkg-descr b/net/py-novaclient/pkg-descr
new file mode 100644
index 000000000000..c6f435c1c3e3
--- /dev/null
+++ b/net/py-novaclient/pkg-descr
@@ -0,0 +1,5 @@
+This is a client for the OpenStack Nova API. There's a Python
+API (the novaclient module), and a command-line script (nova).
+Each implements 100% of the OpenStack Nova API.
+
+WWW: http://pypi.python.org/pypi/python-novaclient