aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-26 04:17:24 +0800
committeraaron <aaron@FreeBSD.org>2006-05-26 04:17:24 +0800
commit2c3ee31d809a6bb415863643fea338f098d29514 (patch)
treed3b9d69fcf377250ffc954f5b4e36b8f51f179a5 /net
parent55284714d82ea1d56eedd4bd1658b7cbbf348eec (diff)
downloadfreebsd-ports-gnome-2c3ee31d809a6bb415863643fea338f098d29514.tar.gz
freebsd-ports-gnome-2c3ee31d809a6bb415863643fea338f098d29514.tar.zst
freebsd-ports-gnome-2c3ee31d809a6bb415863643fea338f098d29514.zip
Adding port net/p5-Net-Whois-IP, Perl extension for looking up the whois information for ip addresses
Approved by: tobez (implicit)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Whois-IP/Makefile22
-rw-r--r--net/p5-Net-Whois-IP/distinfo3
-rw-r--r--net/p5-Net-Whois-IP/pkg-descr7
-rw-r--r--net/p5-Net-Whois-IP/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 62d7bce1b243..68623be93c7e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -454,6 +454,7 @@
SUBDIR += p5-Net-Traceroute6
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
+ SUBDIR += p5-Net-Whois-IP
SUBDIR += p5-Net-Whois-RIPE
SUBDIR += p5-Net-Whois-Raw
SUBDIR += p5-Net-Write
diff --git a/net/p5-Net-Whois-IP/Makefile b/net/p5-Net-Whois-IP/Makefile
new file mode 100644
index 000000000000..178040104ecb
--- /dev/null
+++ b/net/p5-Net-Whois-IP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-Whois-IP
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Whois-IP
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for looking up the whois information for ip addresses
+
+MAN3= Net::Whois::IP.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Whois-IP/distinfo b/net/p5-Net-Whois-IP/distinfo
new file mode 100644
index 000000000000..ca48625da602
--- /dev/null
+++ b/net/p5-Net-Whois-IP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Whois-IP-1.01.tar.gz) = 653492738c0a7b3ae72f6ded3f7fe336
+SHA256 (Net-Whois-IP-1.01.tar.gz) = 70cd5562689e77b69800afc6094ff26d95fde36fdaf2a0d62801a44d5152e77f
+SIZE (Net-Whois-IP-1.01.tar.gz) = 4641
diff --git a/net/p5-Net-Whois-IP/pkg-descr b/net/p5-Net-Whois-IP/pkg-descr
new file mode 100644
index 000000000000..72921e6202bb
--- /dev/null
+++ b/net/p5-Net-Whois-IP/pkg-descr
@@ -0,0 +1,7 @@
+Perl module to allow whois lookup of ip addresses. This module should
+recursively query the various whois providers until it gets the more
+detailed information including either TechPhone or OrgTechPhone by
+default; however, this is overrideable.
+
+WWW: http://search.cpan.org/dist/Net-Whois-IP
+Author: Ben Schmitz <ben@foink.com>
diff --git a/net/p5-Net-Whois-IP/pkg-plist b/net/p5-Net-Whois-IP/pkg-plist
new file mode 100644
index 000000000000..41f86d24dc56
--- /dev/null
+++ b/net/p5-Net-Whois-IP/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Net/Whois/IP.pm
+%%SITE_PERL%%/auto/Net/Whois/IP/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois/IP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois/IP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/auto/Net/Whois/IP
+@dirrmtry %%SITE_PERL%%/auto/Net/Whois
+@dirrmtry %%SITE_PERL%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Whois
+@dirrmtry %%SITE_PERL%%/Net