aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2019-08-20 09:53:01 +0800
committerlwhsu <lwhsu@FreeBSD.org>2019-08-20 09:53:01 +0800
commit2c6fdff0e69b6158f046a1bfc644b2e26adae5a1 (patch)
tree6d1c1a3b54ab362f316ada23b4fd49381e06fa32 /net
parentbaa6904ac8f37002778f81c14b9b3550ca82d862 (diff)
downloadfreebsd-ports-gnome-2c6fdff0e69b6158f046a1bfc644b2e26adae5a1.tar.gz
freebsd-ports-gnome-2c6fdff0e69b6158f046a1bfc644b2e26adae5a1.tar.zst
freebsd-ports-gnome-2c6fdff0e69b6158f046a1bfc644b2e26adae5a1.zip
- Update to 0.5.2
Diffstat (limited to 'net')
-rw-r--r--net/libcmis/Makefile11
-rw-r--r--net/libcmis/distinfo5
-rw-r--r--net/libcmis/files/patch-configure16
-rw-r--r--net/libcmis/files/patch-src_libcmis_xml-utils.cxx21
-rw-r--r--net/libcmis/pkg-descr2
-rw-r--r--net/libcmis/pkg-plist2
6 files changed, 12 insertions, 45 deletions
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
index 0e4b9dbf87ce..d52a55ed3c6e 100644
--- a/net/libcmis/Makefile
+++ b/net/libcmis/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= libcmis
-PORTVERSION= 0.5.1
-PORTREVISION= 14
+PORTVERSION= 0.5.2
CATEGORIES= net devel
-MASTER_SITES= https://dev-www.libreoffice.org/src/
+MASTER_SITES= https://github.com/tdf/libcmis/releases/download/v${PORTVERSION}/
MAINTAINER= office@FreeBSD.org
COMMENT= Client library for the CMIS interface
@@ -16,9 +15,11 @@ BROKEN_sparc64= cannot link with boost
BUILD_DEPENDS= cppunit-config:devel/cppunit \
${LOCALBASE}/lib/libboost_regex.a:devel/boost-libs
-LIB_DEPENDS= libcurl.so:ftp/curl
+LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
+ libcurl.so:ftp/curl
-USES= compiler:c++11-lib gmake libtool pathfix pkgconfig
+USES= compiler:c++11-lib gmake gnome libtool localbase pathfix \
+ pkgconfig
USE_GNOME= libxml2
CONFIGURE_ARGS= --disable-werror --with-boost=${LOCALBASE} --without-man
diff --git a/net/libcmis/distinfo b/net/libcmis/distinfo
index aabbb7a337f3..a8d66de9773e 100644
--- a/net/libcmis/distinfo
+++ b/net/libcmis/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libcmis-0.5.1.tar.gz) = 6acbdf22ecdbaba37728729b75bfc085ee5a4b49a6024757cfb86ccd3da27b0e
-SIZE (libcmis-0.5.1.tar.gz) = 767701
+TIMESTAMP = 1565275967
+SHA256 (libcmis-0.5.2.tar.gz) = ed6f681a48abbf3c2324564b17a180d21fa9503230e8708825e1ad80daee4f81
+SIZE (libcmis-0.5.2.tar.gz) = 808619
diff --git a/net/libcmis/files/patch-configure b/net/libcmis/files/patch-configure
deleted file mode 100644
index d194beb4b6b3..000000000000
--- a/net/libcmis/files/patch-configure
+++ /dev/null
@@ -1,16 +0,0 @@
---- configure.orig 2013-02-12 18:02:16.000000000 -0500
-+++ configure 2013-02-12 18:03:06.000000000 -0500
-@@ -15694,13 +15694,6 @@
- CXXFLAGS="$CXXFLAGS -Werror"
-
- fi
--if test x"$GCC" = xyes; then :
--
-- # Be tough with warnings and produce less careless code
-- CFLAGS="$CFLAGS -Wall -pedantic -Wshadow -Wendif-labels -Wextra"
-- CXXFLAGS="$CXXFLAGS -Wall -pedantic -Weffc++ -Wshadow -Wendif-labels -Wextra -Wsign-promo -Woverloaded-virtual -Wnon-virtual-dtor -Wsign-promo"
--
--fi
-
- # Check for curl
-
diff --git a/net/libcmis/files/patch-src_libcmis_xml-utils.cxx b/net/libcmis/files/patch-src_libcmis_xml-utils.cxx
deleted file mode 100644
index fea40d5b2383..000000000000
--- a/net/libcmis/files/patch-src_libcmis_xml-utils.cxx
+++ /dev/null
@@ -1,21 +0,0 @@
-After https://github.com/boostorg/uuid/commit/33da3e2a5b87 build fails:
-
-xml-utils.cxx:34:10: fatal error: 'boost/uuid/sha1.hpp' file not found
-#include <boost/uuid/sha1.hpp>
- ^~~~~~~~~~~~~~~~~~~~~
-
---- src/libcmis/xml-utils.cxx.orig 2016-03-01 16:14:26 UTC
-+++ src/libcmis/xml-utils.cxx
-@@ -31,7 +31,12 @@
- #include <sstream>
- #include <stdlib.h>
-
-+#include <boost/version.hpp>
-+#if (BOOST_VERSION >= 106600)
-+#include <boost/uuid/detail/sha1.hpp>
-+#else
- #include <boost/uuid/sha1.hpp>
-+#endif
- #include <curl/curl.h>
-
- #include "xml-utils.hxx"
diff --git a/net/libcmis/pkg-descr b/net/libcmis/pkg-descr
index f54f84b5cd0e..b7ed0ee650b6 100644
--- a/net/libcmis/pkg-descr
+++ b/net/libcmis/pkg-descr
@@ -2,4 +2,4 @@ LibCMIS is a C++ client library for the CMIS interface. This allows C++
applications to connect to any ECM behaving as a CMIS server like Alfresco,
Nuxeo for the open source ones.
-WWW: https://sourceforge.net/projects/libcmis/
+WWW: https://github.com/tdf/libcmis
diff --git a/net/libcmis/pkg-plist b/net/libcmis/pkg-plist
index 7cc102fac1f0..7855116dfc31 100644
--- a/net/libcmis/pkg-plist
+++ b/net/libcmis/pkg-plist
@@ -3,6 +3,7 @@ include/libcmis-%%MAJVER%%/libcmis/allowable-actions.hxx
include/libcmis-%%MAJVER%%/libcmis/document.hxx
include/libcmis-%%MAJVER%%/libcmis/exception.hxx
include/libcmis-%%MAJVER%%/libcmis/folder.hxx
+include/libcmis-%%MAJVER%%/libcmis/libcmis-api.h
include/libcmis-%%MAJVER%%/libcmis/libcmis.hxx
include/libcmis-%%MAJVER%%/libcmis/oauth2-data.hxx
include/libcmis-%%MAJVER%%/libcmis/object-type.hxx
@@ -19,6 +20,7 @@ include/libcmis-c-%%MAJVER%%/libcmis-c/allowable-actions.h
include/libcmis-c-%%MAJVER%%/libcmis-c/document.h
include/libcmis-c-%%MAJVER%%/libcmis-c/error.h
include/libcmis-c-%%MAJVER%%/libcmis-c/folder.h
+include/libcmis-c-%%MAJVER%%/libcmis-c/libcmis-c-api.h
include/libcmis-c-%%MAJVER%%/libcmis-c/libcmis-c.h
include/libcmis-c-%%MAJVER%%/libcmis-c/oauth2-data.h
include/libcmis-c-%%MAJVER%%/libcmis-c/object-type.h