aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
committerPav Lucistnik <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
commit2df76eb0a73bb59d817aa60758a5f10e3e544c3b (patch)
tree07e10c49034b87755dafb03956ad93c5363e0bb7 /net
parent1c97f613254a72e0ae97ea8d817ebe38096d6949 (diff)
downloadfreebsd-ports-gnome-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.tar.gz
freebsd-ports-gnome-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.tar.zst
freebsd-ports-gnome-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.zip
- Remove support for a.out format and PORTOBJFORMAT variable from individual
ports With hat: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/ldapsdk/Makefile2
-rw-r--r--net/ldapsdk/pkg-plist2
-rw-r--r--net/pathchar/Makefile9
-rw-r--r--net/wb/Makefile9
4 files changed, 4 insertions, 18 deletions
diff --git a/net/ldapsdk/Makefile b/net/ldapsdk/Makefile
index 651c7075912b..f47eeb8bbc17 100644
--- a/net/ldapsdk/Makefile
+++ b/net/ldapsdk/Makefile
@@ -19,6 +19,7 @@ COMMENT= Mozilla LDAP sdk
WRKSRC= ${WRKDIR}/mozilla
MAKEFILE= ${WRKSRC}/directory/ldapsdk.mk
USE_GMAKE= yes
+USE_LDCONFIG= yes
USE_PERL5= yes
MAKE_ENV+= MOZILLA_CLIENT=1 NO_MDUPDATE=1 MOZ_LDAP_SDK=1
@@ -54,7 +55,6 @@ do-install:
${LN} -sf ${INSTALL_DIR}/include/mozldap.h ${PREFIX}/include
post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
@echo
@echo 'PLEASE NOTE (2000/8/23):'
@echo ' The mozilla lber and ldap libraries now are installed'
diff --git a/net/ldapsdk/pkg-plist b/net/ldapsdk/pkg-plist
index 82a7b328e472..b6c0af498448 100644
--- a/net/ldapsdk/pkg-plist
+++ b/net/ldapsdk/pkg-plist
@@ -19,5 +19,3 @@ lib/libmozldap.so.1
lib/libmozldap.so
lib/libmozlber.a
lib/libmozldap.a
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m /usr/local/lib
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
diff --git a/net/pathchar/Makefile b/net/pathchar/Makefile
index 483507aa25a7..3d4c5a7a7109 100644
--- a/net/pathchar/Makefile
+++ b/net/pathchar/Makefile
@@ -25,13 +25,6 @@ ONLY_FOR_ARCHS= i386
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAN8= pathchar.8
-.include <bsd.port.pre.mk>
-
-.if ${PORTOBJFORMAT} == "aout"
-DISTNAME= pathchar-a0-freebsd-2.2
-PORTVERSION= a0
-.endif
-
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -49,4 +42,4 @@ do-install:
${PREFIX}/share/doc/pathchar
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/wb/Makefile b/net/wb/Makefile
index 4f865b3f9338..83a0ce98bbd0 100644
--- a/net/wb/Makefile
+++ b/net/wb/Makefile
@@ -17,16 +17,11 @@ COMMENT= A shared drawing (whiteboard) tool using multicast
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
+STRIP=
# ghostscript, ghostscript3, ghostscript4 or ghostscript5 will all do.
USE_GHOSTSCRIPT_RUN= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-STRIP=
-.endif
-
pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
@${ECHO} ""
@@ -45,4 +40,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lblwb.ps ${PREFIX}/share/doc/wb
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>