aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-24 20:37:22 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-24 20:37:22 +0800
commit2fd4ebfe5587a3fd857771dee6d904957a21e571 (patch)
tree14ef2b4035b278bf3e518bcd8dec57cf2b340362 /net
parent3685233bed64dfc6153e37551ffef6ef5f797804 (diff)
downloadfreebsd-ports-gnome-2fd4ebfe5587a3fd857771dee6d904957a21e571.tar.gz
freebsd-ports-gnome-2fd4ebfe5587a3fd857771dee6d904957a21e571.tar.zst
freebsd-ports-gnome-2fd4ebfe5587a3fd857771dee6d904957a21e571.zip
add py-xmlrpc
A fast implementation of the xmlrpc spec for Python PR: 26769 Submitted by: Chang, Hye-Shik <perky@python.or.kr>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-xmlrpc/Makefile32
-rw-r--r--net/py-xmlrpc/distinfo1
-rw-r--r--net/py-xmlrpc/files/patch-setup.py11
-rw-r--r--net/py-xmlrpc/pkg-comment1
-rw-r--r--net/py-xmlrpc/pkg-descr9
-rw-r--r--net/py-xmlrpc/pkg-plist3
7 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a819bbb8b4ec..4b8143c6fa9e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -282,6 +282,7 @@
SUBDIR += proxy-suite
SUBDIR += pvm
SUBDIR += pvm++
+ SUBDIR += py-xmlrpc
SUBDIR += queso
SUBDIR += radius
SUBDIR += radiusclient
diff --git a/net/py-xmlrpc/Makefile b/net/py-xmlrpc/Makefile
new file mode 100644
index 000000000000..e113746ebee2
--- /dev/null
+++ b/net/py-xmlrpc/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-xmlrpc
+# Date created: 22 April 2001
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlrpc
+PORTVERSION= 0.8.2
+CATEGORIES= net python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= perky@python.or.kr
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
+
+do-build:
+ ${SETUP_CMD} build
+
+do-install:
+ ${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/net/py-xmlrpc/distinfo b/net/py-xmlrpc/distinfo
new file mode 100644
index 000000000000..03094559a72d
--- /dev/null
+++ b/net/py-xmlrpc/distinfo
@@ -0,0 +1 @@
+MD5 (py-xmlrpc-0.8.2.tar.gz) = bd484cd20b7b7a418222a39b39bb4c39
diff --git a/net/py-xmlrpc/files/patch-setup.py b/net/py-xmlrpc/files/patch-setup.py
new file mode 100644
index 000000000000..c20a56cdf9c0
--- /dev/null
+++ b/net/py-xmlrpc/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sun Apr 22 23:37:47 2001
++++ setup.py Sun Apr 22 23:37:55 2001
+@@ -4,7 +4,7 @@
+
+ import sys
+
+-if sys.platform[:5] == 'linux':
++if sys.platform[:7] == 'freebsd':
+ MACROS = {'define' : []}
+ LIBS = []
+ else:
diff --git a/net/py-xmlrpc/pkg-comment b/net/py-xmlrpc/pkg-comment
new file mode 100644
index 000000000000..11aa9aa8bdc5
--- /dev/null
+++ b/net/py-xmlrpc/pkg-comment
@@ -0,0 +1 @@
+A fast implementation of the xmlrpc spec for Python
diff --git a/net/py-xmlrpc/pkg-descr b/net/py-xmlrpc/pkg-descr
new file mode 100644
index 000000000000..9e75c2e96414
--- /dev/null
+++ b/net/py-xmlrpc/pkg-descr
@@ -0,0 +1,9 @@
+A very fast implementation of the xmlrpc spec
+for Python (written in C). It supports both blocking
+and non-blocking clients and servers on Windows and
+POSIX platforms. Version 0.8.1 is 100% compliant
+with the www.xmlrpc.com validator.
+
+WWW: http://sourceforge.net/projects/py-xmlrpc/
+
+- Hye Shik Chang, a.k.a. "Perky"
diff --git a/net/py-xmlrpc/pkg-plist b/net/py-xmlrpc/pkg-plist
new file mode 100644
index 000000000000..54b53df9f023
--- /dev/null
+++ b/net/py-xmlrpc/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/_xmlrpc.so
+%%PYTHON_SITELIBDIR%%/xmlrpc.py
+%%PYTHON_SITELIBDIR%%/xmlrpc.pyc