aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-08-01 04:27:38 +0800
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-08-01 04:27:38 +0800
commit2feee32f65c64873364997016a9aa8794fc9f5e0 (patch)
tree068f61f4ffdb052491f3f543cd6615d1f92f6f77 /net
parent423da2c5dd2af53c59fe7f45149ed7ed327ad054 (diff)
downloadfreebsd-ports-gnome-2feee32f65c64873364997016a9aa8794fc9f5e0.tar.gz
freebsd-ports-gnome-2feee32f65c64873364997016a9aa8794fc9f5e0.tar.zst
freebsd-ports-gnome-2feee32f65c64873364997016a9aa8794fc9f5e0.zip
kame-dhcp6 is an open-source implementation of Dynamic Host
Configuration Protocol for IPv6 (DHCPv6) developed by the KAME project. The implementation mainly conforms to the following standards: - RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6) - RFC3319: Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiation Protocol (SIP) Servers - RFC3633: IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) - RFC3646: DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Note that the current implementation does not support IPv6 address allocation by DHCPv6, and there is no plan to implement that feature at the moment. The main purpose of this implementation is to provide a way of IPv6 prefix delegation (RFC3633) and to provide some "stateless" configuration information such as DNS recursive server addresses. WWW: http://www.kame.net/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/dhcp6/Makefile39
-rw-r--r--net/dhcp6/distinfo2
-rw-r--r--net/dhcp6/pkg-descr22
-rw-r--r--net/dhcp6/pkg-plist9
5 files changed, 73 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e59ca4579059..a4c1dbd52dfd 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -91,6 +91,7 @@
SUBDIR += dgd-lpmud
SUBDIR += dgd-net
SUBDIR += dhcp-agent
+ SUBDIR += dhcp6
SUBDIR += dhcpdump
SUBDIR += dhcping
SUBDIR += dictd
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
new file mode 100644
index 000000000000..a42a60a020b4
--- /dev/null
+++ b/net/dhcp6/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dhcp6
+# Date created: 30 July 2004
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcp6
+PORTVERSION= 20040731a
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+DISTNAME= kame-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sumikawa@FreeBSD.org
+COMMENT= KAME DHCP6 client and server
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
+USE_REINPLACE= yes
+
+MAN5= dhcp6c.conf.5 dhcp6s.conf.5
+MAN8= dhcp6c.8 dhcp6s.8 dhcp6relay.8 dhcp6sctl.8
+
+post-patch:
+.for file in ${MAN5} ${MAN8}
+ ${REINPLACE_CMD} -e 's|/usr/local/v6/etc|${LOCALBASE}/etc|' \
+ ${WRKSRC}/${file}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/dhcp6c.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/dhcp6s.conf.sample ${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/net/dhcp6/distinfo b/net/dhcp6/distinfo
new file mode 100644
index 000000000000..b935b53c46b0
--- /dev/null
+++ b/net/dhcp6/distinfo
@@ -0,0 +1,2 @@
+MD5 (kame-dhcp6-20040731a.tar.gz) = 99bb4c5cece598ded90d874cfa68c431
+SIZE (kame-dhcp6-20040731a.tar.gz) = 158400
diff --git a/net/dhcp6/pkg-descr b/net/dhcp6/pkg-descr
new file mode 100644
index 000000000000..dce52f79d0d1
--- /dev/null
+++ b/net/dhcp6/pkg-descr
@@ -0,0 +1,22 @@
+kame-dhcp6 is an open-source implementation of Dynamic Host
+Configuration Protocol for IPv6 (DHCPv6) developed by the KAME
+project.
+
+The implementation mainly conforms to the following standards:
+
+- RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
+- RFC3319: Dynamic Host Configuration Protocol (DHCPv6) Options
+ for Session Initiation Protocol (SIP) Servers
+- RFC3633: IPv6 Prefix Options for Dynamic Host Configuration
+ Protocol (DHCP)
+- RFC3646: DNS Configuration options for Dynamic Host
+ Configuration Protocol for IPv6 (DHCPv6)
+
+Note that the current implementation does not support IPv6 address
+allocation by DHCPv6, and there is no plan to implement that feature
+at the moment. The main purpose of this implementation is to provide
+a way of IPv6 prefix delegation (RFC3633) and to provide some
+"stateless" configuration information such as DNS recursive server
+addresses.
+
+WWW: http://www.kame.net/
diff --git a/net/dhcp6/pkg-plist b/net/dhcp6/pkg-plist
new file mode 100644
index 000000000000..463a48fe5b5c
--- /dev/null
+++ b/net/dhcp6/pkg-plist
@@ -0,0 +1,9 @@
+sbin/dhcp6c
+sbin/dhcp6s
+sbin/dhcp6relay
+sbin/dhcp6sctl
+etc/dhcp6s.conf.sample
+etc/dhcp6c.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%@dirrm %%DOCSDIR%%