aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-10-15 21:56:59 +0800
committerRyan Steinmetz <zi@FreeBSD.org>2011-10-15 21:56:59 +0800
commit30af59e9486723426fe8384fc5480ee0e1bab518 (patch)
treed04dc062b88137ac7821f0c875dddd50a4d1285c /net
parent444f4cb73eb0e5fe697ec72cb4e58177cda9d4dd (diff)
downloadfreebsd-ports-gnome-30af59e9486723426fe8384fc5480ee0e1bab518.tar.gz
freebsd-ports-gnome-30af59e9486723426fe8384fc5480ee0e1bab518.tar.zst
freebsd-ports-gnome-30af59e9486723426fe8384fc5480ee0e1bab518.zip
- Update to 0.2.2
PR: ports/161131 Submitted by: "Beni Keller" <navigium@grindcore.ch> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/heybuddy/Makefile26
-rw-r--r--net/heybuddy/distinfo4
-rw-r--r--net/heybuddy/files/patch-heybuddy.py22
-rw-r--r--net/heybuddy/pkg-plist82
4 files changed, 85 insertions, 49 deletions
diff --git a/net/heybuddy/Makefile b/net/heybuddy/Makefile
index ee8e8939131e..c198413e21ca 100644
--- a/net/heybuddy/Makefile
+++ b/net/heybuddy/Makefile
@@ -6,31 +6,37 @@
#
PORTNAME= heybuddy
-PORTVERSION= 0.2.1
+PORTVERSION= 0.2.2
CATEGORIES= net
MASTER_SITES= http://launchpad.net/${PORTNAME}/0.2/${PORTVERSION}/+download/ \
http://freebsd.grindcore.ch/distfiles/
+EXTRACT_SUFX= .tgz
MAINTAINER= navigium@grindcore.ch
-COMMENT= Heybuddy is a supposedly light, feature free identi.ca client
-
-FETCH_ARGS= -Fpr
+COMMENT= A supposedly light, feature free identi.ca client
LICENSE= GPLv3
+FETCH_ARGS= -Fpr
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GNOME= pygtk2
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/heybuddy.py
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/heybuddy.py
+
do-build:
${PYTHON_CMD} -mcompileall ${WRKSRC}
do-install:
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR}
- ${LN} -s ${DATADIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
-
-post-install:
- ${RM} ${DATADIR}/*.txt ${DATADIR}/ChangeLog
+ @${RM} ${WRKSRC}/ChangeLog ${WRKSRC}/gpl-3.0.txt
+ @${MV} ${WRKSRC}/*.bak ${WRKDIR}
+ @${MV} ${WRKSRC}/*.orig ${WRKDIR}
+ @${MV} ${WRKSRC}/locales ${WRKDIR}
+ @${MV} ${WRKSRC}/${PORTNAME}.py ${WRKDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR})
+ (cd ${WRKDIR}/locales && ${COPYTREE_SHARE} . ${PREFIX}/share/locale)
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/net/heybuddy/distinfo b/net/heybuddy/distinfo
index 1cc9e269b7ba..d4d41090f37e 100644
--- a/net/heybuddy/distinfo
+++ b/net/heybuddy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (heybuddy-0.2.1.tar.gz) = 15a5bf1a09ba1e2c37c9ebc341563bac60d0d265a78b8995925ceab49b9e3ba5
-SIZE (heybuddy-0.2.1.tar.gz) = 65726
+SHA256 (heybuddy-0.2.2.tgz) = 4bcc26cecb374bacce0dce401d29e2d8d6e9ac5c3c931e1288347d6cde4e4ce1
+SIZE (heybuddy-0.2.2.tgz) = 77455
diff --git a/net/heybuddy/files/patch-heybuddy.py b/net/heybuddy/files/patch-heybuddy.py
new file mode 100644
index 000000000000..9df8174c6e77
--- /dev/null
+++ b/net/heybuddy/files/patch-heybuddy.py
@@ -0,0 +1,22 @@
+--- ./heybuddy.py.orig 2011-10-15 07:34:58.000000000 -0400
++++ ./heybuddy.py 2011-10-15 07:38:40.000000000 -0400
+@@ -21,9 +21,7 @@
+ import sys, os
+ import gettext
+ import webbrowser
+-locale_dir = os.path.join(
+- os.path.dirname( os.path.realpath(__file__) ),
+- 'locales')
++locale_dir = '%%PREFIX%%/share/locale'
+
+ gettext.bindtextdomain('heybuddy', locale_dir)
+ gettext.textdomain('heybuddy')
+@@ -107,7 +105,7 @@
+ self.last_get_statuses = 0
+ #what are the assets?
+ asset_dir = 'assets'
+- heybuddy_dir = os.path.dirname( os.path.realpath( __file__ ) )
++ heybuddy_dir = '%%DATADIR%%'
+ self.readme_file = os.path.join(heybuddy_dir,'README.txt')
+ self.standard_icon_path = os.path.join(heybuddy_dir,asset_dir,'icon.png')
+ self.direct_icon_path = os.path.join(heybuddy_dir,asset_dir,'direct_icon.png')
diff --git a/net/heybuddy/pkg-plist b/net/heybuddy/pkg-plist
index 5746ce4ac70d..051efe4e3100 100644
--- a/net/heybuddy/pkg-plist
+++ b/net/heybuddy/pkg-plist
@@ -1,54 +1,62 @@
@comment $FreeBSD$
bin/heybuddy
-%%DATADIR%%/assets/icon1.png
-%%DATADIR%%/assets/icon.png
-%%DATADIR%%/assets/throbber.gif
-%%DATADIR%%/assets/icon64.png
-%%DATADIR%%/assets/direct_icon.png
-%%DATADIR%%/assets/icon.svg
-%%DATADIR%%/assets/icon14.png
-%%DATADIR%%/ImageCache.pyc
-%%DATADIR%%/Configuration.py
-%%DATADIR%%/ImageCache.py
-%%DATADIR%%/DentScroller.py
-%%DATADIR%%/heybuddy.py
-%%DATADIR%%/heybuddy.pyc
-%%DATADIR%%/DentScroller.pyc
+%%DATADIR%%/About.py
+%%DATADIR%%/About.pyc
+%%DATADIR%%/CertificateValidatingHTTPSHandler.py
+%%DATADIR%%/CertificateValidatingHTTPSHandler.pyc
+%%DATADIR%%/Communicator.py
%%DATADIR%%/Communicator.pyc
-%%DATADIR%%/PlatformSpecific.py
+%%DATADIR%%/Configuration.py
%%DATADIR%%/Configuration.pyc
%%DATADIR%%/ContextPage.py
-%%DATADIR%%/MainWindow.py
-%%DATADIR%%/XMLProcessor.pyc
-%%DATADIR%%/Notify.pyc
-%%DATADIR%%/Communicator.py
%%DATADIR%%/ContextPage.pyc
%%DATADIR%%/Dent.py
-%%DATADIR%%/StatusIcon.pyc
-%%DATADIR%%/About.pyc
-%%DATADIR%%/PlatformSpecific.pyc
-%%DATADIR%%/_dev/get_text
-%%DATADIR%%/_dev/heybuddy.pot
-%%DATADIR%%/UserPage.py
-%%DATADIR%%/ScrollPage.py
-%%DATADIR%%/SettingsPage.py
-%%DATADIR%%/GroupPage.pyc
+%%DATADIR%%/Dent.pyc
%%DATADIR%%/DentButton.py
-%%DATADIR%%/Notify.py
+%%DATADIR%%/DentButton.pyc
+%%DATADIR%%/DentScroller.py
+%%DATADIR%%/DentScroller.pyc
+%%DATADIR%%/FilterFrame.py
%%DATADIR%%/FilterFrame.pyc
-%%DATADIR%%/ScrollPage.pyc
%%DATADIR%%/GroupPage.py
+%%DATADIR%%/GroupPage.pyc
+%%DATADIR%%/ImageCache.py
+%%DATADIR%%/ImageCache.pyc
+%%DATADIR%%/MainWindow.py
%%DATADIR%%/MainWindow.pyc
+%%DATADIR%%/Notify.py
+%%DATADIR%%/Notify.pyc
+%%DATADIR%%/PlatformSpecific.py
+%%DATADIR%%/PlatformSpecific.pyc
+%%DATADIR%%/README.txt
+%%DATADIR%%/ScrollPage.py
+%%DATADIR%%/ScrollPage.pyc
+%%DATADIR%%/SettingsPage.py
%%DATADIR%%/SettingsPage.pyc
-%%DATADIR%%/DentButton.pyc
%%DATADIR%%/StatusIcon.py
-%%DATADIR%%/FilterFrame.py
+%%DATADIR%%/StatusIcon.pyc
+%%DATADIR%%/UserPage.py
%%DATADIR%%/UserPage.pyc
-%%DATADIR%%/Dent.pyc
%%DATADIR%%/XMLProcessor.py
-%%DATADIR%%/About.py
-@dirrm %%DATADIR%%/_dev
+%%DATADIR%%/XMLProcessor.pyc
+%%DATADIR%%/_dev/get_text
+%%DATADIR%%/_dev/heybuddy.pot
+%%DATADIR%%/assets/direct_icon.png
+%%DATADIR%%/assets/icon.png
+%%DATADIR%%/assets/icon.svg
+%%DATADIR%%/assets/icon1.png
+%%DATADIR%%/assets/icon14.png
+%%DATADIR%%/assets/icon64.png
+%%DATADIR%%/assets/throbber.gif
+%%DATADIR%%/heybuddy.pyc
+share/locale/da/LC_MESSAGES/heybuddy.mo
+share/locale/de/LC_MESSAGES/heybuddy.mo
+share/locale/el/LC_MESSAGES/heybuddy.mo
+share/locale/eo/LC_MESSAGES/heybuddy.mo
+share/locale/es/LC_MESSAGES/heybuddy.mo
+share/locale/gl/LC_MESSAGES/heybuddy.mo
+share/locale/pt/LC_MESSAGES/heybuddy.mo
+share/locale/pt_BR/LC_MESSAGES/heybuddy.mo
@dirrm %%DATADIR%%/assets
-@dirrm %%DATADIR%%/locales
+@dirrm %%DATADIR%%/_dev
@dirrm %%DATADIR%%
-@exec mkdir -p %D%/%%DATADIR%%/locales