aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-17 17:41:52 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-17 17:41:52 +0800
commit30fcf656fffd07a7069d4e35b20c5ac29727abcb (patch)
tree22d039e13164090bd3df17a7ea4df7ba9abd9246 /net
parent6cea6ac11a5af0b3fdefc30ffead90ef081c7669 (diff)
downloadfreebsd-ports-gnome-30fcf656fffd07a7069d4e35b20c5ac29727abcb.tar.gz
freebsd-ports-gnome-30fcf656fffd07a7069d4e35b20c5ac29727abcb.tar.zst
freebsd-ports-gnome-30fcf656fffd07a7069d4e35b20c5ac29727abcb.zip
- Support staging
- Don't build with debug symbols
Diffstat (limited to 'net')
-rw-r--r--net/ncp/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/ncp/Makefile b/net/ncp/Makefile
index d2afa15d6bbe..f35a51d99493 100644
--- a/net/ncp/Makefile
+++ b/net/ncp/Makefile
@@ -11,18 +11,15 @@ COMMENT= A fast file copy tool for LANs
BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
-USE_BZIP2= yes
-MANCOMPRESSED= no
+USES= tar:bzip2
-MAN1= ncp.1 npush.1
-PLIST_FILES= bin/ncp bin/npush bin/npoll
+PLIST_FILES= bin/ncp bin/npush bin/npoll man/man1/ncp.1.gz man/man1/npush.1.gz
CFLAGS+= -I${LOCALBASE}/include/libowfat -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^CC=gcc|CC=${CC}|' \
${WRKSRC}/Makefile
@@ -32,9 +29,10 @@ post-patch:
${WRKSRC}/Makefile
do-install:
- cd ${WRKSRC}; ${INSTALL_PROGRAM} ncp ${PREFIX}/bin
- cd ${WRKSRC}; ${INSTALL_MAN} ncp.1 npush.1 ${PREFIX}/man/man1
- ${LN} -s ${PREFIX}/bin/ncp ${PREFIX}/bin/npush
- ${LN} -s ${PREFIX}/bin/ncp ${PREFIX}/bin/npoll
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncp ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ncp.1 ${WRKSRC}/npush.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${LN} -s ncp ${STAGEDIR}${PREFIX}/bin/npush
+ ${LN} -s ncp ${STAGEDIR}${PREFIX}/bin/npoll
.include <bsd.port.mk>