aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-23 06:31:00 +0800
committerPawel Pekala <pawel@FreeBSD.org>2014-12-23 06:31:00 +0800
commit342bdeaf979e9eb8a238473418f032413f2a7c3a (patch)
treeba1afd1b24cb19fe2bfda2f9552be3e1341ba4ee /net
parentf05c3f3ebb9dfb505db07e63bc6a1f1ca3a09ea3 (diff)
downloadfreebsd-ports-gnome-342bdeaf979e9eb8a238473418f032413f2a7c3a.tar.gz
freebsd-ports-gnome-342bdeaf979e9eb8a238473418f032413f2a7c3a.tar.zst
freebsd-ports-gnome-342bdeaf979e9eb8a238473418f032413f2a7c3a.zip
- Fix build with clang [1]
- Respect CXXFLAGS during build - Make RUN_DEPENDS path independent PR: 196088 [1] (based on) Submitted by: Real Huang <realhuang21@gmail.com> [1]
Diffstat (limited to 'net')
-rw-r--r--net/scribe/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index 0facaba5609f..05a7f3347f55 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
libthrift.so:${PORTSDIR}/devel/thrift-cpp
RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Thrift>0:${PORTSDIR}/devel/p5-Thrift \
- ${PYTHON_SITELIBDIR}/thrift/__init__.py:${PORTSDIR}/devel/py-thrift
+ ${PYTHON_PKGNAMEPREFIX}thrift>0:${PORTSDIR}/devel/py-thrift
GITVERSION= 7359a09
WRKSRC= ${WRKDIR}/facebookarchive-${PORTNAME}-${GITVERSION}
@@ -32,10 +32,22 @@ CONFIGURE_ARGS= --with-boost-filesystem=boost_filesystem \
PY_PREFIX="${PREFIX}"
USE_AUTOTOOLS= aclocal automake autoconf
USE_RC_SUBR= ${PORTNAME}
-USES= gmake perl5 python
+USES= compiler gmake perl5 python
post-patch:
- ${REINPLACE_CMD} -e 's/^AM_INIT_AUTOMAKE/#/' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e 's/^AM_INIT_AUTOMAKE/#/' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e '/boost/! s/shared_ptr/boost::&/g' \
+ ${WRKSRC}/src/conf.cpp \
+ ${WRKSRC}/src/conn_pool.cpp \
+ ${WRKSRC}/src/dynamic_bucket_updater.cpp \
+ ${WRKSRC}/src/env_default.cpp \
+ ${WRKSRC}/src/file.cpp \
+ ${WRKSRC}/src/scribe_server.cpp \
+ ${WRKSRC}/src/store.cpp \
+ ${WRKSRC}/src/store_queue.cpp
+
+post-configure:
+ @${REINPLACE_CMD} 's/-O3/${CXXFLAGS}/' ${WRKSRC}/src/Makefile
post-build:
${LOCALBASE}/bin/thrift -o ${WRKSRC} -I ${LOCALBASE}/share --gen "perl" ${WRKSRC}/if/scribe.thrift
@@ -48,8 +60,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-BROKEN= Does not build on FreeBSD 10.0+
+.if ${COMPILER_TYPE} == clang
+USE_CXXSTD= c++11
.endif
.include <bsd.port.post.mk>