aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-12-22 21:57:16 +0800
committergarga <garga@FreeBSD.org>2005-12-22 21:57:16 +0800
commit3511d1b975dc798c9533cecb9d15cfc01aeaa62c (patch)
treec8f71fc32e6125edba4276fdc16530092d12188d /net
parentb5a08257e040af04ee4c3bcd31f4df906fef4e24 (diff)
downloadfreebsd-ports-gnome-3511d1b975dc798c9533cecb9d15cfc01aeaa62c.tar.gz
freebsd-ports-gnome-3511d1b975dc798c9533cecb9d15cfc01aeaa62c.tar.zst
freebsd-ports-gnome-3511d1b975dc798c9533cecb9d15cfc01aeaa62c.zip
Pathneck is an active probing tool that can detect bottleneck location of
network path. It only needs single end control, and has relatively small probing overhead (33.6KB for one probing in the default setting). WWW: http://gs274.sp.cs.cmu.edu/www/pathneck/ PR: ports/90801 Submitted by: Babak Farrokhi <babak@farrokhi.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pathneck/Makefile39
-rw-r--r--net/pathneck/distinfo3
-rw-r--r--net/pathneck/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 842b820f232d..cac99034bcc7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -521,6 +521,7 @@
SUBDIR += p5-perl-ldap
SUBDIR += passlogd
SUBDIR += pathchar
+ SUBDIR += pathneck
SUBDIR += pbnc
SUBDIR += pchar
SUBDIR += pcnfsd
diff --git a/net/pathneck/Makefile b/net/pathneck/Makefile
new file mode 100644
index 000000000000..3edd51923515
--- /dev/null
+++ b/net/pathneck/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pathneck
+# Date Created: 22 Dec 2005
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pathneck
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= http://gs274.sp.cs.cmu.edu/www/pathneck/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Active network path probing tool
+
+PLIST_FILES= sbin/pathneck \
+ sbin/get-choke
+PORTDOCS= COPYING ChangeLog README
+MAKEFILE= Makefile.bsd
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC .=,CC ?=,' \
+ -e 's,^CFLAGS .=,CFLAGS +=,' \
+ ${WRKSRC}/Makefile.bsd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pathneck ${PREFIX}/sbin/pathneck
+ ${INSTALL_PROGRAM} ${WRKSRC}/get-choke ${PREFIX}/sbin/get-choke
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pathneck/distinfo b/net/pathneck/distinfo
new file mode 100644
index 000000000000..3491fb3780b0
--- /dev/null
+++ b/net/pathneck/distinfo
@@ -0,0 +1,3 @@
+MD5 (pathneck-1.2.tgz) = 24c5af803e2b8128d67dd5d84f13ae1a
+SHA256 (pathneck-1.2.tgz) = abacbe19461ba22a2668c1bfbed2406d7760f9053d0ea2b0c7866bffc98ff600
+SIZE (pathneck-1.2.tgz) = 28484
diff --git a/net/pathneck/pkg-descr b/net/pathneck/pkg-descr
new file mode 100644
index 000000000000..faf2ac868638
--- /dev/null
+++ b/net/pathneck/pkg-descr
@@ -0,0 +1,6 @@
+Pathneck is an active probing tool that can detect bottleneck location of
+network path.
+It only needs single end control, and has relatively small probing overhead
+(33.6KB for one probing in the default setting).
+
+WWW: http://gs274.sp.cs.cmu.edu/www/pathneck/