aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-06-14 07:41:46 +0800
committerwxs <wxs@FreeBSD.org>2008-06-14 07:41:46 +0800
commit370e2646f9ba5642b4711429fb39b7ba15d9cb5e (patch)
treefaa18df3fdb4835ae3fb8f08bfdbcc058c8add5b /net
parent3ede4db549586e2f73f579916bd011f7925d6ae4 (diff)
downloadfreebsd-ports-gnome-370e2646f9ba5642b4711429fb39b7ba15d9cb5e.tar.gz
freebsd-ports-gnome-370e2646f9ba5642b4711429fb39b7ba15d9cb5e.tar.zst
freebsd-ports-gnome-370e2646f9ba5642b4711429fb39b7ba15d9cb5e.zip
Add httpry:
"httpry is a specialized packet sniffer designed for displaying and logging HTTP traffic. It is not intended to perform analysis itself, but to capture, parse, and log the traffic for later analysis. It can be run in real-time displaying the traffic as it is parsed, or as a daemon process that logs to an output file. It is written to be as lightweight and flexible as possible, so that it can be easily adaptable to different applications." WWW: http://dumpsterventures.com/jason/httpry/ Submitted by: Richard Bejtlich (private mail)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/httpry/Makefile50
-rw-r--r--net/httpry/distinfo3
-rw-r--r--net/httpry/files/httpry.in30
-rw-r--r--net/httpry/files/patch-Makefile12
-rw-r--r--net/httpry/pkg-descr8
-rw-r--r--net/httpry/pkg-plist26
7 files changed, 130 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index eecc69424b05..acd62c089995 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -213,6 +213,7 @@
SUBDIR += htpdate
SUBDIR += http_ping
SUBDIR += httping
+ SUBDIR += httpry
SUBDIR += iaxmodem
SUBDIR += icmpinfo
SUBDIR += icpld
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
new file mode 100644
index 000000000000..32f50c310c15
--- /dev/null
+++ b/net/httpry/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: httpry
+# Date created: 12 June 2008
+# Whom: Wesley Shields <wxs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpry
+PORTVERSION= 0.1.3
+CATEGORIES= net
+MASTER_SITES= http://dumpsterventures.com/jason/httpry/
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Packet sniffer designed for displaying and logging HTTP traffic
+
+MAN1= httpry.1
+
+USE_RC_SUBR= httpry
+
+OPTIONS= EXTRASCRIPTS "Install additional scripts" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXTRASCRIPTS)
+PLIST_SUB= EXTRASCRIPTS=""
+USE_PERL5_RUN= yes
+RUN_DEPENDS= ${SITE_PERL}/IO/Compress/Gzip.pm:${PORTSDIR}/archivers/p5-IO-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.else
+PLIST_SUB= EXTRASCRIPTS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's#^(\/etc.*)#${PREFIX}\1#' ${WRKSRC}/scripts/process_logs
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+.if defined(WITH_EXTRASCRIPTS)
+ ${MKDIR} ${PREFIX}/bin/httpry-scripts
+ (cd ${WRKSRC}/scripts/ && \
+ ${COPYTREE_BIN} \* ${PREFIX}/bin/httpry-scripts "! -name *.bak")
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/perl-tools ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/format-string ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/httpry/distinfo b/net/httpry/distinfo
new file mode 100644
index 000000000000..c40dee798ebe
--- /dev/null
+++ b/net/httpry/distinfo
@@ -0,0 +1,3 @@
+MD5 (httpry-0.1.3.tar.gz) = 3d91e672272054e0bebd9ef9bab38a50
+SHA256 (httpry-0.1.3.tar.gz) = ca3c464a95f4b70b9b857e0df7288bdab7eaa95d0a0f26a096e0cb01fb068ea0
+SIZE (httpry-0.1.3.tar.gz) = 40720
diff --git a/net/httpry/files/httpry.in b/net/httpry/files/httpry.in
new file mode 100644
index 000000000000..f01f9b04ccbc
--- /dev/null
+++ b/net/httpry/files/httpry.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: httpry
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable httpry:
+#
+# httpry_enable (bool): Set it to "YES" to enable httpry
+# Default is "NO".
+# httpry_flags (flags): Set extra flags to httpry
+# Default is "-d -q -o /var/log/httpry.log".
+# See httpry(1) for more information.
+#
+
+. %%RC_SUBR%%
+
+name=httpry
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${httpry_enable="NO"}
+: ${httpry_flags="-d -q -o /var/log/httpry.log"}
+
+command=%%PREFIX%%/bin/httpry
+
+run_rc_command "$1"
diff --git a/net/httpry/files/patch-Makefile b/net/httpry/files/patch-Makefile
new file mode 100644
index 000000000000..6c1bc281aa66
--- /dev/null
+++ b/net/httpry/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- ./Makefile.orig 2008-02-08 00:48:09.000000000 -0500
++++ ./Makefile 2008-06-12 18:53:14.000000000 -0400
+@@ -6,8 +6,7 @@
+ # Copyright (c) 2005-2008 Jason Bittel <jason.bittel@gmail.com>
+ #
+
+-CC = gcc
+-CCFLAGS = -Wall -O3 -funroll-loops -I/usr/include/pcap -I/usr/local/include/pcap
++CCFLAGS = ${CFLAGS} -I/usr/include/pcap -I/usr/local/include/pcap
+ DEBUGFLAGS = -Wall -g -DDEBUG -I/usr/include/pcap -I/usr/local/include/pcap
+ LIBS = -lpcap
+ PROG = httpry
diff --git a/net/httpry/pkg-descr b/net/httpry/pkg-descr
new file mode 100644
index 000000000000..e3f3dbaace3e
--- /dev/null
+++ b/net/httpry/pkg-descr
@@ -0,0 +1,8 @@
+"httpry is a specialized packet sniffer designed for displaying and logging
+HTTP traffic. It is not intended to perform analysis itself, but to capture,
+parse, and log the traffic for later analysis. It can be run in real-time
+displaying the traffic as it is parsed, or as a daemon process that logs to an
+output file. It is written to be as lightweight and flexible as possible, so
+that it can be easily adaptable to different applications."
+
+WWW: http://dumpsterventures.com/jason/httpry/
diff --git a/net/httpry/pkg-plist b/net/httpry/pkg-plist
new file mode 100644
index 000000000000..944bcf8d4899
--- /dev/null
+++ b/net/httpry/pkg-plist
@@ -0,0 +1,26 @@
+bin/httpry
+%%EXTRASCRIPTS%%bin/httpry-scripts/parse_log.pl
+%%EXTRASCRIPTS%%bin/httpry-scripts/rotate_log.pl
+%%EXTRASCRIPTS%%bin/httpry-scripts/process_logs
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.mysql
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/find_proxies.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/content_analysis.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/hostnames.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/search_terms.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/find_proxies.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/log_summary.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.css
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/hostnames.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/xml_output.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/db_dump.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/content_analysis.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/search_terms.cfg
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/sample_plugin.pm
+%%EXTRASCRIPTS%%bin/httpry-scripts/plugins/log_summary.cfg
+%%PORTDOCS%%%%DOCSDIR%%/perl-tools
+%%PORTDOCS%%%%DOCSDIR%%/format-string
+%%EXTRASCRIPTS%%@dirrm bin/httpry-scripts/plugins
+%%EXTRASCRIPTS%%@dirrm bin/httpry-scripts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%