aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
committerwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
commit37b062ed62665ace31e4373b458cc75681213764 (patch)
treeb8f38166d53aef4457fc65f9d36d8ee0e550e5ce /net
parenta60ff5681296acc284a5fdc038a18ac26c9daef4 (diff)
downloadfreebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.gz
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.zst
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.zip
Attempt to fix conflicts with a local getopt.h (specifically, the fix is
for libgnugetopt's getopt.h). Not tested, but should work.
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork2/Makefile2
-rw-r--r--net/kdenetwork3/Makefile2
-rw-r--r--net/kdenetwork4/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/kdenetwork2/Makefile b/net/kdenetwork2/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork2/Makefile
+++ b/net/kdenetwork2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes