aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-31 03:31:57 +0800
committerChris Rees <crees@FreeBSD.org>2011-10-31 03:31:57 +0800
commit3c16f745ed57efe6a6a8dd5f07b0ec1b73e5ed89 (patch)
treefa5d37d898690c21e687de49b3afb1eb4efb9449 /net
parent05283844eb5ab0883da459f4e09770d0e4b20df7 (diff)
downloadfreebsd-ports-gnome-3c16f745ed57efe6a6a8dd5f07b0ec1b73e5ed89.tar.gz
freebsd-ports-gnome-3c16f745ed57efe6a6a8dd5f07b0ec1b73e5ed89.tar.zst
freebsd-ports-gnome-3c16f745ed57efe6a6a8dd5f07b0ec1b73e5ed89.zip
- Update to 1.0.7.1
- Re-enable MODSOUNDTOUCH-- no longer broken on amd64 - Add mod_zmq PR: ports/162143 Submitted by: Richard E Neese <r.neese@gmail.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch-core/Makefile23
-rw-r--r--net/freeswitch-core/distinfo16
-rw-r--r--net/freeswitch-core/pkg-plist2
3 files changed, 23 insertions, 18 deletions
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 8ee4c582ac33..16483ab7f7f0 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= freeswitch-core
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.7.1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://dl.dropbox.com/u/152504/ \
http://files.freeswitch.org/downloads/libs/:2 \
- http://download.zeromq.org/historic/:3
+ http://download.zeromq.org/:3
DISTFILES= ${BASE_PORTNAME}-${PORTVERSION}.tar.gz \
opus-0.9.0.tar.gz:2 \
celt-0.10.0.tar.gz:2 \
- flite-1.3.99-latest.tar.gz:2 \
+ flite-1.5.1-current.tar.bz2:2 \
json-c-0.9.tar.gz:2 \
lame-3.98.4.tar.gz:2 \
libmemcached-0.32.tar.gz:2 \
@@ -23,9 +23,10 @@ DISTFILES= ${BASE_PORTNAME}-${PORTVERSION}.tar.gz \
mpg123-1.13.2.tar.gz:2 \
openldap-2.4.11.tar.gz:2 \
pocketsphinx-0.7.tar.gz:2 \
- soundtouch-1.5.0.tar.gz:2 \
+ soundtouch-1.6.0.tar.gz:2 \
sphinxbase-0.7.tar.gz:2 \
- communicator_semi_6000_20080321.tar.gz:2
+ communicator_semi_6000_20080321.tar.gz:2 \
+ zeromq-2.1.10.tar.gz:3
DIST_SUBDIR= ${BASE_PORTNAME}
EXTRACT_ONLY= ${BASE_PORTNAME}-${PORTVERSION}.tar.gz
@@ -95,7 +96,7 @@ OPTIONS= MODSHOUT "Enable mod_shout (streaming audio/mp3)" on \
MODEASYROUTE "Enable mod_easyroute(routing tool)" on \
MODERLANGEVENT "Enable mod_erlang_event (Call Center Dist)" off \
MODLCR "Enable mod_lcr (least cost routing)" on \
- MODSOUNDTOUCH "Enable mod_soundtouch(Audio Effects)" off \
+ MODSOUNDTOUCH "Enable mod_soundtouch(Audio Effects)" on \
MODRSS "Enable mod_rss (rss feed reader)" on \
MODSNOM "Enable mod_snom (snom control)" on \
MODAVMD "Enable mod_avmd (Adavced v-mail detection)" on \
@@ -141,15 +142,13 @@ OPTIONS= MODSHOUT "Enable mod_shout (streaming audio/mp3)" on \
MODDPASTERISK "Enable mod_dialplan_asterisk(* dialplan)" off \
MODBLACKLIST "Enable mod_blacklist(Black list numbers)" on \
MODHTTPCACHE "Enable mod_http_cache(new)" on \
+ MODEVENTZMQ "Enable mod_event_zmq(build issues)(new)" on \
SAMPLECONFIGS "Enable Sample Configurations" on
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
-. if defined(WITH_MODSOUNDTOUCH)
-IGNORE= MODSOUNDTOUCH is broken on amd64, run make config and deselect
-. endif
.endif
.for i in MODFLITE MODPOCKETSPHINX MODCIDLOOKUP MODDPDIRECTORY MODEASYROUTE MODLCR MODSOUNDTOUCH MODRSS \
@@ -157,7 +156,7 @@ IGNORE= MODSOUNDTOUCH is broken on amd64, run make config and deselect
MODSAYDE MODSAYEN MODSAYES MODSAYFR MODSAYHE MODSAYHU MODSAYIT MODSAYNL MODSAYRU MODSAYTH MODSAYZH \
MODNIBBLEBILL MODDINGALING MODDIRECTORY MODMEMCACHE MODPASTREAM MODSHELLSTREAM MODSILK MODUNIMRCP \
MODTTSCMDLINE MODDISTRIBUTOR MODSNAPSHOT MODSKINNY EXTENSIONS MODCALLCENTER MODCODEC2 MODFSK MODOPUS \
- MODDPASTERISK MODRTMP SAMPLECONFIGS MODBLACKLIST MODHTTPCACHE
+ MODDPASTERISK MODRTMP SAMPLECONFIGS MODBLACKLIST MODHTTPCACHE MODEVENTZMQ
.if !defined(WITH_${i})
PLIST_SUB+= WITH_${i}="@comment "
.else
@@ -252,6 +251,7 @@ BROKEN= Requires lrintl, which is not present on FreeBSD 7
pre-configure:
@${REINPLACE_CMD} -e 's|base=http://files.freeswitch.org/downloads/libs/|base=file://${DISTDIR}/${DIST_SUBDIR}/|g' ${WRKSRC}/build/getlib.sh.in
+ @${REINPLACE_CMD} -e 's|2.1.9|2.1.10|g' ${WRKSRC}/src/mod/event_handlers/mod_event_zmq/Makefile
.if !defined(WITH_SAMPLECONFIGS)
@${REINPLACE_CMD} -e 's|$$(MAKE) samples-conf|##$$(MAKE) samples-conf|g' ${WRKSRC}/Makefile.am
.endif
@@ -325,6 +325,9 @@ post-configure:
.if !defined(WITH_MODDPASTERISK)
@${REINPLACE_CMD} -e 's|dialplans/mod_dialplan_asterisk|#dialplans/mod_dialplan_asterisk|g' ${WRKSRC}/modules.conf
.endif
+.if defined(WITH_MODEVENTZMQ)
+ @${REINPLACE_CMD} -e 's|#event_handlers/mod_event_zmq|event_handlers/mod_event_zmq|g' ${WRKSRC}/modules.conf
+.endif
pre-install:
@${CHMOD} 664 ${WRKSRC}/libs/freetdm/conf/*
diff --git a/net/freeswitch-core/distinfo b/net/freeswitch-core/distinfo
index 713b62cbce55..378f5506dd5b 100644
--- a/net/freeswitch-core/distinfo
+++ b/net/freeswitch-core/distinfo
@@ -1,11 +1,11 @@
-SHA256 (freeswitch/freeswitch-1.0.7.tar.gz) = 3ad0abfa104b9ba3ca630791a3d9a394cc2a20c000f099aa5bae245fe290dbb4
-SIZE (freeswitch/freeswitch-1.0.7.tar.gz) = 36116855
+SHA256 (freeswitch/freeswitch-1.0.7.1.tar.gz) = 180db5eb11bc35d383a143ee17ed15092ca1f0651afe93fe6fc2b7f7c35e4dbb
+SIZE (freeswitch/freeswitch-1.0.7.1.tar.gz) = 36116764
SHA256 (freeswitch/opus-0.9.0.tar.gz) = b2f75c4ac5ab837845eb028413fae2a28754bfb0a6d76416e2af1441ef447649
SIZE (freeswitch/opus-0.9.0.tar.gz) = 1255227
SHA256 (freeswitch/celt-0.10.0.tar.gz) = 147c5bc8c6a37b2ad2c8b8af17c91cb35494421ec9b68110018a4bcec72e45dc
SIZE (freeswitch/celt-0.10.0.tar.gz) = 435953
-SHA256 (freeswitch/flite-1.3.99-latest.tar.gz) = ac5832c7b654c5adf9ec3df0e8a7c817d2105233e11ce5aa7e97a8c6c8e14e13
-SIZE (freeswitch/flite-1.3.99-latest.tar.gz) = 17440698
+SHA256 (freeswitch/flite-1.5.1-current.tar.bz2) = 91dab10909efcc1ba1f6869e52f480226284467cf520abc75c725d6173caede2
+SIZE (freeswitch/flite-1.5.1-current.tar.bz2) = 15054556
SHA256 (freeswitch/json-c-0.9.tar.gz) = 816fb2d4baab09e2f51a7c1be75bc9e03ed09d4cf3c2cd03c183f433bb9b565f
SIZE (freeswitch/json-c-0.9.tar.gz) = 328935
SHA256 (freeswitch/lame-3.98.4.tar.gz) = ac3144c76617223a9be4aaa3e28a66b51bcab28141050c3af04cb06836f772c8
@@ -20,11 +20,11 @@ SHA256 (freeswitch/openldap-2.4.11.tar.gz) = 76e57147a2373015f306f2e72128330e51d
SIZE (freeswitch/openldap-2.4.11.tar.gz) = 4941654
SHA256 (freeswitch/pocketsphinx-0.7.tar.gz) = ce0cace1ab153006e631d0a15680f2ec13f289cb2ddafa20c84fb5986fe92455
SIZE (freeswitch/pocketsphinx-0.7.tar.gz) = 23701750
-SHA256 (freeswitch/soundtouch-1.5.0.tar.gz) = a1465b327f513ab3f75fbf5eba039a21568eebcf0dc18ce2809f874b5a79b1af
-SIZE (freeswitch/soundtouch-1.5.0.tar.gz) = 283273
+SHA256 (freeswitch/soundtouch-1.6.0.tar.gz) = 8776edaf7299ffe1e8c97285f020365a63c0e01aa4f6f7c5fd1d011c0ded278f
+SIZE (freeswitch/soundtouch-1.6.0.tar.gz) = 94852
SHA256 (freeswitch/sphinxbase-0.7.tar.gz) = 389cb99a545f7d615a2b3bc3f7362a490ca45fc4dc440140ae1d2a41f87773ec
SIZE (freeswitch/sphinxbase-0.7.tar.gz) = 3291922
SHA256 (freeswitch/communicator_semi_6000_20080321.tar.gz) = dbb5e9fb85000a7cb97d6958a3ef8d77532dc55fc730ac6979705e8645cb0c18
SIZE (freeswitch/communicator_semi_6000_20080321.tar.gz) = 5595694
-SHA256 (freeswitch/zeromq-2.1.9.zip) = 43e4044656968cee3313e71964b3e72c43bb81ea2f48071dc28cbf32ba5fd77f
-SIZE (freeswitch/zeromq-2.1.9.zip) = 2156026
+SHA256 (freeswitch/zeromq-2.1.10.tar.gz) = c6727ee334b572b25269c7fed24a926cde236b3655e22f21c057aad4df5a4b79
+SIZE (freeswitch/zeromq-2.1.10.tar.gz) = 1879075
diff --git a/net/freeswitch-core/pkg-plist b/net/freeswitch-core/pkg-plist
index 21f2e75d06d7..2c8cacbd5680 100644
--- a/net/freeswitch-core/pkg-plist
+++ b/net/freeswitch-core/pkg-plist
@@ -312,6 +312,8 @@ lib/freeswitch/mod/mod_esf.so
%%WITH_MODMULTICAST%%lib/freeswitch/mod/mod_event_multicast.so
lib/freeswitch/mod/mod_event_socket.la
lib/freeswitch/mod/mod_event_socket.so
+%%WITH_MODEVENTZMQ%%lib/freeswitch/mod/mod_event_zmq.la
+%%WITH_MODEVENTZMQ%%lib/freeswitch/mod/mod_event_zmq.so
lib/freeswitch/mod/mod_expr.la
lib/freeswitch/mod/mod_expr.so
lib/freeswitch/mod/mod_fifo.la