aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2015-04-16 19:18:41 +0800
committergarga <garga@FreeBSD.org>2015-04-16 19:18:41 +0800
commit3e3faa71cf98c96f49ba4ebfaacd81ed7ea83747 (patch)
tree1dfcbe090bd0256270fa1ccde3978d49545e7b6f /net
parentf58b050f64235cd0afc32070587e5789abdaf7e5 (diff)
downloadfreebsd-ports-gnome-3e3faa71cf98c96f49ba4ebfaacd81ed7ea83747.tar.gz
freebsd-ports-gnome-3e3faa71cf98c96f49ba4ebfaacd81ed7ea83747.tar.zst
freebsd-ports-gnome-3e3faa71cf98c96f49ba4ebfaacd81ed7ea83747.zip
- Modernize OPTIONS
- Remove old CONFIGURE_ARGS that are now invalid
Diffstat (limited to 'net')
-rw-r--r--net/tcpdump/Makefile52
1 files changed, 13 insertions, 39 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 84977e65a58f..aacf03cce710 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libpcap.so:${PORTSDIR}/net/libpcap
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
USES= gmake
UNPRIV_USER?= nobody
@@ -31,49 +31,23 @@ SMI_DESC= Allow MIBs to be loaded on the fly
USER_DESC= Drop privileges to nobody
CHROOT_DESC= Chroot to /var/run/tcpdump (set CHROOTDIR to change)
-.include <bsd.port.options.mk>
-
-CONFIGURE_ARGS+= --enable-pcap_setdirection --with-pcap_setdirection
-
-# The --without-crypto flag needs to be explicitly specified. The
-# configure script gets confused if you specify --with-crypto and
-# thinks this means you *don't* want crypto.
-#
-.if ${PORT_OPTIONS:MCRYPTO}
-USE_OPENSSL= yes
-.else
-CONFIGURE_ARGS+= --without-crypto
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.if empty(PORT_OPTIONS:MSMB)
-CONFIGURE_ARGS+= --disable-smb
-.endif
-
-.if ${PORT_OPTIONS:MSMI}
-LIB_DEPENDS+= libsmi.so:${PORTSDIR}/net-mgmt/libsmi
-.else
-CONFIGURE_ARGS+= --disable-smi
-.endif
-
-.if ${PORT_OPTIONS:MUSER}
-CONFIGURE_ARGS+= --with-user=${UNPRIV_USER}
-.endif
-
-.if ${PORT_OPTIONS:MCHROOT}
-CONFIGURE_ARGS+= --with-chroot=${CHROOTDIR}
-.endif
-
-.include <bsd.port.pre.mk>
+CRYPTO_USE= OPENSSL=yes
+CRYPTO_CONFIGURE_WITH= crypto
+IPV6_CONFIGURE_ENABLE= ipv6
+SMB_CONFIGURE_ENABLE= smb
+SMI_CONFIGURE_WITH= smi
+SMI_LIB_DEPENDS= libsmi.so:${PORTSDIR}/net-mgmt/libsmi
+USER_CONFIGURE_ON= --with-user=${UNPRIV_USER}
+CHROOT_CONFIGURE_ON= --with-chroot=${CHROOTDIR}
PLIST_FILES= sbin/tcpdump \
man/man1/tcpdump.1.gz
+.include <bsd.port.pre.mk>
+
post-configure:
- @${REINPLACE_CMD} -e "s,\./\.\./${LIBPCAP_FORCE_VER}/libpcap\.a,${LOCALBASE}/lib/libpcap.so.1," ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,\./\.\./${LIBPCAP_FORCE_VER}/libpcap\.a,${LOCALBASE}/lib/libpcap.so.1," \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${STAGEDIR}/${PREFIX}/sbin