aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2019-11-08 00:30:12 +0800
committerrene <rene@FreeBSD.org>2019-11-08 00:30:12 +0800
commit410b5e3f4582ae24645a58008adade1cc1d047a2 (patch)
treef77314253e5ba2ab7585e4cd0aabc08e41f880a0 /net
parent9e22daabca5ec68c79a9c424abd25081d87bef8f (diff)
downloadfreebsd-ports-gnome-410b5e3f4582ae24645a58008adade1cc1d047a2.tar.gz
freebsd-ports-gnome-410b5e3f4582ae24645a58008adade1cc1d047a2.tar.zst
freebsd-ports-gnome-410b5e3f4582ae24645a58008adade1cc1d047a2.zip
Clean up support for FreeBSD 11.2.
While here, modernize some comments in Mk/bsd.*.mk. Note that graphics/drm-fbsd11.2-kmod is not renamed yet, this was somewhat under discussion. Submitted by: rene Reviewed by: antoine, jbeich, mat, zeising Differential Revision: https://reviews.freebsd.org/D21974
Diffstat (limited to 'net')
-rw-r--r--net/mpd5/files/patch-src-Makefile33
-rw-r--r--net/zerotier/Makefile2
2 files changed, 13 insertions, 22 deletions
diff --git a/net/mpd5/files/patch-src-Makefile b/net/mpd5/files/patch-src-Makefile
index 6b1e64a4df0f..bab99faea158 100644
--- a/net/mpd5/files/patch-src-Makefile
+++ b/net/mpd5/files/patch-src-Makefile
@@ -1,6 +1,6 @@
---- src/Makefile.orig 2016-01-06 22:42:06.000000000 +0700
-+++ src/Makefile 2018-11-25 13:48:31.977979000 +0700
-@@ -9,10 +9,20 @@
+--- src/Makefile.orig 2019-10-10 18:24:28 UTC
++++ src/Makefile
+@@ -9,9 +9,11 @@
PROG?= mpd5
PREFIX?= /usr/local
@@ -9,20 +9,11 @@
VERSION= 5.8
-NOMAN=
+
-+.if defined(OSVERSION)
-+.if ${OSVERSION} > 1100100
-+MK_MAN= no
-+.else
-+NO_MAN=
-+.endif
-+.else
+MK_MAN= no
NO_MAN=
-+.endif
BINOWN!= /usr/bin/id -n -u
- BINGRP!= /usr/bin/id -n -g
-@@ -60,9 +70,6 @@
+@@ -59,9 +61,6 @@ USE_TCP_WRAP= yes
USE_AUTH_PAM= yes
USE_AUTH_SYSTEM= yes
@@ -32,7 +23,7 @@
# Build without builtin web server.
#NOWEB= yes
-@@ -72,7 +79,7 @@
+@@ -71,7 +70,7 @@ SYSLOG_FACILITY= LOG_DAEMON
# Print wide protocol names instead of short names.
# Comment this line, to save about 10 KB space
@@ -41,7 +32,7 @@
# Reduce some internal structures size to save more memory
# This is to limit amount of active sessions
-@@ -84,27 +91,27 @@
+@@ -83,27 +82,27 @@ COPTS+= -DPROTO_NAME_LIST
## filter TCP accept connections
LDADD+= -lwrap
DPADD+= ${LIBWRAP}
@@ -73,7 +64,7 @@
.endif
LDADD+= -lnetgraph -lutil
-@@ -113,19 +120,12 @@
+@@ -112,19 +111,12 @@ DPADD+= ${LIBNETGRAPH}
LDADD+= -L/usr/lib -lradius
DPADD+= ${LIBRADIUS}
@@ -97,7 +88,7 @@
-Wcast-align \
-Wchar-subscripts \
-Wformat \
-@@ -135,15 +135,14 @@
+@@ -134,15 +126,14 @@ COPTS+= -Wall \
-Wnested-externs \
-Wpointer-arith \
-Wwrite-strings \
@@ -116,7 +107,7 @@
.endif
# Standard sources
-@@ -155,14 +154,13 @@
+@@ -154,14 +145,13 @@ STDSRCS= assert.c auth.c bund.c rep.c ccp.c cha
util.c vars.c eap.c msoft.c ippool.c
.if defined ( NOWEB )
@@ -133,7 +124,7 @@
PDPATH1= contrib/libpdel/util:contrib/libpdel/structs
PDPATH2= contrib/libpdel/structs/type
.if defined ( NOWEB )
-@@ -200,60 +198,59 @@
+@@ -199,60 +189,59 @@ PDELSRCS+= http_connection.c \
string_fp.c \
timeout_fp.c
.endif
@@ -209,7 +200,7 @@
.endif
.endif
-@@ -262,46 +259,46 @@
+@@ -261,46 +250,46 @@ COPTS+= -DUSE_NG_PRED1
.if defined ( ECP_DES )
SRCS+= ecp_dese.c
SRCS+= ecp_dese_bis.c
@@ -267,7 +258,7 @@
.endif
# Add in required support files and libraries
-@@ -310,15 +307,12 @@
+@@ -309,15 +298,12 @@ DPADD+= ${LIBCRYPTO}
.if exists ( /usr/lib/libexecinfo.so )
LDADD+= -lexecinfo
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 8f803c2a88c4..1644d0b03a9a 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -32,7 +32,7 @@ PLIST_FILES= bin/zerotier-cli bin/zerotier-idtool sbin/zerotier-one
.if ${OPSYS} == "FreeBSD"
# log output via syslog when daemon(8) supports it
-.if ((${OSVERSION} >= 1100513 && ${OSVERSION} < 1200000) || ${OSVERSION} >= 1200015)
+.if (${OSVERSION} < 1200000 || ${OSVERSION} >= 1200015)
SUB_LIST+= ZEROTIER_SYSLOG="-s debug -T zerotier"
.else
SUB_LIST+= ZEROTIER_SYSLOG=""