aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 18:46:37 +0800
committeraz <az@FreeBSD.org>2013-07-26 18:46:37 +0800
commit425a912423003f8cf48eb9dc516a4d77b8a20cf2 (patch)
tree4e432cd7adf68b48f6abe895819485849ed8f886 /net
parent1079766f17b5d6a4c7cf98bd67a211c4e64e0017 (diff)
downloadfreebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.tar.gz
freebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.tar.zst
freebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'net')
-rw-r--r--net/p5-Filesys-SmbClient/Makefile8
-rw-r--r--net/p5-Net-Google-SafeBrowsing2/Makefile3
-rw-r--r--net/p5-Net-Google/Makefile8
-rw-r--r--net/p5-Net-SNPP/Makefile9
-rw-r--r--net/p5-POE-Component-Server-Twirc/Makefile2
-rw-r--r--net/p5-PlRPC/Makefile9
-rw-r--r--net/p5-Samba-LDAP/Makefile8
-rw-r--r--net/p5-ZeroMQ/Makefile2
-rw-r--r--net/tightvnc/Makefile11
-rw-r--r--net/tridiavnc/Makefile15
10 files changed, 25 insertions, 50 deletions
diff --git a/net/p5-Filesys-SmbClient/Makefile b/net/p5-Filesys-SmbClient/Makefile
index 4424a87317f6..2d0c7c39bf3a 100644
--- a/net/p5-Filesys-SmbClient/Makefile
+++ b/net/p5-Filesys-SmbClient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sysutils/p5-Filesys-SmbClient
-# Date created: August 10, 2003
-# Whom: Erwin Lansing <erwin@FreeBSD.org>
-#
+# Created by: Erwin Lansing <erwin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Filesys-SmbClient
PORTVERSION= 3.2
@@ -22,7 +18,7 @@ PERL_CONFIGURE= yes
MAN3= Filesys::SmbClient.3
post-patch:
- ${PERL} -pi -e 's!%%LOCALBASE%%!${LOCALBASE}!g' \
+ @${REINPLACE_CMD} -i '' -e 's!%%LOCALBASE%%!${LOCALBASE}!g' \
${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-SafeBrowsing2/Makefile b/net/p5-Net-Google-SafeBrowsing2/Makefile
index f812721d5845..2887e4744a37 100644
--- a/net/p5-Net-Google-SafeBrowsing2/Makefile
+++ b/net/p5-Net-Google-SafeBrowsing2/Makefile
@@ -58,7 +58,4 @@ BUILD_DEPENDS+= p5-DBD-Pg>=2:${PORTSDIR}/databases/p5-DBD-Pg
RUN_DEPENDS+= p5-DBD-Pg>=2:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-post-patch:
- @${PERL} -pi -e 's/CPAN/ExtUtils/' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/net/p5-Net-Google/Makefile b/net/p5-Net-Google/Makefile
index 9a262178c891..451be128c4df 100644
--- a/net/p5-Net-Google/Makefile
+++ b/net/p5-Net-Google/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Net-Google
-# Date created: 04 June 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Net-Google
PORTVERSION= 1.0.1
@@ -24,6 +20,6 @@ MAN3= Net::Google.3 Net::Google::Cache.3 Net::Google::Response.3 \
Net::Google::Spelling.3 Net::Google::tool.3
post-patch:
- @${PERL} -pi -e 's/CPAN/ExtUtils/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's/CPAN/ExtUtils/g' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/net/p5-Net-SNPP/Makefile b/net/p5-Net-SNPP/Makefile
index bda56850d09e..02137d90a0f1 100644
--- a/net/p5-Net-SNPP/Makefile
+++ b/net/p5-Net-SNPP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Net-SNPP
-# Date created: 6 Jun 2002
-# Whom: devin@spamcop.net
-#
+# Created by: devin@spamcop.net
# $FreeBSD$
-#
PORTNAME= Net-SNPP
PORTVERSION= 1.17
@@ -20,8 +16,7 @@ MAN3= Net::SNPP.3 \
Net::SNPP::Server.3
post-patch:
- @${PERL} -pi -e '$$_="" if /warnings/;' \
+ @${REINPLACE_CMD} -i '' -e '/warnings/d' \
${WRKSRC}/lib/Net/SNPP/Server.pm
- @${RM} ${WRKSRC}/lib/Net/SNPP/Server.pm.orig
.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Server-Twirc/Makefile b/net/p5-POE-Component-Server-Twirc/Makefile
index b79639d6819d..1d64617b2808 100644
--- a/net/p5-POE-Component-Server-Twirc/Makefile
+++ b/net/p5-POE-Component-Server-Twirc/Makefile
@@ -42,6 +42,6 @@ MAN3= App::Twirc.3 \
POE::Component::Server::Twirc.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/auto_install/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/net/p5-PlRPC/Makefile b/net/p5-PlRPC/Makefile
index afbaa883024c..dd2a0a87351d 100644
--- a/net/p5-PlRPC/Makefile
+++ b/net/p5-PlRPC/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-PlRPC
-# Date Created: 27 Feb 2000
-# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
-#
+# Created by: Vanilla I. Shu <vanilla@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= PlRPC
PORTVERSION= 0.2020
@@ -28,6 +24,7 @@ MAN3= Bundle::PlRPC.3 \
post-patch:
@${FIND} ${WRKSRC} -name ".svn" | ${XARGS} ${RM} -rf
- @${PERL} -pi -e 's/perldoc -t/echo perldoc -t/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's/perldoc -t/echo perldoc -t/' \
+ ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/net/p5-Samba-LDAP/Makefile b/net/p5-Samba-LDAP/Makefile
index a8ac7cc035ed..b4041625c8ba 100644
--- a/net/p5-Samba-LDAP/Makefile
+++ b/net/p5-Samba-LDAP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Samba-LDAP
-# Date created: 2006-09-18
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Samba-LDAP
PORTVERSION= 0.05
@@ -35,6 +31,6 @@ MAN3= Samba::LDAP.3 Samba::LDAP::Base.3 Samba::LDAP::Config.3 \
Samba::LDAP::User.3
post-patch:
- ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/auto_install/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/net/p5-ZeroMQ/Makefile b/net/p5-ZeroMQ/Makefile
index fa268ee0f5ff..6eb28893f262 100644
--- a/net/p5-ZeroMQ/Makefile
+++ b/net/p5-ZeroMQ/Makefile
@@ -47,6 +47,6 @@ TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
.endif
post-patch:
- @${PERL} -pi -e "s/lib => 'zmq',//" ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e "s/lib => 'zmq',//" ${WRKSRC}/Makefile.PL
.include <bsd.port.post.mk>
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 4e06e1311140..6847c4c72e9e 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -22,7 +22,8 @@ CONFLICTS= tridiavnc-[0-9]* vnc-[0-9]*
WRKSRC= ${WRKDIR}/vnc_unixsrc
-USES= imake
+USES= imake shebangfix
+SHEBANG_FILES= vncserver
CFLAGS+= -Wno-return-type
USE_GCC= yes
USE_BZIP2= yes
@@ -61,11 +62,11 @@ IGNORE= vnc has already been installed, please uninstall it first
post-patch:
.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def
- @${PERL} -pi -e "s,%%LOCALBASE%%,${PREFIX},g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -i '' -e "s|%%LOCALBASE%%|${PREFIX}|g" ${WRKSRC}/${file}
.endfor
- @${PERL} -pi -e "s,/usr/local/vnc/classes,${DATADIR}/classes,g ; \
- s,^#!/usr/bin/perl,#!${PERL},g" ${WRKSRC}/vncserver
- @${PERL} -pi -e "s,%%CC%%,${CC},g ; \
+ @${REINPLACE_CMD} -i '' -e "s|/usr/local/vnc/classes|${DATADIR}/classes|g" \
+ ${WRKSRC}/vncserver
+ @${REINPLACE_CMD} -i '' -e "s|%%CC%%|${CC}|g ; \
s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Xvnc/config/cf/FreeBSD.cf
do-install:
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
index 5ddfe23054ad..86d05a030d80 100644
--- a/net/tridiavnc/Makefile
+++ b/net/tridiavnc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tridiavnc
-# Date created: 14 June 2001
-# Whom: dwcjr
-#
+# Created by: dwcjr
# $FreeBSD$
-#
PORTNAME= tridiavnc
PORTVERSION= 1.4
@@ -21,7 +17,8 @@ LICENSE= GPLv2
USE_PERL5= yes
WRKSRC= ${WRKDIR}/unix/vnc_unixsrc
-USES= imake
+USES= imake shebangfix
+SHEBANG_FILES= vncserver
USE_XORG= ice sm x11 xaw xext xmu xt xpm
ALL_TARGET= World
NO_INSTALL_MANPAGES= yes
@@ -47,10 +44,10 @@ PLIST_SUB+= XVNC=""
post-patch:
.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def Xvnc/config/cf/Imake.tmpl
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/${file}
.endfor
- @${PERL} -pi -e "s,/usr/local/vnc/classes,${DATADIR}/classes,g ; \
- s,^#!/usr/bin/perl,#!${PERL},g" ${WRKSRC}/vncserver
+ ${REINPLACE_CMD} -i '' -e 's|/usr/local/vnc/classes|${DATADIR}/classes|' \
+ ${WRKSRC}/vncserver
# We have to frob a few things, and we want our own permissions, so it's easier
# to do the install ourselves.