aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-06-17 22:48:39 +0800
committermi <mi@FreeBSD.org>2007-06-17 22:48:39 +0800
commit42704ed216c0b47a610eb2f94507acba1cd2c406 (patch)
tree283daa043a35e778428e4700985b4a2e09372448 /net
parentf530c376d282cc12dbbb84d69afe4b7ad806549f (diff)
downloadfreebsd-ports-gnome-42704ed216c0b47a610eb2f94507acba1cd2c406.tar.gz
freebsd-ports-gnome-42704ed216c0b47a610eb2f94507acba1cd2c406.tar.zst
freebsd-ports-gnome-42704ed216c0b47a610eb2f94507acba1cd2c406.zip
Always use -fPIC, when building shared libraries. Apparently, this is
not always required on i386. While here, remove requirements for particular shlib-versions of the dependencies. Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/opal/Makefile16
-rw-r--r--net/opal3/Makefile16
2 files changed, 14 insertions, 18 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 3f9a39f14257..f6aefcd8e7cb 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= tar.gz
MAINTAINER= jbq@caraldi.com
COMMENT= VoIP abstraction library
-LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
+LIB_DEPENDS= pt_r:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
@@ -34,22 +34,20 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-# Avoid build error on 64-bit architectures
-.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+# Be sure to compile position-independent objects for the shared libraries
CFLAGS+= -fPIC
-.endif
.ifdef (WITH_FFMPEG)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+=--enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.endif
.ifdef (WITH_SPEEX)
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex
BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
-CONFIGURE_ARGS+= --enable-localspeex=no
+CONFIGURE_ARGS+=--enable-localspeex=no
.else
-CONFIGURE_ARGS+= --enable-localspeex=yes
+CONFIGURE_ARGS+=--enable-localspeex=yes
.endif
.include <bsd.port.post.mk>
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 3f9a39f14257..f6aefcd8e7cb 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= tar.gz
MAINTAINER= jbq@caraldi.com
COMMENT= VoIP abstraction library
-LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
+LIB_DEPENDS= pt_r:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
@@ -34,22 +34,20 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-# Avoid build error on 64-bit architectures
-.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+# Be sure to compile position-independent objects for the shared libraries
CFLAGS+= -fPIC
-.endif
.ifdef (WITH_FFMPEG)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+=--enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.endif
.ifdef (WITH_SPEEX)
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex
BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
-CONFIGURE_ARGS+= --enable-localspeex=no
+CONFIGURE_ARGS+=--enable-localspeex=no
.else
-CONFIGURE_ARGS+= --enable-localspeex=yes
+CONFIGURE_ARGS+=--enable-localspeex=yes
.endif
.include <bsd.port.post.mk>