aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-19 11:55:32 +0800
committerclsung <clsung@FreeBSD.org>2006-07-19 11:55:32 +0800
commit4344524af81732477d0cc1fe4ed949699faaa5ed (patch)
tree67414242aaa0e9a110aa71f4b22dcbbbb88f290a /net
parentb8d25789771ff5bf6b419139391a74cb57a7c6b8 (diff)
downloadfreebsd-ports-gnome-4344524af81732477d0cc1fe4ed949699faaa5ed.tar.gz
freebsd-ports-gnome-4344524af81732477d0cc1fe4ed949699faaa5ed.tar.zst
freebsd-ports-gnome-4344524af81732477d0cc1fe4ed949699faaa5ed.zip
Add p5-Net-CSTA 0.03, perl extension for ECMA CSTA.
PR: ports/100506 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-CSTA/Makefile31
-rw-r--r--net/p5-Net-CSTA/distinfo3
-rw-r--r--net/p5-Net-CSTA/pkg-descr6
-rw-r--r--net/p5-Net-CSTA/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 35b86b5c439c..2de971d46d90 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -414,6 +414,7 @@
SUBDIR += p5-Net-BGP
SUBDIR += p5-Net-Blogger
SUBDIR += p5-Net-CIDR-Lite
+ SUBDIR += p5-Net-CSTA
SUBDIR += p5-Net-DHCP
SUBDIR += p5-Net-DHCPClient
SUBDIR += p5-Net-DLookup
diff --git a/net/p5-Net-CSTA/Makefile b/net/p5-Net-CSTA/Makefile
new file mode 100644
index 000000000000..f2febed09a81
--- /dev/null
+++ b/net/p5-Net-CSTA/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-CSTA
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-CSTA
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for ECMA CSTA
+
+RUN_DEPENDS= ${SITE_PERL}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::CSTA.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500701
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-CSTA/distinfo b/net/p5-Net-CSTA/distinfo
new file mode 100644
index 000000000000..265316a01f9e
--- /dev/null
+++ b/net/p5-Net-CSTA/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-CSTA-0.03.tar.gz) = 719e975f512bd3bbb6d1985dc846e861
+SHA256 (Net-CSTA-0.03.tar.gz) = 643f9794e428118a09df89c84fec1cea4d6de7d9f704c9451f2e94f377747c9f
+SIZE (Net-CSTA-0.03.tar.gz) = 10167
diff --git a/net/p5-Net-CSTA/pkg-descr b/net/p5-Net-CSTA/pkg-descr
new file mode 100644
index 000000000000..6f3a03f14a40
--- /dev/null
+++ b/net/p5-Net-CSTA/pkg-descr
@@ -0,0 +1,6 @@
+ECMA CSTA is an ASN.1 based protocol for Computer Integrated Telephony
+(CTI) using CSTA it is possible to write code that communicates with a
+PBX. Typical applications include receiving notifications for incoming
+calls, placing calls, redirecting calls or placing conference calls.
+
+WWW: http://search.cpan.org/dist/Net-CSTA/
diff --git a/net/p5-Net-CSTA/pkg-plist b/net/p5-Net-CSTA/pkg-plist
new file mode 100644
index 000000000000..f7923402f035
--- /dev/null
+++ b/net/p5-Net-CSTA/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CSTA/.packlist
+%%SITE_PERL%%/Net/CSTA.pm
+%%SITE_PERL%%/Net/CSTA/ASN.pm
+%%SITE_PERL%%/auto/Net/CSTA/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CSTA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/CSTA
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/auto/Net/CSTA
+@dirrmtry %%SITE_PERL%%/auto/Net