aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-19 05:30:29 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-19 05:30:29 +0800
commit452f97d97f89d5e81edb6292e4ebd87fede39503 (patch)
tree09bb63a9788ad51a624defb9c6383162f31168ca /net
parent32ef7aa49fe09917a230eef831fdcd3e42715115 (diff)
downloadfreebsd-ports-gnome-452f97d97f89d5e81edb6292e4ebd87fede39503.tar.gz
freebsd-ports-gnome-452f97d97f89d5e81edb6292e4ebd87fede39503.tar.zst
freebsd-ports-gnome-452f97d97f89d5e81edb6292e4ebd87fede39503.zip
- Add p5-MaxMind-DB-Reader 0.050003
MaxMind::DB::Reader provides functionality to read MaxMind DB files. WWW: http://search.cpan.org/dist/MaxMind-DB-Reader/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-MaxMind-DB-Reader/Makefile39
-rw-r--r--net/p5-MaxMind-DB-Reader/distinfo2
-rw-r--r--net/p5-MaxMind-DB-Reader/pkg-descr3
-rw-r--r--net/p5-MaxMind-DB-Reader/pkg-plist26
5 files changed, 71 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dd56423f6d4a..fa1df5e239d8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -540,6 +540,7 @@
SUBDIR += p5-JavaScript-RPC
SUBDIR += p5-Jifty-Plugin-Authentication-Ldap
SUBDIR += p5-MaxMind-DB-Common
+ SUBDIR += p5-MaxMind-DB-Reader
SUBDIR += p5-Net
SUBDIR += p5-Net-AMQP
SUBDIR += p5-Net-APNS
diff --git a/net/p5-MaxMind-DB-Reader/Makefile b/net/p5-MaxMind-DB-Reader/Makefile
new file mode 100644
index 000000000000..75190e3edd6d
--- /dev/null
+++ b/net/p5-MaxMind-DB-Reader/Makefile
@@ -0,0 +1,39 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MaxMind-DB-Reader
+PORTVERSION= 0.050.003
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DROLSKY
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Read MaxMind DB files
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Data-IEEE754>=0:${PORTSDIR}/devel/p5-Data-IEEE754 \
+ p5-Data-Printer>=0:${PORTSDIR}/devel/p5-Data-Printer \
+ p5-Data-Validate-IP>=0.16:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Math-Int128>=0:${PORTSDIR}/math/p5-Math-Int128 \
+ p5-MaxMind-DB-Common>=0.031.000:${PORTSDIR}/net/p5-MaxMind-DB-Common \
+ p5-Module-Implementation>=0:${PORTSDIR}/devel/p5-Module-Implementation \
+ p5-Moo>=1.003000:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-StrictConstructor>=0:${PORTSDIR}/devel/p5-MooX-StrictConstructor \
+ p5-Net-Works>=0:${PORTSDIR}/net/p5-Net-Works \
+ p5-Role-Tiny>=0:${PORTSDIR}/devel/p5-Role-Tiny \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Bits>=0:${PORTSDIR}/devel/p5-Test-Bits \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-MaxMind-DB-Reader/distinfo b/net/p5-MaxMind-DB-Reader/distinfo
new file mode 100644
index 000000000000..74276185b512
--- /dev/null
+++ b/net/p5-MaxMind-DB-Reader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MaxMind-DB-Reader-0.050003.tar.gz) = 4d5b0a7886a233eed6bd232064906f0a1104f1e0d4e5482c5a04b1a57bf7077c
+SIZE (MaxMind-DB-Reader-0.050003.tar.gz) = 73164
diff --git a/net/p5-MaxMind-DB-Reader/pkg-descr b/net/p5-MaxMind-DB-Reader/pkg-descr
new file mode 100644
index 000000000000..1a4a02665424
--- /dev/null
+++ b/net/p5-MaxMind-DB-Reader/pkg-descr
@@ -0,0 +1,3 @@
+MaxMind::DB::Reader provides functionality to read MaxMind DB files.
+
+WWW: http://search.cpan.org/dist/MaxMind-DB-Reader/
diff --git a/net/p5-MaxMind-DB-Reader/pkg-plist b/net/p5-MaxMind-DB-Reader/pkg-plist
new file mode 100644
index 000000000000..5c5b4837fbf1
--- /dev/null
+++ b/net/p5-MaxMind-DB-Reader/pkg-plist
@@ -0,0 +1,26 @@
+bin/mmdb-dump-database
+bin/mmdb-dump-metadata
+bin/mmdb-dump-search-tree
+bin/mmdb-verify-database
+%%SITE_PERL%%/MaxMind/DB/Reader.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Data/Container.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Data/EndMarker.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Decoder.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/PP.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Role/HasDecoder.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Role/HasMetadata.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Role/NodeReader.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Role/Reader.pm
+%%SITE_PERL%%/MaxMind/DB/Reader/Role/Sysreader.pm
+%%SITE_PERL%%/MaxMind/DB/Verifier.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB/Reader/.packlist
+%%PERL5_MAN3%%/MaxMind::DB::Reader.3.gz
+%%PERL5_MAN3%%/MaxMind::DB::Reader::PP.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB/Reader
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind
+@dirrm %%SITE_PERL%%/MaxMind/DB/Reader/Role
+@dirrm %%SITE_PERL%%/MaxMind/DB/Reader/Data
+@dirrm %%SITE_PERL%%/MaxMind/DB/Reader
+@dirrmtry %%SITE_PERL%%/MaxMind/DB
+@dirrmtry %%SITE_PERL%%/MaxMind