aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2016-11-25 00:01:51 +0800
committercy <cy@FreeBSD.org>2016-11-25 00:01:51 +0800
commit4554e9e2faf75a83fde6d83e715726822d3f7bf3 (patch)
treee2b61e6cfa4db80b4afcefeba2000907d1b10e51 /net
parent4f244acbeff537f40f8d1512dfb469727eb870d4 (diff)
downloadfreebsd-ports-gnome-4554e9e2faf75a83fde6d83e715726822d3f7bf3.tar.gz
freebsd-ports-gnome-4554e9e2faf75a83fde6d83e715726822d3f7bf3.tar.zst
freebsd-ports-gnome-4554e9e2faf75a83fde6d83e715726822d3f7bf3.zip
Unbreak Makefile, set up appropriate support for BROKEN.
As suggested by koobs, describe error in BROKEN=.
Diffstat (limited to 'net')
-rw-r--r--net/ntp/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 03c2ad89d84d..3aa5960b7578 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -13,10 +13,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/}
MAINTAINER= cy@FreeBSD.org
COMMENT= The Network Time Protocol Distribution
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BROKEN= Does not build under FreeBSD-9
-.endif
-
BUILD_DEPENDS= autogen:devel/autogen
LIB_DEPENDS= libevent.so:devel/libevent2 \
libmd5.so:www/libwww
@@ -68,6 +64,12 @@ THREADS_CONFIGURE_WITH= threads
${D}_CONFIGURE_ON= --enable-${D}
.endfor
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+BROKEN= Does not build under FreeBSD-9, aclocal not found
+.endif
+
# XXX Temporary hack. Remember to remove this next commit.
post-extract:
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
@@ -81,4 +83,4 @@ post-install:
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>