aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-05-23 15:41:41 +0800
committerAlex Dupre <ale@FreeBSD.org>2012-05-23 15:41:41 +0800
commit455d41725d99664dfc2df6322f63c0fbfac9c215 (patch)
tree8ad5dc4ed18e2a518bc6bb53cac289b75da2dc70 /net
parentdae8d81cd5adb952f338f9012798398441f9ae0c (diff)
downloadfreebsd-ports-gnome-455d41725d99664dfc2df6322f63c0fbfac9c215.tar.gz
freebsd-ports-gnome-455d41725d99664dfc2df6322f63c0fbfac9c215.tar.zst
freebsd-ports-gnome-455d41725d99664dfc2df6322f63c0fbfac9c215.zip
Fix for php 5.4.
Diffstat (limited to 'net')
-rw-r--r--net/pecl-radius/Makefile2
-rw-r--r--net/pecl-radius/files/patch-radius.c11
2 files changed, 11 insertions, 2 deletions
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
index 95b0bcfd84e4..40d8974b0b64 100644
--- a/net/pecl-radius/Makefile
+++ b/net/pecl-radius/Makefile
@@ -18,8 +18,6 @@ COMMENT= Radius client library for PHP
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-radius
diff --git a/net/pecl-radius/files/patch-radius.c b/net/pecl-radius/files/patch-radius.c
new file mode 100644
index 000000000000..f7208cfd4141
--- /dev/null
+++ b/net/pecl-radius/files/patch-radius.c
@@ -0,0 +1,11 @@
+--- radius.c.orig 2012-05-23 09:36:48.000000000 +0200
++++ radius.c 2012-05-23 09:37:04.000000000 +0200
+@@ -62,7 +62,7 @@
+ *
+ * Every user visible function must have an entry in radius_functions[].
+ */
+-function_entry radius_functions[] = {
++zend_function_entry radius_functions[] = {
+ PHP_FE(radius_auth_open, NULL)
+ PHP_FE(radius_acct_open, NULL)
+ PHP_FE(radius_close, NULL)