aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-31 23:23:13 +0800
committermat <mat@FreeBSD.org>2016-03-31 23:23:13 +0800
commit47384b7b765d30db8a3f19efbc728da56db408c1 (patch)
treea7da32f6c0064d6be598b00d61f30117a3f396dd /net
parent7d34bddd896fa9a7fe8636ebc3af9f081ede5884 (diff)
downloadfreebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.tar.gz
freebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.tar.zst
freebsd-ports-gnome-47384b7b765d30db8a3f19efbc728da56db408c1.zip
Cleanup dependencies on lang/p5-Scalar-List-Utils.
The different cases are: - Only bring it if the one bundled with Perl is outdated. - The version bundled with all our Perl is sufficient. - Scalar-List-Util is not really needed by the port. (looking for /(Sub|Scalar|List)::Util/ returns nothing.) While there, do some minor cleanup that caught my eye. PR: 208378 With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/p5-Kafka/Makefile11
-rw-r--r--net/p5-MaxMind-DB-Reader/Makefile10
2 files changed, 17 insertions, 4 deletions
diff --git a/net/p5-Kafka/Makefile b/net/p5-Kafka/Makefile
index 77de76154c72..9fa1af05489f 100644
--- a/net/p5-Kafka/Makefile
+++ b/net/p5-Kafka/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Kafka
PORTVERSION= 0.8010
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SGLADKOV
@@ -22,7 +23,6 @@ BUILD_DEPENDS= p5-Compress-Snappy>=0:${PORTSDIR}/archivers/p5-Compress-Snappy \
p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32 \
p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
p5-Sys-SigAction>=0:${PORTSDIR}/devel/p5-Sys-SigAction \
- p5-Scalar-List-Utils>=1:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-Scalar-Util-Numeric>=0:${PORTSDIR}/devel/p5-Scalar-Util-Numeric \
p5-Data-HexDump-Range>=0:${PORTSDIR}/devel/p5-Data-HexDump-Range
@@ -31,4 +31,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.38:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.38:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-MaxMind-DB-Reader/Makefile b/net/p5-MaxMind-DB-Reader/Makefile
index c4bf8efabe73..57332b1f24c7 100644
--- a/net/p5-MaxMind-DB-Reader/Makefile
+++ b/net/p5-MaxMind-DB-Reader/Makefile
@@ -3,6 +3,7 @@
PORTNAME= MaxMind-DB-Reader
PORTVERSION= 1.000009
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MAXMIND
@@ -27,7 +28,6 @@ BUILD_DEPENDS= p5-Data-IEEE754>=0:${PORTSDIR}/devel/p5-Data-IEEE754 \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Path-Class>=0.27:${PORTSDIR}/devel/p5-Path-Class \
- p5-Scalar-List-Utils>=1.42:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-Test-Bits>=0:${PORTSDIR}/devel/p5-Test-Bits \
p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta \
@@ -37,4 +37,10 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502300
+TEST_DEPENDS+= p5-Scalar-List-Utils>=1.42:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>