aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-01-29 14:36:24 +0800
committermiwi <miwi@FreeBSD.org>2011-01-29 14:36:24 +0800
commit47430c38a6745484b5dea3d3716798d85dafd694 (patch)
tree10b34c23fcdc7640aab313b1361a7b707169637d /net
parentd076d8ba12e7beecc2e416a0b867fdfe2debb857 (diff)
downloadfreebsd-ports-gnome-47430c38a6745484b5dea3d3716798d85dafd694.tar.gz
freebsd-ports-gnome-47430c38a6745484b5dea3d3716798d85dafd694.tar.zst
freebsd-ports-gnome-47430c38a6745484b5dea3d3716798d85dafd694.zip
This is Perl interface for communication with Nessus scanner over XMLRPC.
You can start, stop, pause and resume scan. Watch progress and status of scan, download report, etc. WWW: http://www.cpan.org/modules/by-authors/id/K/KO/KOST PR: ports/154346 Submitted by: Paul Schmehl <pauls at utdallas.edu> Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Nessus-XMLRPC/Makefile23
-rw-r--r--net/p5-Net-Nessus-XMLRPC/distinfo2
-rw-r--r--net/p5-Net-Nessus-XMLRPC/pkg-descr5
-rw-r--r--net/p5-Net-Nessus-XMLRPC/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a19b7ec430e7..4cbc7f404b11 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -606,6 +606,7 @@
SUBDIR += p5-Net-NBsocket
SUBDIR += p5-Net-NIS
SUBDIR += p5-Net-NIS-Listgroup
+ SUBDIR += p5-Net-Nessus-XMLRPC
SUBDIR += p5-Net-OAuth
SUBDIR += p5-Net-OAuth-Simple
SUBDIR += p5-Net-OpenDHT
diff --git a/net/p5-Net-Nessus-XMLRPC/Makefile b/net/p5-Net-Nessus-XMLRPC/Makefile
new file mode 100644
index 000000000000..703a3e69d2c9
--- /dev/null
+++ b/net/p5-Net-Nessus-XMLRPC/Makefile
@@ -0,0 +1,23 @@
+# ports collection makefile for: perl extension for connectiong to a Nessus server
+# Date created: 25 January 2011
+# Whom: Paul Schmehl <pauls@utdallas.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Nessus-XMLRPC
+PORTVERSION= 0.30
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/K/KO/KOST
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pauls@utdallas.edu
+COMMENT= Perl5 interface for communication with Nessus scanner over XMLRPC
+
+RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+PERL_CONFIGURE= yes
+
+MAN3= Net::Nessus::XMLRPC.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Nessus-XMLRPC/distinfo b/net/p5-Net-Nessus-XMLRPC/distinfo
new file mode 100644
index 000000000000..d525d9dba2cc
--- /dev/null
+++ b/net/p5-Net-Nessus-XMLRPC/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Nessus-XMLRPC-0.30.tar.gz) = 69bf9416c346bce5e509461249497120472ce22459c65ae80f73ce5b047aa9f5
+SIZE (Net-Nessus-XMLRPC-0.30.tar.gz) = 8338
diff --git a/net/p5-Net-Nessus-XMLRPC/pkg-descr b/net/p5-Net-Nessus-XMLRPC/pkg-descr
new file mode 100644
index 000000000000..78a5a2c9821f
--- /dev/null
+++ b/net/p5-Net-Nessus-XMLRPC/pkg-descr
@@ -0,0 +1,5 @@
+This is Perl interface for communication with Nessus scanner over XMLRPC.
+You can start, stop, pause and resume scan. Watch progress and status of
+scan, download report, etc.
+
+WWW: http://www.cpan.org/modules/by-authors/id/K/KO/KOST
diff --git a/net/p5-Net-Nessus-XMLRPC/pkg-plist b/net/p5-Net-Nessus-XMLRPC/pkg-plist
new file mode 100644
index 000000000000..a090ae6e1e4f
--- /dev/null
+++ b/net/p5-Net-Nessus-XMLRPC/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/Nessus/XMLRPC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Nessus/XMLRPC/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Nessus/XMLRPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Nessus
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Nessus
+@dirrmtry %%SITE_PERL%%/Net