aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /net
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'net')
-rw-r--r--net/Makefile4
-rw-r--r--net/php55-ldap/Makefile10
-rw-r--r--net/php55-soap/Makefile10
-rw-r--r--net/php55-soap/files/patch-soap.c56
-rw-r--r--net/php55-sockets/Makefile10
-rw-r--r--net/php55-xmlrpc/Makefile10
6 files changed, 100 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 00183541378e..1ff3055fec07 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -868,6 +868,10 @@
SUBDIR += php53-soap
SUBDIR += php53-sockets
SUBDIR += php53-xmlrpc
+ SUBDIR += php55-ldap
+ SUBDIR += php55-soap
+ SUBDIR += php55-sockets
+ SUBDIR += php55-xmlrpc
SUBDIR += phpldapadmin
SUBDIR += pimdd
SUBDIR += pipsecd
diff --git a/net/php55-ldap/Makefile b/net/php55-ldap/Makefile
new file mode 100644
index 000000000000..784bef55a0f0
--- /dev/null
+++ b/net/php55-ldap/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -ldap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php55-soap/Makefile b/net/php55-soap/Makefile
new file mode 100644
index 000000000000..0fe20cdf7379
--- /dev/null
+++ b/net/php55-soap/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -soap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php55-soap/files/patch-soap.c b/net/php55-soap/files/patch-soap.c
new file mode 100644
index 000000000000..b81d1b8cac02
--- /dev/null
+++ b/net/php55-soap/files/patch-soap.c
@@ -0,0 +1,56 @@
+--- soap.c.orig 2012-03-02 15:46:04.000000000 +0100
++++ soap.c 2012-03-02 15:45:38.000000000 +0100
+@@ -23,7 +23,7 @@
+ #include "config.h"
+ #endif
+ #include "php_soap.h"
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ #include "ext/session/php_session.h"
+ #endif
+ #include "zend_exceptions.h"
+@@ -1639,7 +1639,7 @@
+ soap_obj = service->soap_object;
+ function_table = &((Z_OBJCE_P(soap_obj))->function_table);
+ } else if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If persistent then set soap_obj from from the previous created session (if available) */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap;
+@@ -1722,7 +1722,7 @@
+ }
+ efree(class_name);
+ }
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If session then update session hash with new object */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap_pp;
+@@ -1820,7 +1820,7 @@
+ if (service->type == SOAP_CLASS || service->type == SOAP_OBJECT) {
+ call_status = call_user_function(NULL, &soap_obj, &function_name, retval, num_params, params TSRMLS_CC);
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ zval_ptr_dtor(&soap_obj);
+ soap_obj = NULL;
+@@ -1845,7 +1845,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {
+@@ -1887,7 +1887,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {
diff --git a/net/php55-sockets/Makefile b/net/php55-sockets/Makefile
new file mode 100644
index 000000000000..7ea541d8a959
--- /dev/null
+++ b/net/php55-sockets/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -sockets
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php55-xmlrpc/Makefile b/net/php55-xmlrpc/Makefile
new file mode 100644
index 000000000000..4b7e997ac624
--- /dev/null
+++ b/net/php55-xmlrpc/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xmlrpc
+
+.include "${MASTERDIR}/Makefile"