aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2006-08-24 08:58:24 +0800
committersobomax <sobomax@FreeBSD.org>2006-08-24 08:58:24 +0800
commit4c7a0c69e624140282c93bd761870edc1f9eb70e (patch)
treeaa5f5c7f27790bd6fbb967b4123797ab496e52cc /net
parent3c68f3019f6cf3d5314a10555357d19858688849 (diff)
downloadfreebsd-ports-gnome-4c7a0c69e624140282c93bd761870edc1f9eb70e.tar.gz
freebsd-ports-gnome-4c7a0c69e624140282c93bd761870edc1f9eb70e.tar.zst
freebsd-ports-gnome-4c7a0c69e624140282c93bd761870edc1f9eb70e.zip
Fix crash caused by the recent BIND upgrade from version 8 to version 9.
Submitted by: David G. Lawrence
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile2
-rw-r--r--net/asterisk/files/patch-Makefile9
-rw-r--r--net/asterisk10/Makefile2
-rw-r--r--net/asterisk10/files/patch-Makefile9
-rw-r--r--net/asterisk12/Makefile2
-rw-r--r--net/asterisk12/files/patch-Makefile9
-rw-r--r--net/asterisk14/Makefile2
-rw-r--r--net/asterisk14/files/patch-Makefile9
-rw-r--r--net/asterisk16/Makefile2
-rw-r--r--net/asterisk16/files/patch-Makefile9
10 files changed, 35 insertions, 20 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 9a8f636d9677..a5c0982ab70a 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
diff --git a/net/asterisk/files/patch-Makefile b/net/asterisk/files/patch-Makefile
index 879d944fd9e4..6b482dfc0268 100644
--- a/net/asterisk/files/patch-Makefile
+++ b/net/asterisk/files/patch-Makefile
@@ -1,5 +1,8 @@
---- Makefile.orig Wed Jun 14 11:59:17 2006
-+++ Makefile Wed Jun 14 13:54:57 2006
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -71,7 +74,7 @@
INCLUDE+=-Iinclude -I../include
-ASTCFLAGS+=-pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
-ASTCFLAGS+=$(OPTIMIZE)
-+ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
++ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE -DMAKE_VALGRIND_HAPPY
+#ASTCFLAGS+=$(OPTIMIZE)
ASTOBJ=-o asterisk
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 9a8f636d9677..a5c0982ab70a 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
diff --git a/net/asterisk10/files/patch-Makefile b/net/asterisk10/files/patch-Makefile
index 879d944fd9e4..6b482dfc0268 100644
--- a/net/asterisk10/files/patch-Makefile
+++ b/net/asterisk10/files/patch-Makefile
@@ -1,5 +1,8 @@
---- Makefile.orig Wed Jun 14 11:59:17 2006
-+++ Makefile Wed Jun 14 13:54:57 2006
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -71,7 +74,7 @@
INCLUDE+=-Iinclude -I../include
-ASTCFLAGS+=-pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
-ASTCFLAGS+=$(OPTIMIZE)
-+ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
++ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE -DMAKE_VALGRIND_HAPPY
+#ASTCFLAGS+=$(OPTIMIZE)
ASTOBJ=-o asterisk
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index 9a8f636d9677..a5c0982ab70a 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
diff --git a/net/asterisk12/files/patch-Makefile b/net/asterisk12/files/patch-Makefile
index 879d944fd9e4..6b482dfc0268 100644
--- a/net/asterisk12/files/patch-Makefile
+++ b/net/asterisk12/files/patch-Makefile
@@ -1,5 +1,8 @@
---- Makefile.orig Wed Jun 14 11:59:17 2006
-+++ Makefile Wed Jun 14 13:54:57 2006
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -71,7 +74,7 @@
INCLUDE+=-Iinclude -I../include
-ASTCFLAGS+=-pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
-ASTCFLAGS+=$(OPTIMIZE)
-+ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
++ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE -DMAKE_VALGRIND_HAPPY
+#ASTCFLAGS+=$(OPTIMIZE)
ASTOBJ=-o asterisk
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 9a8f636d9677..a5c0982ab70a 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
diff --git a/net/asterisk14/files/patch-Makefile b/net/asterisk14/files/patch-Makefile
index 879d944fd9e4..6b482dfc0268 100644
--- a/net/asterisk14/files/patch-Makefile
+++ b/net/asterisk14/files/patch-Makefile
@@ -1,5 +1,8 @@
---- Makefile.orig Wed Jun 14 11:59:17 2006
-+++ Makefile Wed Jun 14 13:54:57 2006
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -71,7 +74,7 @@
INCLUDE+=-Iinclude -I../include
-ASTCFLAGS+=-pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
-ASTCFLAGS+=$(OPTIMIZE)
-+ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
++ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE -DMAKE_VALGRIND_HAPPY
+#ASTCFLAGS+=$(OPTIMIZE)
ASTOBJ=-o asterisk
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 9a8f636d9677..a5c0982ab70a 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
diff --git a/net/asterisk16/files/patch-Makefile b/net/asterisk16/files/patch-Makefile
index 879d944fd9e4..6b482dfc0268 100644
--- a/net/asterisk16/files/patch-Makefile
+++ b/net/asterisk16/files/patch-Makefile
@@ -1,5 +1,8 @@
---- Makefile.orig Wed Jun 14 11:59:17 2006
-+++ Makefile Wed Jun 14 13:54:57 2006
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -71,7 +74,7 @@
INCLUDE+=-Iinclude -I../include
-ASTCFLAGS+=-pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
-ASTCFLAGS+=$(OPTIMIZE)
-+ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE #-DMAKE_VALGRIND_HAPPY
++ASTCFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE -DMAKE_VALGRIND_HAPPY
+#ASTCFLAGS+=$(OPTIMIZE)
ASTOBJ=-o asterisk