aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-02-03 21:43:00 +0800
committermat <mat@FreeBSD.org>2014-02-03 21:43:00 +0800
commit4f0e297b38df54c4ae122d99b27e25bf92823761 (patch)
tree4e38010f977a062db3eba568e95f40a392356386 /net
parente75e14697402b326f7331686c0c08e0d2f455329 (diff)
downloadfreebsd-ports-gnome-4f0e297b38df54c4ae122d99b27e25bf92823761.tar.gz
freebsd-ports-gnome-4f0e297b38df54c4ae122d99b27e25bf92823761.tar.zst
freebsd-ports-gnome-4f0e297b38df54c4ae122d99b27e25bf92823761.zip
- Support staging
- Use new options helpers a bit Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/libnids/Makefile35
-rw-r--r--net/libnids/pkg-plist1
2 files changed, 10 insertions, 26 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 38f51c7d5d3a..e0a18267f981 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -17,27 +17,22 @@ OPTIONS_DEFINE= LIBNET10 LIBNET11 GLIB2
LIBNET10_DESC= Use libnet 1.0.x
LIBNET11_DESC= Use libnet 1.1.x
GLIB2_DESC= Use GLIB2 for multiprocessing support
+OPTIONS_SUB= yes
.if defined(WITH_LIBNET11)
OPTIONS_DEFAULT= LIBNET11 GLIB2
.else
OPTIONS_DEFAULT= LIBNET10 GLIB2
.endif
+GLIB2_USE= gnome=glib20
+GLIB2_CONFIGURE_ENABLE= libglib
+
WANT_GNOME= yes
USES= pkgconfig
GNU_CONFIGURE= yes
-MAN3= libnids.3
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MLIBNET10}
LIBNET_VERSION= 10
BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet${LIBNET_VERSION}
@@ -53,12 +48,6 @@ LIBNET_LIB= "`${LIBNET_CONFIG} --libs`"
CONFIGURE_ARGS+= --disable-libnet
.endif
-.if ${PORT_OPTIONS:MGLIB2}
-USE_GNOME+= glib20
-.else
-CONFIGURE_ARGS+= --disable-libglib
-.endif
-
post-patch:
@${REINPLACE_CMD} -Ee \
's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
@@ -66,16 +55,10 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/nids.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/src/libnids.a ${PREFIX}/lib
- ${INSTALL_MAN} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for i in README doc/*
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}/
-.endfor
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/src/nids.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/src/libnids.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKSRC}/src/libnids.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README doc/* ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/net/libnids/pkg-plist b/net/libnids/pkg-plist
index 4aba9c55228b..4ed3b3525145 100644
--- a/net/libnids/pkg-plist
+++ b/net/libnids/pkg-plist
@@ -1,5 +1,6 @@
include/nids.h
lib/libnids.a
+man/man3/libnids.3.gz
%%PORTDOCS%%%%DOCSDIR%%/API.html
%%PORTDOCS%%%%DOCSDIR%%/API.txt
%%PORTDOCS%%%%DOCSDIR%%/LINUX