aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-06-19 17:16:46 +0800
committerkris <kris@FreeBSD.org>2004-06-19 17:16:46 +0800
commit50b3208d254438668fa8680964b85e8f2af354c1 (patch)
tree6f759f157d704d58b67f71d17d4544e04d026ab8 /net
parent9398d7d7bbdf08a9b1a09ad00244f98229cfc5e0 (diff)
downloadfreebsd-ports-gnome-50b3208d254438668fa8680964b85e8f2af354c1.tar.gz
freebsd-ports-gnome-50b3208d254438668fa8680964b85e8f2af354c1.tar.zst
freebsd-ports-gnome-50b3208d254438668fa8680964b85e8f2af354c1.zip
BROKEN on amd64: Shared libraries must be compiled with -fPIC
Diffstat (limited to 'net')
-rw-r--r--net/callgen/Makefile8
-rw-r--r--net/callgen323/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/net/callgen/Makefile b/net/callgen/Makefile
index 0a1c5e80ab32..63c96ae919ab 100644
--- a/net/callgen/Makefile
+++ b/net/callgen/Makefile
@@ -24,7 +24,13 @@ THE_MACHTYPE= ${ARCH:S/i386/x86/}
PLIST_FILES= bin/callgen323
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/callgen323 ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/callgen323/Makefile b/net/callgen323/Makefile
index 0a1c5e80ab32..63c96ae919ab 100644
--- a/net/callgen323/Makefile
+++ b/net/callgen323/Makefile
@@ -24,7 +24,13 @@ THE_MACHTYPE= ${ARCH:S/i386/x86/}
PLIST_FILES= bin/callgen323
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/callgen323 ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>