aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2015-08-26 16:40:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2015-08-26 16:40:21 +0800
commit518a3533ee851ed63dbdac7bf2185be139447e45 (patch)
tree59a169c6f798c0252c4b537de681ebab693df7d2 /net
parentf5e960b642923548e67be95d72e95034b9835a61 (diff)
downloadfreebsd-ports-gnome-518a3533ee851ed63dbdac7bf2185be139447e45.tar.gz
freebsd-ports-gnome-518a3533ee851ed63dbdac7bf2185be139447e45.tar.zst
freebsd-ports-gnome-518a3533ee851ed63dbdac7bf2185be139447e45.zip
- Restore functionality of ICA_CERTS (was broken after r391627) [1]
- Adjust wfcmgr wrapper to run the now renamed configuration utility configmgr. Retain name to avoid possible namespace collision due to its generic name. - Make various scripts executable PR: 194900 [1] Submitted by: Helge Oldach <freebsd@oldach.net>
Diffstat (limited to 'net')
-rw-r--r--net/citrix_ica/Makefile14
-rw-r--r--net/citrix_ica/files/wfcmgr.in2
-rw-r--r--net/citrix_ica/pkg-plist50
3 files changed, 38 insertions, 28 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 69ed77d63307..b97da370f138 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -3,7 +3,7 @@
PORTNAME= citrix_ica
PORTVERSION= 13.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net comms linux
MASTER_SITES= #
DISTNAME= linuxx86-13.2.0.322243
@@ -26,6 +26,7 @@ CDIR= ${PREFIX}/ICAClient
CERTDIR= ${CDIR}/keystore/cacerts
PLIST_SUB= MOZILLA_HOME=${MOZILLA_HOME}
+
.if defined(ICA_CERTS)
PLIST_SUB+= HAVE_ICA_CERTS="" ICA_CERTS="${ICA_CERTS}" CERTDIR="${CERTDIR}"
.else
@@ -41,6 +42,14 @@ SUB_LIST= CDIR=${CDIR}
IGNORE=May not be redistributed due to licensing. Please visit http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-13-2.html accept their license and download ${DISTFILES} into ${DISTDIR}
.endif
+.if defined(ICA_CERTS)
+.for f in ${ICA_CERTS}
+PLIST_FILES+= ${CERTDIR}/${f}
+HASH_${f}!= openssl x509 -noout -hash -in ${DISTDIR}/${f}
+PLIST_FILES+= ${CERTDIR}/${HASH_${f}}.0
+.endfor
+.endif
+
pre-fetch:
.if defined(ICA_CERTS)
.for f in ${ICA_CERTS}
@@ -76,12 +85,13 @@ do-install:
${MKDIR} ${STAGEDIR}${CDIR}
${MKDIR} ${STAGEDIR}${CDIR}/config
cd ${WRKDIR}/linuxx86/linuxx86.cor/ && ${COPYTREE_SHARE} . ${STAGEDIR}${CDIR}
- cp ${WRKDIR}/setupwfc ${STAGEDIR}${CDIR}
+ ${CP} ${WRKDIR}/setupwfc ${STAGEDIR}${CDIR}
.if defined(ICA_CERTS)
${MKDIR} ${STAGEDIR}${CERTDIR}
.for f in ${ICA_CERTS}
${INSTALL_DATA} ${DISTDIR}/${f} ${STAGEDIR}${CERTDIR}
+ ${LN} -sf ${f} ${STAGEDIR}${CERTDIR}/$$(openssl x509 -noout -hash -in ${DISTDIR}/${f}).0
.endfor
.endif
diff --git a/net/citrix_ica/files/wfcmgr.in b/net/citrix_ica/files/wfcmgr.in
index 6c28ad601484..24bf9cf1ed1c 100644
--- a/net/citrix_ica/files/wfcmgr.in
+++ b/net/citrix_ica/files/wfcmgr.in
@@ -1,3 +1,3 @@
#!/bin/sh
export ICAROOT=%%CDIR%%
-exec $ICAROOT/wfcmgr
+exec $ICAROOT/util/configmgr
diff --git a/net/citrix_ica/pkg-plist b/net/citrix_ica/pkg-plist
index edebaa148550..b95e8836db93 100644
--- a/net/citrix_ica/pkg-plist
+++ b/net/citrix_ica/pkg-plist
@@ -472,31 +472,31 @@
%%WEBPLUGIN_DIR%%/usb/ctxusbd.rc
%%WEBPLUGIN_DIR%%/usb/ica-usb.rules
%%WEBPLUGIN_DIR%%/usb/usb.conf
-%%WEBPLUGIN_DIR%%/util/DeleteCompleteFlashCache.sh
-%%WEBPLUGIN_DIR%%/util/configmgr
-%%WEBPLUGIN_DIR%%/util/conncenter
-%%WEBPLUGIN_DIR%%/util/ctx_app_bind
-%%WEBPLUGIN_DIR%%/util/ctx_rehash
-%%WEBPLUGIN_DIR%%/util/echo_cmd
-%%WEBPLUGIN_DIR%%/util/gst_aud_play
-%%WEBPLUGIN_DIR%%/util/gst_aud_read
-%%WEBPLUGIN_DIR%%/util/gst_play
-%%WEBPLUGIN_DIR%%/util/gst_read
-%%WEBPLUGIN_DIR%%/util/hdxcheck.sh
-%%WEBPLUGIN_DIR%%/util/hinst
-%%WEBPLUGIN_DIR%%/util/icalicense.sh
-%%WEBPLUGIN_DIR%%/util/libgstflatstm.so
-%%WEBPLUGIN_DIR%%/util/lurdump
-%%WEBPLUGIN_DIR%%/util/new_store
-%%WEBPLUGIN_DIR%%/util/nslaunch
-%%WEBPLUGIN_DIR%%/util/pac.js
-%%WEBPLUGIN_DIR%%/util/pacexec
-%%WEBPLUGIN_DIR%%/util/pnabrowse
-%%WEBPLUGIN_DIR%%/util/pnabrowse_launch
-%%WEBPLUGIN_DIR%%/util/storebrowse
-%%WEBPLUGIN_DIR%%/util/sunraymac.sh
-%%WEBPLUGIN_DIR%%/util/what
-%%WEBPLUGIN_DIR%%/util/xcapture
+@(,,00555) %%WEBPLUGIN_DIR%%/util/DeleteCompleteFlashCache.sh
+@(,,00555) %%WEBPLUGIN_DIR%%/util/configmgr
+@(,,00555) %%WEBPLUGIN_DIR%%/util/conncenter
+@(,,00555) %%WEBPLUGIN_DIR%%/util/ctx_app_bind
+@(,,00555) %%WEBPLUGIN_DIR%%/util/ctx_rehash
+@(,,00555) %%WEBPLUGIN_DIR%%/util/echo_cmd
+@(,,00555) %%WEBPLUGIN_DIR%%/util/gst_aud_play
+@(,,00555) %%WEBPLUGIN_DIR%%/util/gst_aud_read
+@(,,00555) %%WEBPLUGIN_DIR%%/util/gst_play
+@(,,00555) %%WEBPLUGIN_DIR%%/util/gst_read
+@(,,00555) %%WEBPLUGIN_DIR%%/util/hdxcheck.sh
+@(,,00555) %%WEBPLUGIN_DIR%%/util/hinst
+@(,,00555) %%WEBPLUGIN_DIR%%/util/icalicense.sh
+@(,,00555) %%WEBPLUGIN_DIR%%/util/libgstflatstm.so
+@(,,00555) %%WEBPLUGIN_DIR%%/util/lurdump
+@(,,00555) %%WEBPLUGIN_DIR%%/util/new_store
+@(,,00555) %%WEBPLUGIN_DIR%%/util/nslaunch
+@(,,00555) %%WEBPLUGIN_DIR%%/util/pac.js
+@(,,00555) %%WEBPLUGIN_DIR%%/util/pacexec
+@(,,00555) %%WEBPLUGIN_DIR%%/util/pnabrowse
+@(,,00555) %%WEBPLUGIN_DIR%%/util/pnabrowse_launch
+@(,,00555) %%WEBPLUGIN_DIR%%/util/storebrowse
+@(,,00555) %%WEBPLUGIN_DIR%%/util/sunraymac.sh
+@(,,00555) %%WEBPLUGIN_DIR%%/util/what
+@(,,00555) %%WEBPLUGIN_DIR%%/util/xcapture
@(,,00555) %%WEBPLUGIN_DIR%%/wfica
bin/wfcmgr
bin/wfica