aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-10-25 10:28:44 +0800
committerswills <swills@FreeBSD.org>2013-10-25 10:28:44 +0800
commit526f3ed5b66ce9db370b01e87308542e68d39c1c (patch)
tree3950ac9487e3b2576d6e4738d157752a961d5b9a /net
parentf5099b80109d0eeb8ee4d4f224b13c32180d3a92 (diff)
downloadfreebsd-ports-gnome-526f3ed5b66ce9db370b01e87308542e68d39c1c.tar.gz
freebsd-ports-gnome-526f3ed5b66ce9db370b01e87308542e68d39c1c.tar.zst
freebsd-ports-gnome-526f3ed5b66ce9db370b01e87308542e68d39c1c.zip
A LDAP strategy for OmniAuth.
WWW: https://github.com/gitlabhq/omniauth-ldap PR: ports/182766 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-gitlab_omniauth-ldap/Makefile22
-rw-r--r--net/rubygem-gitlab_omniauth-ldap/distinfo2
-rw-r--r--net/rubygem-gitlab_omniauth-ldap/files/patch-gemspec11
-rw-r--r--net/rubygem-gitlab_omniauth-ldap/pkg-descr3
5 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 110856f4fd92..3c89da6df9e4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1030,6 +1030,7 @@
SUBDIR += rubygem-domain_name
SUBDIR += rubygem-dropbox-sdk
SUBDIR += rubygem-geoip
+ SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-http_parser.rb
SUBDIR += rubygem-httpauth
SUBDIR += rubygem-ipaddress
diff --git a/net/rubygem-gitlab_omniauth-ldap/Makefile b/net/rubygem-gitlab_omniauth-ldap/Makefile
new file mode 100644
index 000000000000..39c2f3b2864b
--- /dev/null
+++ b/net/rubygem-gitlab_omniauth-ldap/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= gitlab_omniauth-ldap
+PORTVERSION= 1.0.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A LDAP strategy for OmniAuth.
+
+RUN_DEPENDS= rubygem-net-ldap>=0.3.1:${PORTSDIR}/net/rubygem-net-ldap \
+ rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth \
+ rubygem-pyu-ruby-sasl>=0.0.3.1:${PORTSDIR}/security/rubygem-pyu-ruby-sasl \
+ rubygem-rubyntlm>=0.1.1:${PORTSDIR}/net/rubygem-rubyntlm
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitlab_omniauth-ldap/distinfo b/net/rubygem-gitlab_omniauth-ldap/distinfo
new file mode 100644
index 000000000000..b047098e53e6
--- /dev/null
+++ b/net/rubygem-gitlab_omniauth-ldap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/gitlab_omniauth-ldap-1.0.3.gem) = aaab9d9c192ae690a53972998af4ed29a6e08b467282f7aac88aa5e806983545
+SIZE (rubygem/gitlab_omniauth-ldap-1.0.3.gem) = 12288
diff --git a/net/rubygem-gitlab_omniauth-ldap/files/patch-gemspec b/net/rubygem-gitlab_omniauth-ldap/files/patch-gemspec
new file mode 100644
index 000000000000..de01589e0c54
--- /dev/null
+++ b/net/rubygem-gitlab_omniauth-ldap/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- gitlab_omniauth-ldap-1.0.3.gemspec.orig 2013-10-25 02:24:55.456068284 +0000
++++ gitlab_omniauth-ldap-1.0.3.gemspec 2013-10-25 02:25:06.863067558 +0000
+@@ -58,7 +58,7 @@
+ requirements:
+ - - ~>
+ - !ruby/object:Gem::Version
+- version: 0.1.1
++ version: 0.4.0
+ type: :runtime
+ prerelease: false
+ version_requirements: !ruby/object:Gem::Requirement
diff --git a/net/rubygem-gitlab_omniauth-ldap/pkg-descr b/net/rubygem-gitlab_omniauth-ldap/pkg-descr
new file mode 100644
index 000000000000..b04fa56389d8
--- /dev/null
+++ b/net/rubygem-gitlab_omniauth-ldap/pkg-descr
@@ -0,0 +1,3 @@
+A LDAP strategy for OmniAuth.
+
+WWW: https://github.com/gitlabhq/omniauth-ldap