aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-23 03:45:34 +0800
committerpawel <pawel@FreeBSD.org>2012-11-23 03:45:34 +0800
commit5bcda10e8b084ce6185eee9ef266714be9be406a (patch)
treed292d8ac91deab9d17db9101b62cc0b44d651830 /net
parent7b8b99e8e16cc51e1ef93201e40ec3a8a37a9194 (diff)
downloadfreebsd-ports-gnome-5bcda10e8b084ce6185eee9ef266714be9be406a.tar.gz
freebsd-ports-gnome-5bcda10e8b084ce6185eee9ef266714be9be406a.tar.zst
freebsd-ports-gnome-5bcda10e8b084ce6185eee9ef266714be9be406a.zip
- Update to version 0.1.1
PR: ports/170163 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/netembryo/Makefile32
-rw-r--r--net/netembryo/distinfo4
-rw-r--r--net/netembryo/pkg-plist6
3 files changed, 32 insertions, 10 deletions
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 46ad12ee9916..08a1c521c984 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -6,20 +6,40 @@
#
PORTNAME= netembryo
-PORTVERSION= 0.0.5
+PORTVERSION= 0.1.1
CATEGORIES= net
MASTER_SITES= http://lscube.org/files/downloads/netembryo/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A network abstraction library used by for feng, libnemesi, felix
+COMMENT= Network abstraction library used by for feng, libnemesi, felix
LICENSE= LGPL21
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+OPTIONS_DEFINE= OPENSSL
+OPTIONS_DEFAULT=OPENSSL
+
USE_BZIP2= yes
+USE_GNOME= glib20 gnomehack
+USE_PKGCONFIG= build
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
-USE_GNOME= gnomehack
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB}"
+.else
+CONFIGURE_ARGS+=--without-openssl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CPPFLAGS=|#CPPFLAGS| ; \
+ s|freebsd[0-9]|freebsd|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/net/netembryo/distinfo b/net/netembryo/distinfo
index c2d0f9cd926a..b2337ba6560b 100644
--- a/net/netembryo/distinfo
+++ b/net/netembryo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netembryo-0.0.5.tar.bz2) = 5ca8ac883d255335d3fa047c861ffc61e6c74b98843a3b1093c40ca41ecc986b
-SIZE (netembryo-0.0.5.tar.bz2) = 452744
+SHA256 (netembryo-0.1.1.tar.bz2) = b20c12f09e99f9c00efab3b9588457fd8a2fa6bb3ed26c35ada572c0b172a981
+SIZE (netembryo-0.1.1.tar.bz2) = 265851
diff --git a/net/netembryo/pkg-plist b/net/netembryo/pkg-plist
index 3349acb23fc3..760c410d71cf 100644
--- a/net/netembryo/pkg-plist
+++ b/net/netembryo/pkg-plist
@@ -1,9 +1,11 @@
+include/netembryo/rtsp.h
include/netembryo/url.h
-include/netembryo/rtsp_errors.h
include/netembryo/wsocket.h
+include/netembryo/wsocket-internal.h
lib/libnetembryo.a
lib/libnetembryo.la
lib/libnetembryo.so
-lib/libnetembryo.so.5
+lib/libnetembryo.so.9
libdata/pkgconfig/libnetembryo.pc
+libdata/pkgconfig/libnetembryo-sctp.pc
@dirrm include/netembryo